This project is read-only.

Blogengine 2.0 installation fails

Topics: ASP.NET 2.0
Feb 13, 2011 at 10:10 PM

I've been using Blogengine for years on 1and1 shared hosting.

I've just tried to upgrade to 2.0 from BE 1.6, which failed, and I then tried a completely clean install, into a clean directory, only the 2.0 files/folders downloaded directly, and after changing the write/modify for App_Data folder and turning on the application and viewing the URL, I get:

Server Error in '/ecosynth/blog' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Unrecognized configuration section system.serviceModel.

Source Error: 

Source File: E:\kunden\homepages\21\d116931462\ecosynth\blog\web.config    Line: 45 

Line 43:     <add key="BlogEngine.HardMinify" value="blog.js,widget.js,WebResource.axd"/>
Line 44:   </appSettings>
Line 45:   <system.serviceModel>
Line 46:     <services>
Line 47:       <service behaviorConfiguration="AuthenticationServiceBehaviors"

Version Information: Microsoft .NET Framework Version:2.0.50727.3615; ASP.NET Version:2.0.50727.3614


NOTE That I still have BE 1.6 blogs running in other directories...

Thank you for any help you can offer in getting this running again!

Feb 18, 2011 at 1:46 PM

Be sure that your config version matches the .Net framework you targeting. I'm not sure that system.serviceModel was available in Microsoft .NET Framework Version:2.0.50727.3615. So increase the version in IIS to 4.0 integrated. THere are a bunch of configs in the settings folder to help with this.

Feb 18, 2011 at 2:37 PM

Actually- this is on a hosted server- 1and1- so can't alter the .net framework.

Does this mean I can't use 2.0 and must stick with 1.6?

Thank you for your advice on this!

Feb 18, 2011 at 3:39 PM

Even on hosted services you should be able to change the target framework. You might need to contact support if the sites' control panel doesn't expose functionality to change it. 

Feb 18, 2011 at 3:58 PM

I just called 1and1 tech support- they say that they cannot change to another .NET framework - it is "fixed at 2.0".  Very frustrating!

I suppose that kills this chance to upgrade BE to 2.0?

Another 1and1 disappointment?....

Feb 18, 2011 at 5:22 PM

A deal breaker IMO. 

I use arvixe and so far am happy. I can switch the framework version from 2.0 through 4.0 integrated. I can also manage permissions and create virtual directories. 

Feb 18, 2011 at 9:17 PM


Mar 6, 2011 at 6:47 PM

A hacked fix!

I've just commented out the failed System.ServiceModel section in Web.Config:

      <service behaviorConfiguration="AuthenticationServiceBehaviors"        name="System.Web.ApplicationServices.AuthenticationService">  
     <endpoint binding="basicHttpBinding" contract="System.Web.ApplicationServices.AuthenticationService" />  
 <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />    
 <behavior name="AuthenticationServiceBehaviors">  
       <serviceMetadata httpGetEnabled="true" /> 

And now it works!  I am wondering if this is ok, or whether this is going to cause other problems?

So far, everything seems ok.


<!--system.serviceModel> <services> <service behaviorConfiguration="AuthenticationServiceBehaviors" name="System.Web.ApplicationServices.AuthenticationService"> <endpoint binding="basicHttpBinding" contract="System.Web.ApplicationServices.AuthenticationService" /> </service> </services> <serviceHostingEnvironment aspNetCompatibilityEnabled="true" /> <behaviors> <serviceBehaviors> <behavior name="AuthenticationServiceBehaviors"> <serviceMetadata httpGetEnabled="true" /> </behavior> </serviceBehaviors> </behaviors> </system.serviceModel-->
Mar 7, 2011 at 3:05 PM

Oh no- a bug- I am guessing this is introduced by my removal of the service.model section.

For some reason, comments are not being allowed- I can type them in, but get no change when I press the "save comment" button.

Does this make sense?

Any thoughts on getting this working?  This is for two blogs:

Thank you for any help you can offer!