This project is read-only.

Content pages take minutes to load

Topics: ASP.NET 2.0
Feb 14, 2011 at 9:20 PM
Edited Feb 14, 2011 at 9:22 PM

I suspect that either a security patch or removing SQL has had a serious adverse affect on BlogEngine. I am running BlogEngine 1.6.1 and pages can take over 5 minutes to load. The system was working properly initially (a few seconds to load the page) and I wasn't using it for several months - now it is pathetic.  When pages eventually load, everything is fine

ASP.NET seems to be running properly as the settings pages load properly.

I thought I am using the default BlogEngine XML rather than SQL but if the system is looking for SQL, it will of course time out and then work properly.

Server - Win2008 Advanced in a VM, adequate RAM and disk.

I have disabled unnecessary extensions, removed compress etc. but am now at my wits end with what to do.

Further reason that I suspect it is a database issue - posting content also takes minutes.  I would prefer not to have to reinstall SQL if at all possible.

The site is


Feb 14, 2011 at 9:44 PM

If you try to access your "robots" file ( you'll run into same issue.

This file is plain text delivered by your web server, not related to BlogEngine or database at all. I would guess something is wrong with connection to your server.

Feb 15, 2011 at 12:33 AM

I just tried it and it loaded very quickly if that helps.

Feb 15, 2011 at 1:49 AM
Edited Feb 16, 2011 at 8:32 AM

Thanks guys - it seems there was some issue with the VM. Rebuilt it and it flies. Now that it's at the network and OS layer I can work on it.

I was wrong!!  Not that simple!

Feb 15, 2011 at 6:48 PM
Edited Feb 16, 2011 at 8:33 AM

Unfortunately BlogEngine ran well for a few hours and then slowed down to a crawl again. Network and OS seems OK, although I need to fully test the ASP environment with another application. Another interesting thing is that I cannot update content. It takes a long time then times out with a server error 500.  Am I being hacked?


I have tried a reinstall of BlogEngine from backup and it looks like a problem with ASP.  Any ideas?