rtur BeWap20 Unknown server tag 'blog:PostPager'

Topics: Business Logic Layer
Feb 22, 2011 at 10:41 PM

While working on this problem http://blogengine.codeplex.com/discussions/247141 I discovered http://blogengine.codeplex.com/SourceControl/network/Forks/rtur/BeWap20 

Figured I would work on that as I belive the benifits of a web application project are superior to a web site project. ?Right? More secure deploy, fewer files. I'm hoping the web application will allow me to update just the changed files needed to run the application. Unfortunatley the host I'm using only supports ftp at this time.

Are there any plans to keep a web application project version supported? And perhaps include the source to build the entire project?

I get this error when I run the project.

Line 8: 
Line 9:  <div style="clear:both; display:block">
Line 10:   <blog:PostPager ID="pager1" runat="server"></blog:PostPager>
Line 11: </div>

 With the project running I can manually navigate to Account/login.aspx and other pages like /admin/Posts/Posts.aspx when I click on a valid post I get

 
Line 75: 	  <label for="cbNotify" style="width:auto;float:none;display:inline;padding-left:5px"><%=Resources.labels.notifyOnNewComments %></label><br />
Line 76:  
Line 77: 	  <blog:RecaptchaControl ID="recaptcha" runat="server" TabIndex="8" />
Line 78:      <blog:SimpleCaptchaControl ID="simplecaptcha" runat="server" TabIndex="8" />
Line 79: 
 
Perhaps something with Theme? Manually navigating to the settings page I made sure to try Standard and Mobile for the main theme with the same results.
In Solution Explorer BlogEngine.Core.pdb and BlogEngine.Core.XML have yellow triangles with exclamation point. Not a critical error just a warning? 


Coordinator
Feb 23, 2011 at 2:12 AM

Just downloaded this fork and run it in VS. These two DLLs can be safely deleted, they used for debug and will be re-generated if needed. Not sure why you getting this post pager errors, works perfect for me. Check if you have PostMenu.cs in the Custom_Code folder and if you see any difference between this file and other user controls in that same folder. Also, make sure you have this in web.config :

<add assembly="BlogEngine.Net" namespace="App_Code.Controls" tagPrefix="blog"/>

Feb 23, 2011 at 2:46 AM

:-) Cool. Works now.

I had copied the /setup/SQLServer/SQLServerWeb.Config to /Web.Config. Anything else that might be missing from the sql version of web.config?

Thanks for the help!  - jeffa

 

Aug 19, 2012 at 4:22 PM
Edited Aug 19, 2012 at 4:33 PM

@rtur, I was getting the same error:

Unknown server tag 'blog:PostPager'

When I updated the Web.config with:

<add assembly="BlogEngine.Net" namespace="App_Code.Controls" tagPrefix="blog"/>

Now I'm getting:

Could not load file or assembly 'BlogEngine.Net' or one of its dependencies. The system cannot find the file specified.