Twitter widget no longer working.

Topics: Controls, Themes
Feb 25, 2011 at 4:58 PM

I hopped on to my blog today and noticed that the last tweet the twitter widget was displaying was on Feb 14th. I made no changes and the URLs for the account and RSS feed are correct. I checked out the xml file the widgets creates and the 14th is the last post in there also. I enabled the logging so i can check back tomorrow and see if anything was logged. Has anyone else experienced a sudden stop like this with this widget? any help is apreciated!


Feb 25, 2011 at 9:41 PM

I think that old data is coming from twitter_feeds.xml in the App_Data directory.  If you refresh the page, do you get the new tweets?

The tweets are retrieved asynchronously and stored in cache memory for XX number of minutes.  It used to be that if the blog hadn't been visited for a while, when you would pull it up, there would be no tweets in memory and you wouldn't see any tweets on the page, until after a few seconds have passed and you refresh the page.  That was changed to store the last batch of tweets in the XML file, so in this scenario, those older tweets would be displayed while the latest tweets are fetched from Twitter.  The purpose of this is it's probably better to show a few old tweets rather than show nothing while the latest tweets are being retrieved.

If it's working correctly, then if you see the old tweets, wait a few seconds, refresh the page, and you should see the new tweets.

Mar 15, 2011 at 3:57 PM

Hello and thank you for the help.


As you directed above i refreshed my blog to see if the new tweets populated and it did not. the old info was still being displayed. i then went into the twitter_feeds.xml file and cleared out the saved tweets in hope the new ones would be pushed out. This also did not work. I have also removed and then re-added the twitter widget but still no tweets.  would i maybe have to re-install the widget?

Mar 15, 2011 at 4:46 PM

You can try twitter widgets from here - worked fine with be 2.0 in my testing.