A couple of new themes

Topics: Themes
Feb 25, 2011 at 7:46 PM
Edited Mar 29, 2011 at 3:35 PM

Hi all

I want to share a few themes with you, they're free!
The first one I have called Blue Line, there is no deeper meaning about the name in addition to it has a blue line

Blogengine blog theme - Blueline

Blueline.rar (22,07 kb)

BlueHorizon with skies

BlueHorizon.rar (324,15 kb)

I have a few themes more on the way, but until then they can be seen to WordPress on my blog with wordpress themes>Hope it's okay to make links to them here on the forum, I have tried to upload them through http://www.blogenginetheme.com/ but I've got no response

Coordinator
Feb 25, 2011 at 11:13 PM

Very nice, I've added both to the gallery. It is our secret app store, still in beta and nobody knows about it so you won't get lots of downloads and hits just yet. If you create account there let me know and I'll transfer ownership to you.

Feb 27, 2011 at 9:37 AM

Thanks that's super, I've created a profile on the website. And can see that they have been downloaded a couple of times already.

The next theme I´m gonna made will be the one that is called Black Night, so time will tell whether there are anyone who will use it

Coordinator
Feb 27, 2011 at 3:58 PM

I've set you as an owner.

Feb 27, 2011 at 5:15 PM

Thx :o)

Feb 28, 2011 at 7:13 PM
Edited Mar 29, 2011 at 3:36 PM

Hi

 

I can´t upload any new themes, and i when i tried to delete one of  the bluehorizon it deleted them both.
And here is the new one.....

Blacknight Theme

Blogengine blog theme - Blacknight

Blacknight.rar (19,77 kb)

Coordinator
Mar 1, 2011 at 4:11 PM

Oh I see, I was wondering why one of the themes gone. We have issue with packages displaying as dups even though repository has only one record, so it deleted that single record. No worries. We are in process moving to different host, way to many issues with this one. Once there, I'll make sure all 3 themes are in the gallery. Domain remains the same, so you can check back on it in a few days. And you can't upload because you need to package theme as NuGet package, see gallery home page for instructions.

Apr 1, 2011 at 4:42 PM

Yet another theme :)

Gray and Gold ver. 2.0

Black Night Theme for Blogengine.net blogs

 

There are 2 versions of this theme one with a dropdowm menu control made by Jonah Carneskog, and one with the normal navigation.
If you wanna use the version with the dropdown menu remember to set enableSessionState="true" in web.config in order to enable session variables. Or else it wont work!!!

Download it here Gray and Gold
Test is live here Gray and Gold demo

The themes Blacknight and Bluehorizon is also updated with 2 versions, and some better graphic.

And i have 3 or 4 themes more one the way ;)
Blackskyline

Btw. does anyone know how i can get at link on this page.?? http://www.dotnetblogengine.net/page/Themes.aspx

Apr 1, 2011 at 4:49 PM

I like your themes especially the Gray and Gold, I tried the download link but can't seem to find where to download it.  I would really like this theme in a nice muted desert theme color.

Thanks

Coordinator
Apr 1, 2011 at 4:57 PM

Sweet, I'll move them all to the gallery this weekend. There is nice new "preview" function so people can check them out in all glory :)

Apr 1, 2011 at 5:07 PM

The gallery is now my favorite site to check out BE stuff, great job.

Coordinator
Apr 1, 2011 at 5:09 PM

I think once we get direct integration into admin panel for the next version, its going to be even better.

Apr 1, 2011 at 7:32 PM

@Jerry you can download it here http://w3blog.dk/download-blogengine-themes/gray-and-gold

@rtur is it this you mean.??

Black Night Theme for Blogengine.net blogs

Apr 1, 2011 at 8:06 PM
Edited Apr 1, 2011 at 8:18 PM

Thank you, I think you need to change the text. The WordPress through me off, will these also be available on the new Blogengine Gallery?

Download wordpress theme Gray and Gold with menu
Download wordpress theme Gray and Gold  no menu

Edit:

This link returns 404 error.

Download wordpress theme Gray and Gold with menu

Apr 1, 2011 at 8:48 PM

I changed the title of the blog, so there are both wordpress and blog engine in it.

The link is updated, and should work but if you still get the 404 page then try ctrl+f5 that should do it. ;o)
And the "wordpress ..." is changed, you gotta love gut and paste......
It was/is my plan that they will be there also.


have a nice weekend.!

Apr 1, 2011 at 10:12 PM

I get this error when trying to use either with the menu or without theme.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. 

Compiler Error Message: CS1061: 'BlogEngine.Core.BlogSettings' does not contain a definition for 'FileExtension' and no extension method 'FileExtension' accepting a first argument of type 'BlogEngine.Core.BlogSettings' could be found (are you missing a using directive or an assembly reference?)

Source Error:

 
Line 313:										if (HasParentChildren)
Line 314:										{
Line 315:											string hrefCat =Utils.RelativeWebRoot + "category/" + Utils.RemoveIllegalCharacters(CurrentParent) + BlogSettings.Instance.FileExtension;	
Line 316:											sb.AppendFormat("<li class=\"top\"><a href=\"{0}\" class=\"{2}\">{1}</a>\n", hrefCat, CurrentParent,CSSClassTop);
Line 317:		

Apr 1, 2011 at 10:31 PM

It seems issue is not related to the theme. Try to rebuild the solution again and then try again.

Meanwhile I have uploaded two-three most wanted blogEngine themes on my site by personally checking and validating them. Also i have updated them with latest build on - http://themes.blogenginewall.com

Try themes from here and let me know if you get some issues. I am always available for support.

Thanks have a gr8 weekend :)

Apr 1, 2011 at 10:41 PM
Edited Apr 1, 2011 at 10:42 PM

I believe it is theme related as all other themes work great.

I have been using the original PortraitPress for a couple of years on my hiking club webisite with some changes, see http://sahcinfo.org

I am now in the process of using the same updated theme downloaded from your site, how do I get the gallery to work, thanks.

Apr 2, 2011 at 12:34 AM

I am glad that you like it.

Actually gallery user control is completely separate from theme. I have just write one post on how to install it and how to use it. - BlogEngine Gallery UserControl Refreshed

I hope it will help you.

 

Apr 2, 2011 at 8:11 AM

In the version with out the menu controll, delete the file "JC_MenuControl.ascx" it should fix the problem.!

I should had deleted it, but forgot it....

The problem occurs when the menu control is making your list of categories, but why it occurs I can´t say.
But post your list, then i´ll see if I can find problem.?

Have a nice weekend :o)

Apr 2, 2011 at 11:29 AM

I also had to delete <%@ Register Src="JC_MenuControl.ascx" TagName="JC_MenuControl1" TagPrefix="uc3" %> from the site.master.

I only have these catagories 

<input id="fb0cace8-cdee-436b-92ad-e39b9a059f18" type="checkbox" /><label>eBulletin</label>
<input id="ba160ed4-99b1-41ab-a33a-70908d911280" type="checkbox" /><label>eHike</label>
<input id="05366547-5c8e-4643-ad94-377d3f809ab8" type="checkbox" /><label>General</label>
<input id="1d330253-c5aa-436b-aaaa-be6b57f4a533" type="checkbox" /><label>Hike</label>

Apr 2, 2011 at 12:10 PM

Yes of course that one also.

I can get it to crash if I mess with catagory parents.
For example if I put "General" to be parents to "Hike" and "Hike" to be parents to "eHike" which in turn are parents to "eBulletin".
This will work, but if i set "Hike", "eHike" og "Ebulletin" to be the parent to "General", it crashes.

But i´ll work one it som more.! :o)

Apr 3, 2011 at 6:51 PM

The site.master.cs needs to be changed to the following per the new release of BE.

 if (Page.User.Identity.IsAuthenticated)
        {
            aLogin.InnerText = Resources.labels.logoff;
            aLogin.HRef = BlogEngine.Core.Utils.RelativeWebRoot + "Account/login.aspx?logoff";
        }
        else
        {
            aLogin.HRef = BlogEngine.Core.Utils.RelativeWebRoot + "Account/login.aspx";
            aLogin.InnerText = Resources.labels.login;
        }
    }

Apr 3, 2011 at 7:18 PM

I´ll update them all tomorrow and post when i´m done :)

Apr 4, 2011 at 8:50 AM

They are all updatet and working again.
I´ve made a post on the blog about upgrading or downgrading the themes, so that ppl can use them no matter which version they use.

Updating your theme

Apr 6, 2011 at 4:49 PM

 

This code is not working in Grayandgold-no-menu, any ideas.  I have several pages that I need to remove the sidebar on.  I really like this theme and want to use it but I need pages without the sidebar.

 

public partial class Ehike_schedule : System.Web.UI.Page
{
    protected void Page_Load(object sender, EventArgs e)
    {
        PlaceHolder phSidebar = Master.FindControl("phSidebar") as PlaceHolder;
        if (phSidebar != null)
            phSidebar.Visible = false;
    }

}
Apr 6, 2011 at 6:22 PM

Got the above working, having an issue with the css on a few pages without the sidebar, I need a wider width.

Apr 6, 2011 at 6:23 PM
Edited Apr 6, 2011 at 6:51 PM

Edit

Apr 6, 2011 at 6:47 PM
Edited Apr 6, 2011 at 6:52 PM

Hmm wrong answer..

The code in site.master should be like this

 

 

<asp:PlaceHolder ID="phSidebar" runat="server">
<div class="right" id="sidebar">
    <div id="sidebar_content">
        <blog:WidgetZone runat="server" ID="rightzone" />
         <br /><a runat="server" id="aLogin" />
    </div>
</div>
</asp:PlaceHolder>

and at line 367 replace #main_content with this

#main_content
{
    margin: 0 0 0 30px;
    padding: 10px 20px 10px 10px;
    background: transparent;
    border-right: 1px solid #ccc;
    width:630px;
    float:left;
}
    form.noSidebar #main_content{
    width:900px;
    border-right:none;
}

that will do it. :o)

NB: you can set width: to 100%

 

Apr 6, 2011 at 9:49 PM

I was close, I didn't have 

 border-right:none;

If you have time, please take a look at this link, it did look better here with old theme, any help would be appreciated.  This is my last issue with using Grayandblack-no-menu theme.
Thanks
Apr 7, 2011 at 9:34 PM

 

Try this temp login to the link below.

jerrydean

6549a

 I went ahead and switched themes to try it out, I would still like to have this gridview a look better, I guess I need some css to go in this code to improve it, specific only to a table or gridview.

 

 

form.noSidebar #main_content
{ 
    width: 100%;
    border-right: none;

}

 

 
Apr 8, 2011 at 8:17 AM

I have make a theme for my blog http://cyclopedia.name/ 

I would like to share with anybody who appreciate it.

Apr 8, 2011 at 8:57 AM

Hey Jerry

I can´t see that page, need a login to do that. J

Fra: jerrysdean43 [email removed]
Sendt: 7. april 2011 23:34
Til: jimmy@webiq.dk
Emne: Re: A couple of new themes [blogengine:247619]

From: jerrysdean43

Try this temp login to the link below.

jerrydean

6549a

I went ahead and switched themes to try it out, I would still like to have this gridview a look better, I guess I need some css to go in this code to improve it, specific only to a table or gridview.

form.noSidebar #main_content
{ 
    width: 100%;
    border-right: none;
 
}

Apr 8, 2011 at 11:07 AM

I gave you this temp login, thanks

jerrydean

6549a

Apr 8, 2011 at 12:15 PM
Edited Apr 8, 2011 at 12:18 PM

Hey

 

This should to it. :O 

 

.alternate

{

background-color:#e6e3e1;

}

#main tr th,

#main thead th {

background-color:#342e2b;

color:#C69028;

font-size: 12px;

font-weight: bold;

line-height: 18px;

padding: 9px 24px;

}

#main tr td {

border-top: 1px solid #e7e7e7;

padding: 6px 24px;

}

 

Black Night Theme for Blogengine.net blogs

Apr 8, 2011 at 2:29 PM
Edited Apr 8, 2011 at 3:07 PM

Is this correct, not looking right to me: Thanks

alternate:

{

background-color:#e6e3e1;

}

#main tr th,

#main thead th {

background-color:#342e2b;

color:#C69028;

font-size: 12px;

font-weight: bold;

line-height: 18px;

padding: 9px 24px;

}

#main tr td {

border-top: 1px solid #e7e7e7;

padding: 6px 24px;

}

Apr 8, 2011 at 3:33 PM

Yes that is correct.

But you might wanna change the width setting that´s 900%

Apr 8, 2011 at 4:08 PM

The alternate color rows are not working for me.

Apr 8, 2011 at 5:13 PM

That´s because it´s a gridview and not a table, you need to add "<AlternatingRowStyle CssClass="alternate" />" to the gridview.

Apr 8, 2011 at 5:34 PM

Your good, thanks for the theme and your help.

Apr 10, 2011 at 12:33 AM

FYI, the latest theme preview does not work, grayandgold-no-menu, I get a lot of weird characters.

Apr 10, 2011 at 5:41 PM
Edited Apr 11, 2011 at 8:58 AM

I don´t know why your are getting them og dnbgallery, men I get them if I preview the one with menu.
But I´ll find out why.

It might be the menu that is the cause to it.!

 

*Update..

It is the menu version that fails, and it is because of the menu....

Apr 13, 2011 at 7:27 PM

Help please!

I have discovered that my ajax calendar controls are picking up the table with no sidebar pages css and not rendering properly, I think it is the padding. so you know some code I can put with the control to not use the themes css or maybe another css class that does not use the special css that you have provided  fro me?  You can check what is happening here in the date field.  Thank you very much.

http://www.sahcinfo.org/hikingforms/hikeresults1.aspx

Apr 14, 2011 at 5:11 AM

The Ajax calendar extender does not seem to work with this theme, (Gray and gold-no-menu), see link, date field. Thanks, it does not work on pages with or without the sidebar.

http://www.sahcinfo.org/hikingforms/hikeresults1.aspx    no sidebar

http://www.sahcinfo.org/HikingForms/Comingevent.aspx    with sidebar

Apr 14, 2011 at 6:26 AM

Hi

 

This is what you need to do.

1) Change <div Id="main_content"> to <div class="main_content"> in the site.master.cs

2) Delete the table css style #main .........

3) insert this instead

.main_content tr th,
.main_content thead th {
    color: #f6aa16;
    font-size: 12px;
    font-weight: bold;
    line-height: 18px;
    padding: 9px 24px;
}
.main_content tr td {
    border-top: 1px solid #e7e7e7;
    padding: 6px 24px;
}

This will make the css styles on the datepicker work.

Apr 14, 2011 at 6:49 AM
Edited Apr 14, 2011 at 6:53 AM

Thanks but I ran into issues, I assume you meant the site.master and not the .cs file, I made the changes above and the calendar extender still did not work and it wiped out the sidebar on all the pages.

I still need this code I believe for the pages without the sidebar that contains gridviews.

.alternate

{

background-color:#e6e3e1;

}

#main tr th,

#main thead th {

background-color:#342e2b;

color:#C69028;

font-size: 12px;

font-weight: bold;

line-height: 18px;

padding: 9px 24px;

}
Apr 14, 2011 at 7:34 AM

Sorry forgot to say that you also has to change #main_content in the css file to .main_content

By doing this you can have different styles on tables.


Apr 14, 2011 at 1:14 PM

I am sorry to be such a dunce at this but can you show me exactly what this section should be so the calendar extender will work and my gridviews will work on my pages without the sidebar. Thank you for your patience and help with this.

/*----------------------------
Main Left
----------------------------*/
#main {
	
	margin: 0 auto;
	width: 970px;
	padding-top:30px;
	
}
#main_content
{
	margin: 0 0 0 30px;
	padding: 10px 20px 10px 10px;
	background: transparent;
	border-right: 1px solid #ccc;
	width:630px;
	float:left;
}

form.noSidebar #main_content
{ 
    width: 900px;
    border-right: none;
 }  

.alternate

{

background-color:#e6e3e1;

}

#main tr th,

#main thead th {

background-color:#342e2b;

color:#C69028;

font-size: 12px;

font-weight: bold;

line-height: 18px;

padding: 9px 24px;

}

#main tr td {

border-top: 1px solid #e7e7e7;

padding: 6px 24px;

}

Apr 14, 2011 at 2:20 PM

In the master edit from

 

<div id="main_content">
<blog:SearchOnSearch ID="SearchOnSearch1" runat="server" MaxResults="3" Headline="You searched for" Text="The following results include what you were looking at" />
<asp:ContentPlaceHolder ID="cphBody" runat="server" />

 

To

 

<div class="main_content">
<blog:SearchOnSearch ID="SearchOnSearch1" runat="server" MaxResults="3" Headline="You searched for" Text="The following results include what you were looking at" />
<asp:ContentPlaceHolder ID="cphBody" runat="server" />

 

And use this

 

/*
Main Left
--------------------------------------------------------*/
#main {
   
    margin: 0 auto;
    width: 970px;
    padding-top:30px;
   
}
.main_content
{
    margin: 0 0 0 30px;
    padding: 10px 20px 10px 10px;
    background: transparent;
    border-right: 1px solid #ccc;
    width:630px;
    float:left;
}

form.noSidebar #main_content
{ 
    width: 900px;
    border-right: none;
 }  

/* Table
-------------------------------------------------------------- */
.alternate
{
    background-color:#e6e3e1;
}
.main_content tr th,
.main_content thead th {
    background-color:#342e2b;
    color:#C69028;
    font-size: 12px;
    font-weight: bold;
    line-height: 18px;
    padding: 9px 24px;
}
.main_content tr td {
    border-top: 1px solid #e7e7e7;
    padding: 6px 24px;
}

/* Table
-------------------------------------------------------------- */
.alternate
{
	background-color:#e6e3e1;
}
.table tr th,
.table thead th {
	background-color:#C69028;
	color:#342e2b;
	font-size: 12px;
	font-weight: bold;
	line-height: 18px;
	padding: 9px 24px;
}
.table tr td {
	border-top: 1px solid #e7e7e7;
	padding: 6px 24px;
}

This will style tables in the main_content / main, but will still allow you to style another tabels as you want.
To test it duplicate the table style call it .table and switch bg-color and color.
Then edit a post and insert this

<h2>List Type Tests</h2>
<table>
<tbody>
<tr>
<th>Title</th><th class="views">Views</th><th>&nbsp;</th>
</tr>
<tr class="alternate">
<td class="label"><a href="http://blogengine.codeplex.com/discussions/247619">Themes</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
<tr>
<td class="label"><a href="http://wordpress.com/">Wordpress</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
<tr class="alternate">
<td class="label"><a href="http://w3blog.dk/">Bloegengine.net themes</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
<tr>
<td class="label"><a href="http://google.com">Google</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
</tbody>
</table>

<table class="table">
<tbody>
<tr>
<th>Title</th><th class="views">Views</th><th>&nbsp;</th>
</tr>
<tr class="alternate">
<td class="label"><a href="http://blogengine.codeplex.com/discussions/247619">Themes</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
<tr>
<td class="label"><a href="http://wordpress.com/">Wordpress</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
<tr class="alternate">
<td class="label"><a href="http://w3blog.dk/">Bloegengine.net themes</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
<tr>
<td class="label"><a href="http://google.com">Google</a></td>
<td class="views">1</td>
<td class="more">More</td>
</tr>
</tbody>
</table>



Apr 14, 2011 at 2:34 PM
Edited Apr 14, 2011 at 3:12 PM

I made the change above and the calendar extender still does not work correctely and now there is a vertical line on the no sidebar pages, see here:

http://www.sahcinfo.org/hikingforms/hikeresults1.aspx

Edit:

It works and looks great locally, it is on the server that the issues are?

I love this theme but I need to get it working to use it,  the natives are restless and complaining about the calendar extender when trying to use the hiking forms.

I really appreciate your patience and help with this issue but I may have to revert back to my old theme if we cannot solve the problem, I feel bad about taking up so much of your time.

Apr 14, 2011 at 3:35 PM

Have you changed the nosidebar style

form.noSidebar #main_content

{ 
width: 100%;
border-right: none;
 }
Into
form.noSidebar .main_content

{
width: 100%;
border-right: none;
}
Apr 14, 2011 at 4:32 PM

Thanks, that took care of the vertical line, but the calendar extender still does not render correctly.

Apr 14, 2011 at 5:30 PM

Try a Ctrl+f5 to refresh the cache

It´s working fine in ie and ff here

Apr 14, 2011 at 5:45 PM
Edited Apr 14, 2011 at 5:59 PM

I refreshed in Chrome and FF and it still does not render properly, nor does it work for other members, only show sun and mon for me.

Thanks again for all your generous help, for the time being I had to revert back to my PortraitPress theme, we have too many hikes being submitted and the guides need the calendar extender.

The curious issue I have is why would it display correctly locally but not on the server,  I checked the bin folder and all the files match.

Apr 14, 2011 at 7:08 PM

Try deleting all the files on the server, and then load the page without it this will of course not work.
But i just might delete the cache files that are one the server.

It has to be somthing like that, it worked for me in ff and ie.

Apr 14, 2011 at 8:57 PM

Sorry but I am not deleting all the files on the server, I cannot afford to have the website down, too many hiking members accessing it.  

Sorry to say but I had to revert back to the old theme, it works without any issues.  

Thanks you very much for your time and efforts.

Sep 19, 2011 at 11:54 PM

Hi

is there a solution for this topic because i'm still got this error

 

Line 313: if (HasParentChildren)
Line 314: {

Line 315: string hrefCat =Utils.RelativeWebRoot + “category/” + Utils.RemoveIllegalCharacters(CurrentParent) + BlogSettings.Instance.FileExtension;
Line 316: sb.AppendFormat(“{1}\n”, hrefCat, CurrentParent,CSSClassTop);
Line 317:

i've allso used the update files

TIA