This project is read-only.

js.axd timeout ? can't find solution

Topics: ASP.NET 2.0
Feb 28, 2011 at 12:10 AM
Edited Feb 28, 2011 at 12:53 AM


I ran in to this problem today, on a fresh installed Windows Server 2008 r2 machine.

All updates are installed, MSSQL 2008 r2 Express and Umbraco 4.5.x Sites running fine (.net 3.5 version)

I'v tryed reinstalling .net framework (both x86 and x64) , new machineKey and everything else i found using google :(

BE 2.0 running, but i halts for 30+ sec's on every page load, and it's a clean install 
From Event log: 


Event code: 3005 
Event message: An unhandled exception has occurred. 
Event time: 27-02-2011 23:54:09 
Event time (UTC): 27-02-2011 22:54:09 
Event ID: 90e3426fd9584949985f8f369c3b7cad 
Event sequence: 44 
Event occurrence: 9 
Event detail code: 0 
Application information: 
    Application domain: /LM/W3SVC/7/ROOT-1-129433197906093750 
    Trust level: Full 
    Application Virtual Path: / 
    Application Path: D:\sites\\httpdocs\ 
    Machine name: PRIME 
Process information: 
    Process ID: 2316 
    Process name: w3wp.exe 
    Account name: IIS APPPOOL\projectblog 
Exception information: 
    Exception type: WebException 
    Exception message: The operation has timed out 
Request information: 
    Request URL: 23:54:09aAn unhandled exception has occurred.
fAn unhandled exception has unhandled exception has occurred.f
WebResource.axd27-02-2011 23:54:09fd27-02-2011 23:54:09ds9CssEdDB3wvd9XpVGkzBLBGngvALZ5D4qU0-lk_Vrk8vO8ArPkfhWChZyt6pzLe_IB9YVsOYYFxLgXLwWlzvV6UhLc1IIS
APPPOOL\projectblogamp27-02-2011 23:54:09bt27-02-2011 23:54:09d634245226248165742 Request path: /js.axd User host address: xx.xx.xx.xx User: Is authenticated: False Authentication Type: Thread account name: IIS APPPOOL\projectblog Thread information: Thread ID: 7 Thread account name: IIS APPPOOL\projectblog Is impersonating: False Stack trace: at System.Net.HttpWebRequest.GetResponse() at BlogEngine.Core.RemoteFile.GetWebResponse() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\RemoteFile.cs:line 67 at BlogEngine.Core.RemoteFile.GetFileAsString() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\RemoteFile.cs:line 114 at BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler.RetrieveRemoteScript(String file, String cacheKey, Boolean minify) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Web\HttpHandlers\JavaScriptHandler.cs:line 206 at BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler.ProcessRequest(HttpContext context) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Web\HttpHandlers\JavaScriptHandler.cs:line 80 at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) Custom event details:

Any one got the answer ?

Feb 28, 2011 at 1:02 AM

Nevermind, found the answer here on BE board, a post answered by BenAmada 
"On the Settings tab in the control panel, there's an Advanced Settings section.  Uncheck "Compress WebResource.axd"."