have a problem on posting comments

Topics: ASP.NET 2.0
Mar 3, 2011 at 5:19 AM

Hi , I have downloaded a new version of BlogEngine2.0 and installed it on my website. Every thing is going well except the comments! When I add Comments ,a forbidden error is shown.On my website I have "IIS User" and "IIS WP User" and I gave full control permission on folder "App_Data" to both of them. After that I got this error : "There was an error in the callback".

What can I do? please help me out! tnx

Mar 3, 2011 at 11:39 AM

I would check to make sure that IIS_User has read access to the root installation of BE. Also, what IIS are you running on? Is there any other sites/virtual directories running? What exactly is the error you're receiving?

Mar 7, 2011 at 2:23 PM

I am having another issue with being able to post comments- would love your thoughts on this.


Mar 9, 2011 at 5:18 AM
MGD_King wrote:

I would check to make sure that IIS_User has read access to the root installation of BE. Also, what IIS are you running on? Is there any other sites/virtual directories running? What exactly is the error you're receiving?

Sorry for delay!

I'm running on IIS 6 and I have another sites running on it perfectly! And the error that I receive is "sorry, the following error occurred while processing your comment: There was an error in the callback"

Do you have any idea? 

Apr 2, 2011 at 2:26 PM
Has anyone found a solution to this problem. I didn't have this issue when using XML but as soon as I switched data storage to SQL server I now get this error too....
Apr 2, 2011 at 3:31 PM

Check if you have "website" text box in the form, if not - add it from the admin/settings/comments.

Apr 2, 2011 at 3:57 PM


The 'website' text box is present in the comment form, but I checked out the admin panel > Settings > Comment rules and filters tab and found a check box for 'Trust authenticated authors'. Ticking this box has now solved the problem for me.

Oct 6, 2011 at 5:15 PM

I too am getting same issue in my blog from morning and trying to resolve.

Jan 21, 2014 at 10:09 AM
Edited Jan 22, 2014 at 12:34 PM
Hi I have BE 2.9.1 and have the same callback error even since perhaps 2.8 and have narrowed it down to the recaptcha plugin.
I have configured BE to not display the recaptcha for authenticated users. Those users can add comments just fine. So it is definitly recaptcha related. But I cannot live without recaptcha or something similar because of all the spambots.

There is no notification in elmah and/or logs in the app_data folder. So I am having a hard time troubleshooting this callback issue with recaptcha.

best regards,

edit it seems that I have version 1.1 in BE installed (recaptcha) but on the bloodforge (author) site is only 0.9.1 available

edit2: changed line 40 in app_code\extensions\recaptcha\recaptchavalidator.cs
to: private const string VerifyUrl = "http://www.google.com/recaptcha/api/verify"; // "http://api-verify.recaptcha.net/verify";
but still the callback error. I think that I am using an old recaptcha plugin? (https://developers.google.com/recaptcha/docs/troubleshooting)

edit3: when I download all the code and run it locally with IIS8.5.9600 it just works. No callback error from recaptcha. When I test it with the same source online, I get a callback error.
Jan 23, 2014 at 2:54 PM
The callback error usually is a JavaScript error, to troubleshoot it you would need to debug JavaScript in FireBug or alike. The file to look at is "/Scripts/auto/blog.js", it has functions like "validateAndSubmitCommentForm" that run on comment submit.

If callback does get submitted and error on server side, check the "/User controls/CommentView.aspx.cs" where callback should run function "RaiseCallbackEvent". If something wrong with recaptcha, like API changed etc. the error will be there. In any case this function should run on comment submit, if it doesn't it means JavaScript failed to call it.
Jan 24, 2014 at 7:38 AM
Thank you rtur, I have already looked at the js console window in firefox and chrome but have not noticed anything yet. Your comment does point me in the right direction. I will update this asap to let you know what caused it in my case.
Jan 27, 2014 at 8:01 AM
Edited Jan 28, 2014 at 10:42 AM
I have uploaded '/admin/pages/RecaptchaLogViewer.aspx' and the aspx.cs from an old backup and I get this message:
There are no successful reCaptcha submissions to display
The alert window that I get after submitting a comment is:
Sorry, the following error occurred while processing your comment: There was an error in the callback.

but the chrome console is still rather "emtpy" : Image
And I cannot find anything in the appdata logger.txt

edit: I have read about the recaptcha requiring full trust in the web.config. is that still the case? I am hosting on azure atm. Recaptcha have not worked since.

edit2: full trust did not change a thing
Jan 31, 2014 at 2:44 PM
I tried to make a new recaptcha key for mycustomdomain.appcloud.net because it runs on azure. but that did not resolve it. Perhaps it has something to do with recaptcha not being azure compatible?