This project is read-only.

Help, BE just stopped working.

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Mar 20, 2011 at 10:34 AM

My blogs, and were both on be 1.6.

Now, neither are working. I cant edit any posts, add new posts, etc. I get the 500 error when I try.

Following the upgrade instructions, I did the 2.0 install.

It works fine until I copy the app data folder over.

Then nothing works.


Mar 20, 2011 at 11:35 AM

Looks like both sites are coming up now.

If you still get the error, and it only happens when copying over your old App_Data data, one possible cause could be if your old settings are referencing a custom Theme that doesn't exist in the BE 2.0 Themes folder.  So make sure your theme folder from BE 1.6 exists in the BE 2.0 Themes folder.

Mar 21, 2011 at 3:12 AM
Edited Mar 21, 2011 at 10:13 AM


Thanks for hitting me back. When I try to make an entry on the site, I can make the entry but when I click the save post button, I get a:

Now, bare in mind, both of the blogs have been up and running for a year. No problems or issues. Just all of the sudden they don't work.

As for the blog, I am copying over the themes also, and still not working. I am losing my mind with this. On, I have tried almost everything I can think of. I get the  blog to work on a clean 2.0 install, once I move the old app data contents to the new app data contents, nothing works. I move the themes over, nothing works. I don't care about the theme, I have thousands of posts on that I absolutely cannot replicate by hand. I have to have this working.

Once I copy my posts over to, this is what I get when I hit

��`I�%&/m�{J�J��t��`$ؐ@�������iG#)�*��eVe]f@�흼��{����{����;�N'���?\fdl��J�ɞ!���?~|?"��Ey�')=��y6�����h����z��<=���~|W>�Z5�u�A:�f��/>����y�(��G�d^ϲe��!z���Ѳ�Y)5��G��A�8�VeU?������/I=����Yd�E��n�գt����/�q��IU�n �ۻ�/No�������N�|� ��&�} �0��euU���?_O�Y��T˦*s�3�0_�/� �ۼV�@ʄJ��TH�����Y>���-���tY-���e^7�U���ŋ:�[�`��+�'U�V�G����]�ݻU��e��F�v{^/gy]�{�#����.���u��su�S��]���Uq�?��' 賏��E�d�� B����w�^�5�[�*-���w?N�W���2����:�*f���ݝ��=�,|�+h~�%�{��.���0�;J]�-�������E��l���q]d�(�vN����(�<_�����z�:[6ۯ��u�գ��_M^�id����i�L�b%3�����x�fn��Ll5%�����v���f������m�nh���&o�by��D��F�@��/� @��6+�&����~��5A��-�,�+B��U�����9wE�5}�5$w��aS���(�WW�b���'�uuECh�z�\����Y��K�tN�8�Ҍ�����S�#P1}S�����7H"F�ʧ�y1�!.���.�ie��7 +������FID����Y� KR Ly���^��i�]kROK��E��=��'�i�7��dMA��:Ĺº���:|cy|���%���n� �i�|��!"Q�yA�m���,����Z�Y n`��fKH���r�(g�����c�Oq~�w��B�Y~����U.<�c���x��C�{���b�<C��W�Ļ}�}����ey��љ#m�� �����/�;�7��'Yw��

Please, any help will be greatly appreciated.

Ok, so after a restart of IIS, I now get this:

Ooops! An unexpected error has occurred.
This one's down to me! Please accept my apologies for this - I'll see to it that the developer responsible for this happening is given 20 lashes (but only after he or she has fixed this problem).

Error Details:
Url :

Raw Url : /default.aspx

Message : Exception of type 'System.Web.HttpUnhandledException' was thrown.

Source : System.Web

StackTrace : at System.Web.UI.Page.HandleError(Exception e)

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest()

at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)

at System.Web.UI.Page.ProcessRequest(HttpContext context)

at ASP.default_aspx.ProcessRequest(HttpContext context)

at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

TargetSite : Boolean HandleError(System.Exception)

Message : Root element is missing.

Source : System.Xml

StackTrace : at System.Xml.XmlTextReaderImpl.Throw(Exception e)

at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)

at System.Xml.XmlTextReaderImpl.ParseDocumentContent()

at System.Xml.XmlTextReaderImpl.Read()

at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)

at System.Xml.XmlDocument.Load(XmlReader reader)

at System.Xml.XmlDocument.Load(String filename)

at BlogEngine.Core.Providers.XmlBlogProvider.SelectPost(Guid id) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Providers\XmlProvider\Posts.cs:line 211

at BlogEngine.Core.Post.DataSelect(Guid id) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Post.cs:line 1307

at BlogEngine.Core.BusinessBase`2.Load(TKey id) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\BusinessBase.cs:line 303

at BlogEngine.Core.Providers.XmlBlogProvider.b__15(String id) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Providers\XmlProvider\Posts.cs:line 68

at System.Linq.Enumerable.<>c__DisplayClass12`3.b__11(TSource x)

at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()

at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)

at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)

at BlogEngine.Core.Providers.XmlBlogProvider.FillPosts() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Providers\XmlProvider\Posts.cs:line 63

at BlogEngine.Core.Post.get_Posts() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Post.cs:line 215

at _default.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at BlogEngine.Core.Web.Controls.BlogBasePage.OnLoad(EventArgs e) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Web\Controls\BlogBasePage.cs:line 317

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

TargetSite : Void Throw(System.Exception)

Man, what in the heck is going on?

I go into admin, to this page;

Everything is smashed together on the right side of the page.

About an inch across and 4 feet down...


I can't find your email address anywherer, but you can email me,

I can give you remote acess to the server, login information for the blogs, etfc. I am losing sleep over this man,.

 It is driving me insane. Please, PLEASE help me.

Mar 21, 2011 at 10:14 AM

So, I have all my posts in and the categories in but nothing is displaying.

Help me man. PLEASE!

Nothing is working, I can log in but I can't do anything once I log in. Nothing is displaying correctly, no posts are showing up, it is all sorts of messed up.

Mar 21, 2011 at 10:30 AM
Edited Oct 24, 2011 at 8:09 PM

Do a clean install.  Back up your server to local computer.  Then delete the entire site.

Keep the app_data folder there but delete its files and content with in the folder to keep your read/write permissions.


Then download a new fresh copy of BlogEngine


Upload that copy to your server.


Make sure its up and enable logging from the extensions.


Then once everything is working then only copy over your posts and pages from the app_data folder

don't copy anything else from the app_data folder from your backup copy.


Hopefully that works.  Also change your password :)   I was able to login to your blog with the default login info I see

that nothing in the admin panel is loading.



Java Blog

Mar 21, 2011 at 10:39 AM

Thanks for hitting me back man.

I will do this right now. I am installing BE from Microsoft WPI through IIS.

I'll post back here when I have the blog reinstalled.

Mar 21, 2011 at 10:42 AM

Alright, it's up and running. I am going to add the pages and blog posts now.

Mar 21, 2011 at 10:50 AM


I have put the pages and posts into the blog as you said.

I didn't do anything else but that. Now have a look,

I don't get it. Help!

I have uploaded the blog pages, posts and categories.xml here,

If you can get the blog up and running somewhere, I would appreciate it if I can just import it into my blog through the import function. I  am so darn frustrated with this.

Please help me.


Mar 21, 2011 at 10:59 AM

You need read/write access to the app_data

Mar 21, 2011 at 11:01 AM

Get free blogengine hosting here:


This is where I am hosting my website at very easy to use.

Mar 21, 2011 at 11:04 AM

What user needs read/write access to the app_data folder?

Network service has it.

Mar 21, 2011 at 11:06 AM

I have my own servers and business internet. I want this shit up and running properly, not someone trying to spam my for hosting.

I installed the blogengine through microsoft's web platform installer.

Mar 21, 2011 at 11:20 AM

Write permissions need to be given to the account the Application Pool is running under.  This post may help.

Oftentimes with IIS7, the default account for the application pool is "ApplicationPoolIdentity".  It's usually easiest to change that account on the application pool to "Network Service", and then you can make sure that Network Service has Write permissions (or full permissions) on the App_Data account.

Mar 21, 2011 at 11:41 AM
timmathews wrote:

I have my own servers and business internet. I want this shit up and running properly, not someone trying to spam my for hosting.

I installed the blogengine through microsoft's web platform installer.



If you can get the blog up and running somewhere, I would appreciate it if I can just import it into my blog through the import function. I  am so darn frustrated with this.

Please help me.


I was just trying to help not spam,  you said "If you can get the blog up and running somewhere"  .

Sorry for offending you, that was not my intentions.  I was only trying to help the best I can not spam you.

Mar 21, 2011 at 11:43 AM

Also your Global.asx  file might not be loading with the app_start section.


I had that problem too before and none of my admin side loaded because of it.

Mar 21, 2011 at 11:45 AM


Looks like  is working now.

Mar 21, 2011 at 7:24 PM
kbdavis07 wrote:

Also your Global.asx  file might not be loading with the app_start section.


I had that problem too before and none of my admin side loaded because of it.

So, please tell me how to make the app_start section load. is working, as far as displaying the pages. When I try to add a new entry, I get 500 server error.

Help! You said you know how to run it, can you or would you please get the blog up as a new directory in your blog...  <---- that would be my blog and use my pages, posts and categories and I can import my blog from your dev site?

Please help!


Mar 21, 2011 at 11:17 PM
Edited Mar 21, 2011 at 11:20 PM


I have just deleted the web and reinstalled be 2.0 for the 45th time in the last 48 hours.

Everything works great. I can view the back end, make blog posts, etc.

Now, once I drop in the pages, the blog dies and does not work.

How can I put the pages back into the blog and make it work?

There is not an issue with the permissions, as it is working just fine before I try to add the pages back in.

I have uploaded the pages, posts and categories in the site, you can dl them here:

Please have a look at it Ben. I can't figure this out for the life of me and my site is dead in the water.

I have tried copying the whole appdata folder over, just the posts, just the pages, etc. I can't get it sussed. Please, Ben Amada, HELP ME!

If you can get the blog up and running with my posts in it and let me import it into my blog, I'll paypal you some CASH for your assistance. This offer goes out to EVERYONE. Get my blog up and running with the above pages, posts and categories and allow me to import it into a clean install of BE 2.0 and I will paypal you some cash. I am thinking around $25-$30.00... You all seem to think it is such a simple solution, so do it and make $25 for 5 minutes of work.



Mar 22, 2011 at 12:58 AM

I am uploading your posts to my website.  They are so far working for me.


Once all are loaded then I will export the file for you to upload into yours.

Mar 22, 2011 at 1:04 AM


Awesome man. That's fantastic. I see one page in there from my blog... I am looking forward to you getting this up and running and I am also looking forward to sending you some MONEY!


Mar 22, 2011 at 1:12 AM

I think you may well have a bad post or posts somewhere, I dropped the whole lot of your posts into a known good copy of BE and it went belly up. When I put 5 in it was fine.

Try putting the posts back in small batches, checking after each insertion that you are still good.

Otherwise, as you say everything else is fine. I was able to add a page and a post and had a good click around.

Mar 22, 2011 at 1:20 AM

One of the many posts are missing an xml elment.  Finding which ones have it is a task :)  But, currently working on it.

Mar 22, 2011 at 1:23 AM


Thanks for your input. I appreciate it. I will try adding a few in at a time and see how it goes. Enjoy your beer.



Mar 22, 2011 at 1:23 AM

Nicely done, crashed on me.

Mar 22, 2011 at 1:25 AM

Got most of them done :)


about 50% are loaded.

Mar 22, 2011 at 1:45 AM
Edited Mar 22, 2011 at 1:56 AM


I found a post with a file size of "0". I deleted this one and copied the rest over. It is now working! I have all the posts back up and running. I am so stoked. I honestly thought all my hard work was lost. Man, I am so dang happy now.


Mar 22, 2011 at 1:56 AM

thats great!