This project is read-only.

ISAPI and CGI Restriction

Topics: ASP.NET 2.0
Mar 22, 2011 at 2:05 AM

I am trying to install blogengine but I am getting the error:

"The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server."

I found a Microsoft KB article on it but the solution talked about going to an isapi restriction option that doesn't exists on my server 2008.  (


Anyone know why I am getting this error and how to fix it?

Mar 22, 2011 at 12:18 PM

The KB article explains what I was going to suggest, but if that option doesn't exist, it's probably not installed. Make sure it's an added feature of the role and then check the options after adding it.

Apr 22, 2011 at 1:32 PM
Edited Apr 22, 2011 at 2:13 PM

** EDIT **

OK I found it (I was looking at folder level but option appears at the very top level).

There is a list of dll files and exe files already allowed.  What file do I have to allow to make blogengine work?

Here is a screenshot of current restrictions:

Apr 22, 2011 at 4:27 PM

If by chance you are using one of latest development builds, this error can be related to .cshtml pages not installed on your box (usually by MVC3 or WebMatrix).

If so, add DLLs from lib/razor folder to the /bin to fix it.

Apr 23, 2011 at 1:37 PM

I downloaded the source version as I plan to make some changes when I get it working.  I followed instructions and uploaded the folder with the built project.


I don't have a "razor" folder in the "lib" folder.  Any ideas what I am doing wrong?

Apr 28, 2011 at 1:00 PM
rtur wrote:

(usually by MVC3 or WebMatrix).

Do I have to install anything additional on the server to get this to work?

Apr 28, 2011 at 3:25 PM

If you downloaded source version from "downloads" tab - no, it should compile and run just fine. I am not sure what your steps are (can't see your image, dropbox not allowed here...). Are you running this source version within VS? Did you compile and move it to IIS?

May 9, 2011 at 11:38 AM
Edited May 9, 2011 at 11:59 AM

I followed the instructions and uploaded the folder that comes with it that is already compiled and ready to upload.

I tried just now to open the solution in visual studio but I am using visual studio 2008 and it gives me error that it was created in newer version of VS.

I opened the BlogEngine.WEB folder as a website and built the project and it built correctly and also runs on my local machine.  I then uploaded the files but I get the same error.


What should I do as I am out of ideas?

May 9, 2011 at 12:46 PM
Edited May 9, 2011 at 12:47 PM

OK I got it working, not sure what I did to be honest.  I  went to the virtual directory in plesk and enbaled every permission I could find, it then started working.  I reset the permissions to how they were originally so I could enable one by one to see which setting made it work but the odd thing is that after I reset to original settings it still works.

Thanks for everyones suggestions, I will now continue with customization and see how I go :)