This project is read-only.

Getting lost with Creating a new Web Application project

Topics: ASP.NET 2.0
Mar 22, 2011 at 2:44 AM

I am trying to follow what described in Create new Web Application project. To do that I downloaded the file BlogEngine.NET 2.0 (web) application, 2670K. I guess I missed something in the process but I can't find out what. Did I used the good file ? Don't know.

The errors I am getting are here:

Mar 22, 2011 at 3:19 AM

Unless you doing it for educational purposes...

"Conclusion: you can download end result of this walk-through from here"

Mar 22, 2011 at 8:30 PM

Spending so many hours on this... Can't see why, when I originally the 4.5 version it worked like a charm (almost) right out of the box. 

I setup Read/Write permissions on the App_Data. 

I setup the web.config to point to my blog

<add key="BlogEngine.VirtualPath" value="~/blog/es/"/>

Customer error mode is off

 <customErrors mode="Off" />

But  still can't see the error:

Mar 23, 2011 at 8:23 AM

In this post back on Nov 9th, I posted an Application_Error handler for the global.asax file.  In the BE 2.0 global.asax file, there is a Application_Error handler.  Try replacing the one from that Nov 9th post in your global.asax file.  It *should* display an error message, rather than the garbage characters you're getting now.

Mar 23, 2011 at 2:28 PM

It didn't  help :-( I had already the error handler you suggested 

Mar 24, 2011 at 2:14 AM
Edited Mar 24, 2011 at 2:15 AM


I moved forward: removing completely what's included in the   <system.webServer> "removed" the error.

As it appears I don't have luck on this project, now I am facing the following issue: my blog is located in a subfolder I specified it in the web.config:

<add key="BlogEngine.VirtualPath" value="~/blog/es/"/>
Strange enough I am getting a message saying "The file '/blog/es/blog/es/themes/Standard/site.master' does not exist." 
And when I am using the web.config
<add key="BlogEngine.VirtualPath" value="~/"/>
The blog comes up but without any applied style.
Mar 24, 2011 at 12:31 PM

Sounds like you're making a small amount of progress.

Since the blog is installed in a folder that is its own application (aka application starting point) in IIS, BlogEngine.VirtualPath should be:

<add key="BlogEngine.VirtualPath" value="~/"/>

The only time it's needed to set the virtual path to something such as "~/blog/es/" would be if the blog folder wasn't its own separate application.

The error currently on your site is:

'/blog/es/blog/es/themes/Standard/site.master' does not exist.

If you change BlogEngine.VirtualPath to "~/" (as shown above), this particular error should go away as BE will then look for your site.master file in the correct location:


After switching BlogEngine.VirtualPath to "~/", it sounds like your blog comes up, but none of the CSS styles are applied?  One possible cause for this is a setting in the control panel.  In the control panel, under Settings -> Advanced, there is a setting called "Trim stylesheets".  Try unchecking that and saving.

Right now, this is the only thing that comes to mind.  If your blog still continues to not have styles after unchecking "Trim stylesheets", try leaving it alone, and I'll navigate to the site and see if I see anything.  Of course you're welcome to try anything you feel might help.

Mar 24, 2011 at 11:52 PM
Edited Mar 25, 2011 at 3:18 AM

Done, I tried the compress thing but  no way CSS not applied

Eventually I found out that it was wrong to remove the <system.webServer> as mentionned before. Read this post from you and updated the system.webserver with that one and guess what ? It's working !!!!

Update. Well almost. If browsing the blog works ( see here ) when I am watching a month it doesn't see . Same when I want to see one particular post:

New update: the issue is with my custom site master page. Don't know why yet....

Another update: problem coming from the AspxMenu I am using in my master page. Sounds weird that when browsing the default page it's working fine but in another situation not. It would be nicer to have a better error message rather than that scribbled text

Mar 25, 2011 at 12:27 PM

Yes, I see that a lot of the links end up with the garbage characters showing.  I completely understand that the garbage characters don't help at all.  Typically in a .NET application, you get the yellow screen of death ... not these characters.  I looked into it once for a bit, but couldn't come up with why the garbage characters appear.  The yellow screen of death would be preferable since it contains error details.

The problem could be with your custom site master page, or possibly some problem with the web.config file.  I think the key here is to get a "real" error message.

I think you said you tried it before, but if not or if you removed it, I would try using the Application_Error handler code from this Nov 9th post.  At least for me in the past, it helped with getting a real error message instead of the garbage characters.

If that doesn't work, then next I would try is Elmah.  It does a good job at catching the errors and logging them.  This post recommends using NuGet to install Elmah into BE.  This person got Elmah installed in his BE 2.0 blog just recently.  When installing Elmah (either manually or via NuGet) it adds a few things to your web.config file.  Once it's installed, you can view a list of errors by navigating to /elmah.axd (ex: or possibly  To be able to access elmah.axd remotely, you'll want to make sure that "allowRemoteAccess" is set to "1", as explained in that post I just referenced.  If you install Elmah manually (rather than using NuGet), there's lots of posts on how to do this ... as Elmah has been around for a long time, and is popular.  Here's one "how to install elmah" post I Googled.

Mar 25, 2011 at 7:55 PM


Thanks for your help. I am using Elmah on other systems but on that one I couldn't make it working properly. Eventually I got rid of the ASPXmenu I was using in my custom site master page and without that it was working properly. Still don't understand why it was working on the default page but not on other pages. Spent way too much time on this issue so I'll use it that way.

Mar 25, 2011 at 8:02 PM

This link might help you in conversion if you are still having some problem