Runs locally but not on server

Apr 3, 2011 at 11:00 PM

I am trying to update to the latest release (4c572bcd4c47), it runs great locally but returns this error message below on the server.

I have it setup now as ASP.net 4.0 without Integrated pipeline, I tried it with it and received the same error.

 

Unable to find the requested .Net Framework Data Provider.  It may not be installed.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 


[ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.]
   System.Data.Common.DbProviderFactories.GetFactory(String providerInvariantName) +1402071
   BlogEngine.Core.Providers.DbConnectionHelper..ctor(String providerName, String connectionString) in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\Providers\DbConnectionHelper.cs:55
   BlogEngine.Core.Providers.DbConnectionHelper..ctor(ConnectionStringSettings settings) in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\Providers\DbConnectionHelper.cs:44
   BlogEngine.Core.Providers.DbBlogProvider.CreateConnection() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\Providers\DbBlogProvider.cs:2036
   BlogEngine.Core.Providers.DbBlogProvider.LoadSettings() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\Providers\DbBlogProvider.cs:794
   BlogEngine.Core.Providers.BlogService.LoadSettings() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\Providers\BlogService.cs:304
   BlogEngine.Core.BlogSettings.Load() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\BlogSettings.cs:1259
   BlogEngine.Core.BlogSettings..ctor() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\BlogSettings.cs:77
   BlogEngine.Core.BlogSettings..cctor() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\BlogSettings.cs:31

[TypeInitializationException: The type initializer for 'BlogEngine.Core.BlogSettings' threw an exception.]
   BlogEngine.Core.BlogSettings.get_Instance() in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\BlogSettings.cs:95
   BlogEngine.Core.Web.HttpModules.CompressionModule.System.Web.IHttpModule.Init(HttpApplication context) in C:\Users\Jerry Dean\Documents\Visual Studio 2010\Websites_2011\blogengine_42bdbb0a8a41\BlogEngine\DotNetSlave.BusinessLogic\Web\HttpModules\CompressionModule.cs:77
   System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +431
   System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +194
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +339
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +253

[HttpException (0x80004005): The type initializer for 'BlogEngine.Core.BlogSettings' threw an exception.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +8950644
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +97
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +256

Apr 4, 2011 at 5:50 AM

Update:

This is the error:

Source Error: 

Line 70:     void Application_Start(object sender, EventArgs e)
Line 71:     {
Line 72:         Utils.LoadExtensions();
Line 73:     }
Line 74: 


Source File: c:\HostingSpaces\sahcinfo\blogengine.testing.sahcinfo.org\wwwroot\Global.asax    Line: 72 

Coordinator
Apr 4, 2011 at 8:56 AM

Is this site configured to use SQL CE?  You can check the web.config file to see what the default blogProvider is.  For example:

<blogProvider defaultProvider="XmlBlogProvider">

If you're planning on using SQL CE, the defaultProvider above would be "DbBlogProvider".  At any rate, do you have the <system.data> section defined in the web.config file, where "Microsoft SQL Server Compact Data Provider 4.0" is added as a "DbProviderFactory"?  The "SQL_CE_for_ASP.NET_4.0_Web.Config" file in the setup\SQL_CE folder has this defined in it.  I would make sure that your web.config file has that in it, and also make sure the SQL CE DLLs are in the BIN directory.

Apr 4, 2011 at 12:03 PM

Everything is as stated above. including the SQL CE DLLs 

For testing I tryed it with the SQL_CE_for_ASP.NET_4.0_Web.Config, even though that was the one I was using that created the error above, now it won't run locally either with the same error appearing,

Unable to find the requested .Net Framework Data Provider.  It may not be installed.


Here is the web.config that workd locally but not on the server.

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <configSections>
    <sectionGroup name="BlogEngine">
      <section name="blogProvider" requirePermission="false" type="BlogEngine.Core.Providers.BlogProviderSection, BlogEngine.Core" allowDefinition="MachineToApplication" restartOnExternalChanges="true" />
    </sectionGroup>
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
      <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
          <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere" />
          <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
          <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
          <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
        </sectionGroup>
      </sectionGroup>
    </sectionGroup>
  </configSections>
	<BlogEngine>
		<blogProvider defaultProvider="DbBlogProvider">
			<providers>
				<add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core" />
				<add name="DbBlogProvider" type="BlogEngine.Core.Providers.DbBlogProvider, BlogEngine.Core" connectionStringName="BlogEngine" />
			</providers>
		</blogProvider>
	</BlogEngine>
	<connectionStrings>
		<clear />
		<add name="BlogEngine" connectionString="Data Source=|DataDirectory|BlogEngine.sdf;" providerName="System.Data.SqlServerCe.4.0" />
	</connectionStrings>
	<appSettings>
		<add key="BlogEngine.FileExtension" value=".aspx" />
		<!-- You can e.g. use "~/blog/" if BlogEngine.NET is not located in the root of the application -->
		<add key="BlogEngine.VirtualPath" value="~/" />
		<!-- The regex used to identify mobile devices so a different theme can be shown -->
		<add key="BlogEngine.MobileDevices" value="(iemobile|iphone|ipod|android|nokia|sonyericsson|blackberry|samsung|sec\-|windows ce|motorola|mot\-|up.b|midp\-)" />
		<!-- The name of the role with administrator permissions -->
		<add key="BlogEngine.AdminRole" value="Administrators" />
		<!-- The name of the role for anonymous(non-authenticated) users. -->
		<add key="BlogEngine.AnonymousRole" value="Anonymous" />
		<!-- The name of the role for Editors -->
		<add key="BlogEngine.EditorsRole" value="Editors" />
		<!--This value is to provide an alterantive location for storing data.-->
		<add key="StorageLocation" value="~/App_Data/" />
		<!--A comma separated list of script names to hard minify. It's case-sensitive. -->
		<add key="BlogEngine.HardMinify" value="blog.js,widget.js,WebResource.axd" />
	</appSettings>
    <system.serviceModel>
      <services>
        <service behaviorConfiguration="AuthenticationServiceBehaviors" name="System.Web.ApplicationServices.AuthenticationService">
          <endpoint binding="basicHttpBinding" contract="System.Web.ApplicationServices.AuthenticationService" />
        </service>
      </services>
      <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />
      <behaviors>
        <serviceBehaviors>
          <behavior name="AuthenticationServiceBehaviors">
            <serviceMetadata httpGetEnabled="true" />
          </behavior>
        </serviceBehaviors>
      </behaviors>
    </system.serviceModel>
  <system.web.extensions>
    <scripting>
      <webServices>
        <authenticationService enabled="true" requireSSL="false" />
        <jsonSerialization maxJsonLength="2147483644"></jsonSerialization>
      </webServices>
    </scripting>
  </system.web.extensions>
  <system.data>
    <DbProviderFactories>
      <remove invariant="System.Data.SqlServerCe.4.0"/>
      <add name="Microsoft SQL Server Compact Data Provider 4.0" invariant="System.Data.SqlServerCe.4.0" description=".NET Framework Data Provider for Microsoft SQL Server Compact" type="System.Data.SqlServerCe.SqlCeProviderFactory, System.Data.SqlServerCe, Version=4.0.0.1, Culture=neutral, PublicKeyToken=89845dcd8080cc91"/>
    </DbProviderFactories>
  </system.data>
	<system.web>
    <compilation debug="true" targetFramework="4.0">
      <assemblies>
        <add assembly="System.Management, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Xml, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
      </assemblies>
      <expressionBuilders>
        <add expressionPrefix="LinqLength" type="BlogEngine.Core.Compilation.LinqLengthExpressionBuilder, BlogEngine.Core" />
        <add expressionPrefix="Reflect" type="BlogEngine.Core.Compilation.ReflectExpressionBuilder, BlogEngine.Core" />
        <add expressionPrefix="Session" type="BlogEngine.Core.Compilation.SessionExpressionBuilder, BlogEngine.Core" />
        <add expressionPrefix="Server" type="BlogEngine.Core.Compilation.ServerVariableExpressionBuilder, BlogEngine.Core" />
        <add expressionPrefix="QueryString" type="BlogEngine.Core.Compilation.QueryStringExpressionBuilder, BlogEngine.Core" />
        <add expressionPrefix="Code" type="BlogEngine.Core.Compilation.CodeExpressionBuilder, BlogEngine.Core" />
      </expressionBuilders>
    </compilation>
		<globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto" />
		<httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384" requestValidationMode="2.0" />
		<machineKey validationKey="D9F7287EFDE8DF4CAFF79011D5308643D8F62AE10CDF30DAB640B7399BF6C57B0269D60A23FBCCC736FC2487ED695512BA95044DE4C58DC02C2BA0C4A266454C" decryptionKey="BDAAF7E00B69BA47B37EEAC328929A06A6647D4C89FED3A7D5C52B12B23680F4" validation="SHA1" decryption="AES" />
		<authentication mode="Forms">
			<forms timeout="129600" name=".AUXBLOGENGINE" protection="All" slidingExpiration="true" loginUrl="~/Account/login.aspx" cookieless="UseCookies" />
		</authentication>
		<pages enableSessionState="false" enableViewStateMac="true" enableEventValidation="true" controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
			<controls>
				<add namespace="App_Code.Controls" tagPrefix="blog" />
			</controls>
			<namespaces>
				<add namespace="BlogEngine.Core" />
			</namespaces>
		</pages>
		<customErrors mode="Off" defaultRedirect="~/error.aspx" redirectMode="ResponseRewrite">
			<error statusCode="404" redirect="~/error404.aspx" />
		</customErrors>
		<membership defaultProvider="DbMembershipProvider">
			<providers>
				<clear />
				<add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed" />
				<add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine" />
				<add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Clear" connectionStringName="BlogEngine" />
			</providers>
		</membership>
		<roleManager defaultProvider="DbRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES">
			<providers>
				<clear />
				<add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider" />
				<add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine" />
				<add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine" />
			</providers>
		</roleManager>
		<siteMap defaultProvider="PageSiteMap" enabled="true">
			<providers>
				<add name="PageSiteMap" description="The site map provider that reads in the .sitemap XML files." type="BlogEngine.Core.Web.Controls.PageSiteMap, BlogEngine.Core" />
				<add name="SecuritySiteMap" description="Used for authenticated users." type="BlogEngine.Core.SecuritySiteMapProvider, BlogEngine.Core" securityTrimmingEnabled="true" siteMapFile="Web.sitemap" />
			</providers>
		</siteMap>
		<httpModules>
			<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" />
			<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core" />
			<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" />
			<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core" />
			<!--Remove the default ASP.NET modules we don't need-->
			<remove name="PassportAuthentication" />
			<remove name="Profile" />
			<remove name="AnonymousIdentification" />
		</httpModules>
		<httpHandlers>
			<add verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" validate="false" />
			<add verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="js.axd" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="res.axd" type="BlogEngine.Core.Web.HttpHandlers.ResourceHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" validate="false" />
			<add verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" validate="false" />
			<add verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" validate="false" />
			<add verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" validate="false" />
			<add verb="*" path="*.htm" type="System.Web.StaticFileHandler" />
		</httpHandlers>
        <trust level="Full" />
	</system.web>
	<system.webServer>
		<validation validateIntegratedModeConfiguration="false" />
		<!-- Enable the staticContent section below to add Expires headers to images for better performance.
				 Some hosting providers does not allow the staticContent section to be set. -->
		<!--
		<staticContent>
			<clientCache httpExpires="Sun, 29 Mar 2020 00:00:00 GMT" cacheControlMode="UseExpires" />
			<mimeMap fileExtension=".mp4" mimeType="video/mp4" />
		</staticContent>
		-->
		<modules>
			<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" />
			<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core" />
			<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" />
			<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core" />
		</modules>
        <directoryBrowse enabled="false" />
        <defaultDocument>
            <files>
                <clear />
                <add value="Default.htm" />
                <add value="Default.asp" />
                <add value="default.php" />
                <add value="default.html" />
                <add value="index.html" />
                <add value="index.htm" />
                <add value="index.asp" />
                <add value="index.cfm" />
                <add value="index.aspx" />
                <add value="index.php" />
                <add value="index.cgi" />
                <add value="index.pl" />
                <add value="Default.aspx" />
                <add value="index.wml" />
                <add value="default.wml" />
                <add value="default.xhtml" />
                <add value="index.xhtml" />
                <add value="_holding.asp" />
                <add value="_holding.htm" />
            </files>
        </defaultDocument>
		<!-- Enable the httpProtocol section below to manipulate some HTTP headers.
				 Some hosting providers does not allow the httpProtocol section to be set. -->
		<!--
		<httpProtocol>
			<customHeaders>
				<remove name="X-Powered-By" />
				<add name="Etag" value=" " />
			</customHeaders>
		</httpProtocol>
		-->
	</system.webServer>
</configuration>


  
    
      
    
    
      
        
        
          
          
          
          
        
      
    
  
	
		
			
				
				
			
		
	
	
		
		
	
	
		
		<!-- You can e.g. use "~/blog/" if BlogEngine.NET is not located in the root of the application -->
		
		<!-- The regex used to identify mobile devices so a different theme can be shown -->
		
		<!-- The name of the role with administrator permissions -->
		
		<!-- The name of the role for anonymous(non-authenticated) users. -->
		
		<!-- The name of the role for Editors -->
		
		<!--This value is to provide an alterantive location for storing data.-->
		
		<!--A comma separated list of script names to hard minify. It's case-sensitive. -->
		
	
    
      
        
          
        
      
      
      
        
          
            
          
        
      
    
  
    
      
        
        
      
    
  
  
    
      
      
    
  
	
    
      
        
        
        
        
        
        
        
      
      
        
        
        
        
        
        
      
    
		
		
		
		
			
		
		
			
				
			
			
				
			
		
		
			
		
		
			
				
				
				
				
			
		
		
			
				
				
				
				
			
		
		
			
				
				
			
		
		
			
			
			
			
			<!--Remove the default ASP.NET modules we don't need-->
			
			
			
		
		
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
		
        
	
	
		
		<!-- Enable the staticContent section below to add Expires headers to images for better performance.
				 Some hosting providers does not allow the staticContent section to be set. -->
		<!--
		<staticContent>
			<clientCache httpExpires="Sun, 29 Mar 2020 00:00:00 GMT" cacheControlMode="UseExpires" />
			<mimeMap fileExtension=".mp4" mimeType="video/mp4" />
		</staticContent>
		-->
		
			
			
			
			
		
        
        
            
                
                
                
                
                
                
                
                
                
                
                
                
                
                
                
                
                
                
                
                
            
        
		<!-- Enable the httpProtocol section below to manipulate some HTTP headers.
				 Some hosting providers does not allow the httpProtocol section to be set. -->
		<!--
		<httpProtocol>
			<customHeaders>
				<remove name="X-Powered-By" />
				<add name="Etag" value=" " />
			</customHeaders>
		</httpProtocol>
		-->
	


Apr 4, 2011 at 12:20 PM

I tried debugging the website in vwd express and get this error now in the db connection helper.cs and it does not run locally with the stock SQL_CE web.config even though it did previous. 

"Failed to find or load the registered .Net Framework Data Provider"

Maybe I did not build the solution correctly from the source code although it seemed to be working great locally.

Apr 4, 2011 at 1:12 PM

Sorry about this, I think I have this issue solved, I was missing the http://localhost:52457/BlogEngine.NET/Bin/System.Data.SqlServerCe.dll in the bin folder.