New Post Options

Topics: ASP.NET 2.0, Business Logic Layer, Controls
May 11, 2011 at 3:52 PM

I would like to set the "Publish" checkbox under "Options" to be unchecked by default.  Where in the code or settings can I configure this?

May 11, 2011 at 4:04 PM
Edited May 12, 2011 at 8:49 PM

To do so, open Add_entry.aspx file located in \admin\Posts and replace

<asp:CheckBox runat="server" ID="cbPublish" Text="<%$ Resources:labels, publish %>" Checked="true" />

with

<asp:CheckBox runat="server" ID="cbPublish" Text="<%$ Resources:labels, publish %>" Checked="false" />

________________________

Free BlogEngine.Net Hosting
BlogEngine.net Forums Community

May 11, 2011 at 4:26 PM

I tried that and nothing changed. Maybe the application pool needs to be recycled before the change will show up?

Thanks!!
May 11, 2011 at 4:31 PM
Edited May 12, 2011 at 8:49 PM

Yes, you need a rebuild. Or change a line in your web.config file, save, undo, save again. Do you understand where I'm going?

________________________

Free BlogEngine.Net Hosting
BlogEngine.net Forums Community

May 11, 2011 at 6:58 PM

There must be another place in the code generating this "checked" box. I recycled the site in IIS. I did the web.config save and re-save and the box is still checked by default. I made the change directly in the "Add_entry.aspx " View. I don't have this set up as a "Project" in VS.

I saved the web.config at the root level. Do I need to do the same with the web.config at the "admin" level?
.............................................................................................
May 11, 2011 at 7:02 PM
Edited May 12, 2011 at 8:49 PM

Humm, I don't think so...

I think you'll have to rebuilt.

________________________

Free BlogEngine.Net Hosting
BlogEngine.net Forums Community

May 12, 2011 at 12:19 AM
Edited Oct 24, 2011 at 9:37 PM

Go to extensions turn one off and then back on that resets the app pool.

 

Also just pick a .dll file and re upload it that will work too.

 

I use the blogengne.core.dll   I ftp it to local then re ftp it back to the server.  That seems to do the trick.


Java Blog

May 12, 2011 at 1:29 PM

Thanks for the new options. I tried both but the "publish" checkbox is still checked by default. I have direct access to the files via a mapped drive inside our network. I have resaved the web.config, blogengine.core.dll and recycled the site in IIS.

Are you sure this is the only place where the code needs to be changed?

<asp:CheckBox runat="server" ID="cbPublish" Text="<%$ Resources:labels, publish %>" Checked="false" />

Thanks!!
May 12, 2011 at 5:20 PM

I think, yes.

Try to delete your browser cache.