Access denied to foo.xml error

Topics: ASP.NET 2.0, Business Logic Layer
Apr 15, 2008 at 8:39 PM
Edited Apr 15, 2008 at 8:50 PM
Edit: OK, I'm only a partial idiot. Scroll down again to see the latest issue
Edit: I'm an idiot. Scroll to the bottom if you're having a similar issue.

Folks:

I'm getting a weird error on my newly-pushed-live blog (http://danimal.acsysinteractive.com). From time to time just viewing the blog I get an "access denied to quotes.xml" error (with instructions to make sure aspnet has rights to the file, yada yada). Also, when I try to edit a file (say, I edit a page, or try to change a setting in the admin tool) I get the same message (on a different file name, of course). The thing is, when I go to look at the file, the changes took! Quite odd, I thought.

Finally, I am unable to save any comments to the blog.

Any idea what could be wrong? I've checked and double-checked that aspnet has full control of the app_data directory tree, and in advanced settings I propagated down to subdirectories and files. I checked individual files and the permission is indeed there. I've tried recycling the application pool in IIS, though I can't do an IIS reset because it's a production box. None of the other 50-odd sites on that server have any issues.

Anyone suggestions?


>>>>>>

The solution: grow a brain and do a search before posting a problem. Needed to give the "Network Service" account full control on the app_data tree. Duh.

>>>>>>

Latest issue: I can now save settings changes and the like. However, I still can't post comments. The ajax indicator graphic shows, but never goes away and the comment never gets posted. Thoughts?
Apr 15, 2008 at 8:58 PM
What extensions do you have running? There are several events that are fired when posting a comment and anyone of them can cause the posting to delay or give up...
Apr 15, 2008 at 9:03 PM
Thanks for your help! I have the following extensions installed

Akismet (disabled)
BBCode
BreakPost
CodeFormatterExtension
QuickerLinks
ResolveLinks
SendCommentMail
SendPings
Smilies
SocialBookmarks
Apr 16, 2008 at 1:07 AM
Hrmm, disabling all extensions allowed comments (though I still get file permission warnings when I change settings). Tomorrow I'll enable them one at a time and figure out what happened.
Apr 18, 2008 at 9:29 PM
1. Right click on "App_Code" then "Properties".
2. Security
3. Add
4. Type "aspnet" in the white field, then click on "Check Names"
5. Mark "Modify" to.
6. Ok