This project is read-only.

Website problem

Jun 8, 2011 at 8:47 PM
Edited Jun 8, 2011 at 8:49 PM

hello, I am having a problem with blogengine on my website.

After I install it everything works perfect for a few days and then somehow after a few days it is like the CSS does not want to load and I am also no longer able to see the posts in the admin section. I have to place a backup back to my hosting and delete and create a new database, also place a backup back into the database and it works again for like 3 days and then it does the same.
For example right now it is broken again for me:

Does anyone know why this keeps happening? I use the latest version by the automatic Microsoft web app function.

Jun 8, 2011 at 10:04 PM

Looks like you have some problem with MediaElementPlayer extension conflicting with jQuery. Try to disable MediaElementPlayer and see if it will help.

Jun 8, 2011 at 10:09 PM
Edited Jun 10, 2011 at 10:08 PM

Thank you for the reply, I have disabled the MediaElementPlayer but it still will not load tit correctly somehow.

Just to edit it also does not show anything in the admin panel I did make a screenshot:

And not sure if it helps I use MSSQL 2008 database, it is really strange because it works good every time for 3 days and then it does this and not sure why.

I removed all posts except a very basic hello one, but that does not solve it either and I disabled all extensions now.

Something must be really weird because I can load the theme like this:

Jun 9, 2011 at 3:12 AM

Another thing you can do is in "advanced" settings uncheck http compression and trim stylesheets.

Jun 9, 2011 at 10:56 AM

Did also not seem to happen, when I disable it and then save it is like the database doesnt update, when I go back to the page it will show it enabled again.
Well I removed everything and I started from scratch so I will see if it keeps working now. ;) Thanks anyway for all your help! I will post if it does it again ^^

Jun 10, 2011 at 1:37 PM

It broke again after 1 day:

Is there maybe something wrong with the MSSQL connection? or is it really a style-sheet problem, because I notice it doesnt wane update anything in control panel so that must mean it is not updating the database.

Not really sure what is wrong because my forum also does run on another MSSQL database and that has no problem.

Well I will make a test blog in MySQL to see if that is any better.

Jun 10, 2011 at 3:16 PM

Really odd. I doubted it is database issue, I'd try to upgrade to latest development build that uses .net 4.0.

Jun 10, 2011 at 3:47 PM
Edited Jun 10, 2011 at 3:48 PM

Were could I download this? I checked the website and under planned it does not show anything. Is there a special place?

Sorry maybe I am just blind :)


Never mind I found it (^.^) thanks I am going to try this out directly.

Jun 10, 2011 at 8:57 PM


I'm having the same problem--most of the admin pages are not listing their contents, including Posts, Comments, Users, etc.  It appears to be related to a javascript error that's getting thrown when those pages load,


Uncaught TypeError: Object [object Object] has no method 'setTemplateURL'


This same exception happens in different places for different pages; for the Posts management page the top of the stacktrace is at /Scripts/jquery-1.5.1.min.js:16

I tried manually including a <script> reference to every javascript file on the site, and that didn't fix it.  Could it have something to do with script handlers or something in the 4.0 web.config?

I am running the site otherwise successfully, using BlogEngine.NET on ASP.NET 4.0.  I did NOT recompile the BlogEngine Core 3.5 DLL to 4.0, though like I said, the rest of the site has been running correctly.

I also experienced the behavior where it worked correctly for a few days and then stopped.  It is working incorrectly consistently across two development environments (Windows 7 Ultimate + IIS7.5, Windows 7 Professional + IIS 7.5) and one production environment (EC2 Windows Server 2008 R2 + IIS7.5)

Jun 11, 2011 at 12:12 AM
Edited Jun 11, 2011 at 12:13 AM

I have been playing around with your latest release (34ca9fe0c061) but I cannot get it to work, I keep getting stuck at a error, I am not really a expert on coding itself :) not sure if you can see what it means? I left it on my site it has a bunch of more information to much to post here.



Server Error in '/' Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0246: The type or namespace name 'BlogEngine' could not be found (are you missing a using directive or an assembly reference?)

Source Error:

Line 3:  using System.Data;
Line 4:  
Line 5:  using BlogEngine.Core;
Line 6:  using BlogEngine.Core.Web.Controls;
Line 7:  using BlogEngine.Core.Web.Extensions;

Source File: wwwroot\App_Code\Extensions\BBCode.cs Line: 5


Jun 11, 2011 at 12:44 AM
Edited Jun 11, 2011 at 12:57 AM

I found out that the issue is somewhere in the SQLServer.NET_4.0_Web.Config that you need to use for MSSQL, if you use the default xml database Web.Config the blog runs perfect however if I swap to the MSSQL database and use the provided SQLServer.NET_4.0_Web.Config above (i change it to Web.Config) it will provide a error.


Also tried to rebuild the project then it does give another erro when using mssql:

Server Error in '/' Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0234: The type or namespace name 'Html' does not exist in the namespace 'System.Web.WebPages' (are you missing an assembly reference?)

Source Error:

Line 3:  using System.Linq;
Line 4:  using System.Web;
Line 5:  using System.Web.WebPages.Html;
Line 6:  using System.Text.RegularExpressions;
Line 7:  using System.Web.UI;

Source File: wwwroot\App_Code\Helpers\RazorHelpers.cs Line: 5

Jun 11, 2011 at 3:18 AM

Web.config for XML and MSSql should be almost identical, only default providers changed from XML to SQL in 3 places. You can use XML config if it works for you and just manually change default providers from XML to DB.

Razor error is because you don't have web pages installed on your server (or workstation). It usually installed into global cache with MVC 3 or Webmatrix. If not, you need copy all DLLs from downloaded /lib/Razor folder into web site's /bin.

Jun 11, 2011 at 12:31 PM

I was curious about something, are the usernames and passwords stored in a MSSQL database (if you use this) or still in a XML file?

Jun 12, 2011 at 2:01 AM

Update on my problem (again, same symptoms, probably different cause:)

While tweaking my project, I had added some additional .js files to /Scripts/ (for jQuery UI.)  Apparently, somewhere along the line, BlogEngine scans the /Scripts folder and automatically adds each script to each page via the script handler (js.axd).  The scripts I added, which I did not intend to add to the admin pages, got added anyways and caused a collision somewhere along the line.  I moved my scripts (different version of jquery and jquery UI) to a /Scripts-Custom folder instead of /Scripts and now it all works as expected.

Jun 12, 2011 at 1:03 PM

Script  references are added by the ScriptModule.. See web.config entry 

      <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>