Upgrade path?

Topics: Controls
Jun 17, 2011 at 3:55 AM

My web host has version 1.0 of blogengine available.  It has crashed three times in as many weeks so I want to see if I can upgrade.  I looked at version 1.5 and the instructions seemed to imply that I should be at 1.45 to upgrade to 1.5. True or a mis-reading on my part?



Jun 17, 2011 at 6:15 AM

Version 1.0 is very old and it's possible you cannot directly upgrade to 1.5.  To be honest I'm not sure as I've not ever worked with anything prior to 1.4.5 code.

Your data is probably stored as XML in the App_Data folder.  You could try installing the latest BE 2.0 code, and then copy your data in App_Data into the App_Data folder for 2.0.  In particular, there's a "Posts" folder under App_Data that probably contains XML files ... one XML file for each blog post.  You could try copying those XML files into the App_Data\Posts folder.  Then restart the blog (BE 2.0) by making any change to the web.config file (add a space, etc).  Doing this will clear out any cached posts in memory so the latest data gets read from App_Data\Posts.  Not sure if it'll work, but is worth a try if you do have those XML files.