PROBLEM WHILE VIEWING THE POST

Jun 24, 2011 at 12:19 PM

�`I�%&/m�{J�J��t��`$ؐ@�����iG#)�*��eVe]f@�흼 ��{���{��;�N'���?\fdl��J�ɞ!���?~|?"��Ey�')=��y6����h���8=��E�f �U���z���Ϛ����t�n�4Wп�2m�y�2��ӶJ�M����g�t�l�I����?�U]�� ?�+}x�6�u�A:�f��/>����y�(��G�d^ϲe��!z���ђ��J�)~�?J����*��Ѥ̦o I��]�P�"�/��v[����W�~���m`N�rvk���Mqz3���w V�vR�4��5A�[��qE��C]�yg����b��'ղ��\���<���c���� �L�TzL�Tm��ݞ�Ӫ�ڢZ>J��2? @[6�U��ŋ:�[�uM��쓪m�ţtwg����*[βII#K�=����. �=��q^f����n�9�:�)��������� ��GW��?��Z !x��ۻG�EOyd�2������jUS�v�x^�����g�;;�{�Y�lW��)Jz���]���a�w�>.~��@q��� <� pz�M��>:������ �F7J?ϗ�%�|�^�Ζ���b]f�(m��X���M�ҧy3���0�㻓��e�^b�J���4���jJs )���by�c���ӵ|{�pB�*��u���yӎӗe� ��ȯ�Y��mM�I�EErS,A]��4�T�V���$lҫy�VD޺ ��Z¥JO�Y>�������Ӽ͊�����n�|1>[^fe1�f�ѱ��?�,0���j]�����ѵ,��[���sz�S����T�?��}S��D?zL�qxNJ ����>/i��u[M ~�5/�e�e}�X��[��9~b��ׯ���~�/ZW�a���t>m��߹c@�@���8i��SI�� ��]�Z������]��/�~���a8��w1��wy�]j�C�} �v���WWWd��wRV�$"��9���}B���'ޯ��o~߯�S�j˶�ʆ -�eD����Ot� ��fu(�� �v~��%�5K�H��;��{?GB�}�O�w���1��'2=f��}������ț�ְ75�ǭ0Ͽ����?�gCҞ?���H�fF_.�W�l��,�q}Ѥ� �{;H �^��[�����^�w�w��ޜ��e]M�Q}�EV,��T�fK��i���$�y�$'�ȏ����eU,�Q mv|��kE}��J��H����E��O��|�<Vb��(�u�T�m >K���"��귩��ho�3���`��xg������Kn�~���^�b��|N�H�Q���u{;ݤ�������}/ ���L��)/�6��m���L�1���)����i���a$k�n��W&(�� ���Wy�`�ӫ�!ɪ���&i�6��>���'�9��-{�9���M�KZ�Euܐ|�[�&p %7X����!m|�U5��5�w�yQu�w�嬺j~_kkXXS��^Z���+J����� \h~_�5{�Y>�����}��e�ӝߗ�!�? ������/ZV?X�ww��) ��PN��ƬOM����W� -寸Hw_նxo+CI�|e9��2'u��dkY������>�

 

actually this is the output what i get when i want to view the post i have posted.what may be the problem .CAN U PLEASE GIVE ME THE SOLUTION,SIR.

Jun 24, 2011 at 1:33 PM

What theme are you using and what version of BE are you using? I've seen this happen with incompatible themes. Change your theme to Standard and see if the issue is still there.

Jun 24, 2011 at 1:45 PM
Edited Jun 24, 2011 at 1:45 PM

ya sir in the standard theme it works fine .in my developed  theme only the problem.actually two issues need to be solved 

one is when i save the post , i get this one

another one is when i want to view the post, this error comes.

please tell me what i should do

Jun 24, 2011 at 1:49 PM

version of BE is 2.0

Jun 24, 2011 at 5:09 PM

Compare your PostView.ascx, CommentView.ascx, and site.master files to the files in the Standard theme. Chances are there's a discrepency in the site.master file.

Jun 27, 2011 at 12:49 PM

Sir,nothin happened after comparing ,now, wat to do ? can u give me the alternatives .i think while redirecting to the page there is a problem.actually the file is an xml file and also it works fine with the other themes

Jun 27, 2011 at 3:14 PM

I think the problem is with the your custom theme. Can you zip it and share it so I can take a look at it?

Jun 28, 2011 at 5:19 AM
Edited Jun 28, 2011 at 5:20 AM

<%@ Control Language="C#" AutoEventWireup="true" EnableViewState="false" Inherits="BlogEngine.Core.Web.Controls.PostViewBase" %>

<div class="post xfolkentry" id="post<%=Index %>">
  <h1><a href="<%=Post.RelativeLink %>" class="taggedlink"><%=Server.HtmlEncode(Post.Title) %></a></h1>
  <span class="author">by <a href="<%=VirtualPathUtility.ToAbsolute("~/") + "author/" + BlogEngine.Core.Utils.RemoveIllegalCharacters(Post.Author) %>.aspx"><%=Post.AuthorProfile != null ? Post.AuthorProfile.DisplayName : Post.Author %></a></span>
  <span class="pubDate"><%=Post.DateCreated.ToString("d. MMMM yyyy HH:mm") %></span>
 
  <div class="text"><asp:PlaceHolder ID="BodyContent" runat="server" /></div>
  <div class="bottom">
    <%=Rating %>
   <%-- <p class="tags">Tags: <%=TagLinks(", ") %></p>
    <p class="categories"><%=CategoryLinks(" | ") %></p>
--%>  </div>

  <div class="footer">   
    <div class="bookmarks">
      <%--<a rel="nofollow" title="Index <%=Index %>" target="_blank" href="http://www.dotnetkicks.com/submit?url=<%=Server.UrlEncode(Post.AbsoluteLink.ToString()) %>&amp;title=<%=Server.UrlEncode(Post.Title) %>">Submit to DotNetKicks...</a>--%>
    </div>
   
    <%=AdminLinks %>
   
    <% if (BlogEngine.Core.BlogSettings.Instance.ModerationType == BlogEngine.Core.BlogSettings.Moderation.Disqus)
       { %>
    <a rel="nofollow" href="<%=Post.PermaLink %>#disqus_thread"><%=Resources.labels.comments %></a>
    <%}
       else
       { %>
    <a rel="bookmark" href="<%=Post.PermaLink %>" title="<%=Server.HtmlEncode(Post.Title) %>">Permalink</a> |
    <a rel="nofollow" href="<%=Post.RelativeLink %>#comment"><%=Resources.labels.comments %> (<%=Post.ApprovedComments.Count %>)</a>  
    <%} %>
    </div>
</div>

this is the postview of that theme.

 

<%@ Control Language="C#" EnableViewState="False" Inherits="BlogEngine.Core.Web.Controls.CommentViewBase" %>

<div id="id_<%=Comment.Id %>" class="vcard comment<%= Post.Author.Equals(Comment.Author, StringComparison.OrdinalIgnoreCase) ? " self" : "" %>">
  <div class="comment_header">
    <span class="gravatar"><%= Gravatar(28)%></span>
    <div class="visitor">
        <%= Comment.Website != null ? "<a href=\"" + Comment.Website + "\" rel=\"nofollow\" class=\"url fn\">" + Comment.Author + "</a>" : "<span class=\"fn\">" +Comment.Author + "</span>" %>
        <%= Flag %>
        <div style="float:right; padding-right:10px"><%= Comment.DateCreated %> <a href="#id_<%=Comment.Id %>">#</a></div>
    </div> 
  </div>
   
  <p class="content"><%= Text %></p>
 
  <p class="author">         
    <%= AdminLinks.Length > 2 ? AdminLinks.Substring(2) : AdminLinks %>
    <span style="float:right"><%=ReplyToLink%></span>
  </p>
 
  <div class="comment-replies" id="replies_<%=Comment.Id %>" <%= (Comment.Comments.Count == 0 || Comment.Email == "pingback" || Comment.Email == "trackback") ? " style=\"display:none;\"" : "" %>>
    <asp:PlaceHolder ID="phSubComments" runat="server" />
  </div>
 
</div>

 

this is the comment view.ascx file

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<post>
  <author>Admin</author>
  <title>NEWS</title>
  <description />
  <content>&lt;p&gt;&lt;span style="font-size: small;"&gt;aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Nulla sit amet nulla. Quisque gravida arcu. Praesent mauris est, congue sed, scelerisque non, auctor mattis, est. Vivamus sodales posuere dui. Etiam varius luctus augue. Suspendisse rutrum massa sed felis. Donec ut nunc in mi dapibus euismod. Phasellus vestibulum nisl.&lt;/span&gt;&lt;/p&gt;</content>
  <ispublished>True</ispublished>
  <isdeleted>False</isdeleted>
  <iscommentsenabled>True</iscommentsenabled>
  <pubDate>2011-06-27 17:02:00</pubDate>
  <lastModified>2011-06-27 17:03:45</lastModified>
  <raters>0</raters>
  <rating>0</rating>
  <slug>NEWS</slug>
  <tags />
  <comments />
  <categories>
    <category>c018ad01-7fea-47ff-b9f3-616f8d99bb41</category>
  </categories>
  <notifications />
</post>

this is the xml file created when i created a post in the site.

Jun 30, 2011 at 6:56 AM

sir waiting for ur reply

Jun 30, 2011 at 12:18 PM

Try uploading your web.Config file again. In fact, make sure you upload the entire contents of the latest stable release and your theme from scratch. Delete everything but your App_Data folder first.

Jul 5, 2011 at 9:40 AM

If you switch your IIS server's pipeline to "Classic" mode, it will return a readable error message.  There will most likely be an error in the code somewhere.  Also, you can check the log file if you have the logger extension enabled and the error should show in there.

Jul 6, 2011 at 12:20 PM
Edited Jul 6, 2011 at 12:37 PM

 

i have done it as u said,sir.now me getting the error Object reference not set

to

an instance of an object.

 

 

:            {
Line 131:                var settings = ExtensionManager.GetSettings("Recaptcha");
Line 132:                return Convert.ToInt32(settings.GetSingleValue("MaxLogEntries"));
Line 133:            }
Line 134:        }

 

Coordinator
Jul 6, 2011 at 11:36 PM

In App_Data\datastore\extensions is a file named Recaptcha.xml.  You might want to try deleting that file, and then restarting the blog.  You can restart the blog by making any change to the web.config file (add a space, etc).

Jul 7, 2011 at 5:46 AM

i tried what u said sir,But stil nothing happened.i deleted the  xml file as u said

Jul 7, 2011 at 7:35 AM
Edited Jul 7, 2011 at 7:36 AM

actually there is an error named null reference exception for the max log entries in recaptchacontrol.cs page ,AS I HAVE SHOWN IN THE PREVIOUS POST so contact page returns an error wen i tried to view that page in my blog

Coordinator
Jul 7, 2011 at 11:00 AM

You can try changing the code for MaxLogEntries in RecaptchaControl.cs to the following.  It'll get past the error, but it's possible an error somewhere else might popup.  MaxLogEntries is not that important anyways ... it's just a logging feature for Recaptcha.

public int MaxLogEntries
{
	get
	{
		return 10;
	}
}
Jul 7, 2011 at 12:08 PM

Server Error in '/' Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 488:
Line 489:            var settings = ExtensionManager.GetSettings("Recaptcha");
Line 490:            this.publicKey = settings.GetSingleValue("PublicKey");
Line 491:            this.privateKey = settings.GetSingleValue("PrivateKey");
Line 492:


Source File: c:\inetpub\wwwroot\BEPageLinkMenu1\BlogEngine\BlogEngine.Net\App_Code\Extensions\Recaptcha\RecaptchaControl.cs    Line: 490

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
   App_Code.Controls.RecaptchaControl.OnInit(EventArgs e) in c:\inetpub\wwwroot\BEPageLinkMenu1\BlogEngine\BlogEngine.Net\App_Code\Extensions\Recaptcha\RecaptchaControl.cs:490
   System.Web.UI.Control.InitRecursive(Control namingContainer) +333
   System.Web.UI.Control.InitRecursive(Control namingContainer) +210
   System.Web.UI.Control.InitRecursive(Control namingContainer) +210
   System.Web.UI.Control.InitRecursive(Control namingContainer) +210
   System.Web.UI.Control.InitRecursive(Control namingContainer) +210
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +378



Version Information: Microsoft .NET Framework Version:2.0.50727.4016; ASP.NET Version:2.0.50727.4435

Coordinator
Jul 7, 2011 at 3:35 PM

Go to admin and turn recaptcha off, see if this will fix error. If you upgraded, try to remove old recaptcha settings XML file in the app_data/datastore/extensions, then you should be ok to turn recaptcha back on.

Jul 8, 2011 at 6:00 AM
Edited Jul 8, 2011 at 6:14 AM

sorry sir,but i dint get what is meant by turning recaptcha off.should i disable it in xml file in the admin folder.i dint get it.

Coordinator
Jul 8, 2011 at 8:48 AM

In the control panel, there's an Extensions tab.  On the Extensions tab, you can enable or disable each extension.  One of the extensions will be Recaptcha.  It is suggested that you try and disable the Recaptcha extension.

Jul 14, 2011 at 5:42 AM

thank you very much sir,it worked now.

Jul 15, 2011 at 10:51 AM

In case anyone else experiences the gobbledygook at the top of this page, it’s something inside blog engine and happens when you have certain errors is your code, not all but some and I can’t work out which. I had been working with it for a long time until I realized it only happens on sites I have blog engine set up on. I still have no idea what causes it, but one way to reproduce it is to open your database if you have one in Visual Studio 2010 and then try running you site from localhost.

I hope this helps people in the future, It’s so nice to get to the bottom of things, I had no idea what was causing this to happen until just recently.

Cheers,

Mike.

Coordinator
Jul 15, 2011 at 11:13 AM

If you get these garbage characters, remove or comment out the Compression module in the web.config file -- it's in there twice and looks like:

<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>

Starting from BE 2.5, you shouldn't get these garbage characters anymore since the Compression Module has been updated to not compress the response if an unhandled exception occurs.