2.5 - Password does not work anymore.

Topics: ASP.NET 2.0
Jul 6, 2011 at 6:04 PM

Hi everybody, I've been using blog engine 2.0 since the release version and it was working fine.

Today, I tried to update it to 2.5 version, the setup (run the sript to database, and upload the files) was fine but the access to administration area stopped working. I didn't change my password, it just stopped working.

Is there anything I can do to fix it ? or is it advisable to go back to version 2.0 ?


Jul 6, 2011 at 10:34 PM

Did you try signing in again after upgrading to 2.5?  It's a different cookie that is used, so logging in is required.

Jul 6, 2011 at 10:39 PM

If you did try logging in again, the problem might be related to a different encryption being used in ASP.NET 4.0.

If you're using the DbMembershipProvider, your username/password is stored in the be_Users table in the DB.  I would clear out the password, with something like:

UPDATE be_Users SET Password = ''

And then restart the blog for any cached data to get cleared out.  You can restart the blog by making any change to the web.config file (add a space, etc).  And then you should be able to login using the default password -- admin.

Jul 6, 2011 at 11:03 PM

Hi BenAmanda, thanks for your help.

I clean the password collumn in my database (mysql) like you said.

And I change something simple in my web.config (a space) to restart the blog and tried to access the blog with default password (admin), but it still does not work.

Is there any other thing I can do?

Thank you! 

Jul 7, 2011 at 2:34 AM

Are you using the web.config file that was included with BE 2.5?

Is your default MembershipProvider in the web.config file set to DbMembershipProvider or XmlMembershipProvider?  The default one will look like what you see below (the important part is what the default provider is -- in this example, it's XmlMembershipProvider).

<membership defaultProvider="XmlMembershipProvider">

If you are using DbMembershipProvider, then you updated the correct spot (be_Users in the MySQL table).  If it's XmlMembershipProvider, then users.xml file in the App_Data folder is used.

Jul 7, 2011 at 9:42 AM

Also, when you say that the password "does not work" .... does that mean you get a "Login Failed" message, or does it mean that you do not receive this type of error message, and it just redirects you back to the homepage?  What if you try entering an intentionally incorrect password, do you then see "Login Failed"?

If you're not seeing a "Login Failed" message and being redirected to the homepage upon entering your password, then the password check is probably working.  My next guess is what I asked in my previous email about whether you are using the web.config file that came with BE 2.5.  If you're using a different web.config file (e.g. BE 2.0 or a custom one), then the login cookie might not be recognized.

Jul 7, 2011 at 10:02 PM

Hi Ben,

Yes, I get a web.config file from 2.5 and change it, I changed a connectionstring to my MySql database, add a reference to MySql.Data.dll (version 6.2.3).

I changed  "defaultProvider" to DbMembershioProvider like you said too.

My username is: Felipe Oriani

I don't know if is there any problem to have a "space" in my username, in other versions there's no problem.

I`m getting a message "Login falied", I don't get a redirect to default page.

I'll try to reinstall it again, if you have any other suggestion, I`d like to try!

Thanks Ben!

Jul 13, 2011 at 1:24 PM

Hi Ben, now it's working. I reinstall everything and change the configuration in web.config file. Now everything is fine.

But, there's another problem, some pages that uses razor (.cshtml) doesn't work for me! Have I need to upload some dll file on bin folder?

Thanks for your help!

Jul 15, 2011 at 10:21 AM

BE 2.5 includes 6 DLL files for the BIN directory needed for Razor support.

5 DLLs starting with System.Web

Are you getting any errors?  Can you view the Dashboard? 

Jul 15, 2011 at 11:45 AM

Yes, these dll files are there in Bin directory:


When I try to access Dashboard, I got 500 error, with a message something like this 'Can not find the Web page' (but in my language, portuguese... I'm trying to translate).

Thank you!

Jul 16, 2011 at 4:10 AM

You might already have the error details there on the page.  Or you might be seeing a generic error message from error.aspx.  One thing to try which could help is in your web.config file, change the "mode" on <customErrors> to "Off" (it's case sensitive).  So it would look like:

<customErrors Mode="Off" .......>

This might possibly show more error details.  Then again, you might already have all the error details already.

Jul 22, 2011 at 1:09 PM

Olá Ben, sorry for wait... but I disable the customErros, and the message shows is: "No support for the request." (but in portuguese). There's no exception page,only a white page with this message.

My server support .Net 4, but I don't know why it's happing!?