This project is read-only.

Integrating BE 2.5 into MVC subdomain

Topics: ASP.NET 2.0, Business Logic Layer
Jul 10, 2011 at 4:44 AM

Hi There,

I am having trouble setting up BE as a web application to an existing sub-domain.

I have a secure site, which is already a sub domain, like The root is an MVC 3 website, running on 4. (I know, what else would it run under). It is on an windows 2008 R2 server, running IIS 7.5, (I think)

I have been trying to get BE 2.5 to run as a web application under it, in a folder like "blogs", but with no luck. The code has been compiled for the .NET 4 Framework, and it is running in its own .NET 4 Integrated application pool.

If I go to the site at I can log in and it goes to it landing page. If I try to go to it ends up on some search page saying it cannot find, somehow the "www" was added to it. I created an index.htm page at the blog level (url: an it displays fine.

Just to test that BE was working fine, I created it own sub domain like, logged in through BE's login screen, and it workd fine. Somehow it is getting it to work as part of the other site that is the issue. When I tried to have point to the secure sub domain for authentication, it did not work. It would take me there, I would log in, but then back to the searc page. There may be more I need to know about pasing credentials from one sub domain to another.

I am in the process of upgrading some web servers, and I have a similar setup on a secure site in IIS 6, running BE 2.0 in a sub web application, and it works fine. It was set up that you log into the root site and then have your credentials carry over to BE.

So there are a few variables from one setup to the other. IIS 6 to IIS 7, Root site going from 3.5 to 4.0 framework, and root site going from webforms to MVC. Initially I had a hybrid webform/MVC root application, that itself worked fine, but BE didn't. In debugging why BE 2.5 did not display, I replaced the root site with just a very basic MVC one, where you log in and have its home page.

I have tried setting the vitual path in the web config, but that did not do anything, and also the setting in the dashboard about enforcing sub domains, but likewise no effect.

It may be something simple, but all my internet searches have not shed any answers yet. I did find out about MVC and routing rules, but not sure if that worked. I tried setting an ignore rule once, but either it did not work, or something else was not working. Maybe I did not do it correctly.

Thanks for any help that can resolve this