This project is read-only.

Comment saving trouble

Apr 23, 2008 at 9:40 PM
I've been using BEN 1.3x and it's fantastic! but I have a weird trouble with posting comments with that version. I've installed BEN in a godaddy shared hosting and in my own local webserver to test, both of them are using XmlBlogProvider and configured as usual following many tutorials online (including the BEN wiki installing tutorial). The blog is installed and the configuration are working as expected, I've been able to post new blog posts and everything works fine in both installations.
This is the weird thing, when I try to post a new comment to a existent blog post the only thing I get is the animated gif indicating the "comment is been saving..." I've been waiting for many minutes (5 to be exact) and the comment is not saved. I try to wait for 10 minutes and go to the front page and the comments are not posted. This behavior is in both installations (local and shared hosting)
I've tried changing the DataStorage to MSSQLBlogProvider and the same behavior persists.

Am I doint something wrong??? If I could post a blog post why not a comment to that post? (enable comment posting is enabled in the post of course!).
Jun 19, 2008 at 5:51 PM
I am having the same problem, though I converted my site over to use MSSQLBlogProvider.
The animated gif spins round and round but it doesn't save the comment.
Jun 19, 2008 at 6:00 PM
Just had another hunt on here and disabling the Askimet extension seems to have solved my problem. Though it might mean I end up with lots of spam in the comments...
Jun 19, 2008 at 10:30 PM
This thread may help:

Agus Suhanto
Jun 20, 2008 at 5:40 AM

Two things have caused this issue for me in the past.

1) Referencing the jQuery library: even if writing jQuery scripts in noConflict mode, comments would not work

2) Akismet extension: Removing the Akismet extension allowed comments to start working

Hope that helps.