BlogEngine.Net 2.5

Jul 15, 2011 at 4:26 AM

I am getting 404.3 error when i log in and try to go to Dashboard.

It's a shared Plesk hosting environment using IIS7.5,

Path:

/admin/default.cshtml

Error:

HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

I have compiled the version myself using following instructions

http://blogengine.codeplex.com/discussions/264583

Screenshot:

http://imageshack.us/photo/my-images/13/unled3af.jpg/

HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Jul 15, 2011 at 4:43 AM

I think i got the solution. Have mailed the service provide have asked them to configure mime type for .cshtml file

Jul 29, 2011 at 2:30 AM

Did this work, I have tried adding the MIME type (running iis6 on server 2003) but no joys. I am only getting this in the multisite feature in BE 2.5.0.6.. it seems to work fine for the Primary blog though.

Aug 25, 2011 at 7:35 AM

I made some changes to web.config and it started working, can't remember what exactly i did.

Apr 2, 2012 at 2:35 AM

this worked for me - http://community.discountasp.net/showthread.php?t=13224

modify web.config to include:

        <security>
            <requestFiltering>
                <fileExtensions>
                    <remove fileExtension=".cshtml" />
                    <add fileExtension=".cshtml" allowed="true" />
                </fileExtensions>
            </requestFiltering>
        </security>