Error With sql server 2000

Topics: ASP.NET 2.0, Business Logic Layer
Jul 23, 2011 at 7:00 AM

 

 

i am facing problem

Server Error in '/BlogEngine' Application.


Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Invalid object name 'be_Rights'.

Source Error:

Invalid object name 'be_Rights'.

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[SqlException (0x80131904): Invalid object name 'be_Rights'.]
   System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) +1948826
   System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) +4844747
   System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) +194
   System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) +2392
   System.Data.SqlClient.SqlDataReader.ConsumeMetaData() +33
   System.Data.SqlClient.SqlDataReader.get_MetaData() +83
   System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) +297
   System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) +954
   System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) +162
   System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) +32
   System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) +141
   System.Data.SqlClient.SqlCommand.ExecuteDbDataReader(CommandBehavior behavior) +12
   System.Data.Common.DbCommand.ExecuteReader() +12
   BlogEngine.Core.Providers.DbBlogProvider.FillRights() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Providers\DbBlogProvider.cs:429
   BlogEngine.Core.Providers.BlogService.FillRights() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Providers\BlogService.cs:202
   BlogEngine.Core.Right.RefreshAllRights() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:155
   BlogEngine.Core.Right..cctor() in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:113

[TypeInitializationException: The type initializer for 'BlogEngine.Core.Right' threw an exception.]
   BlogEngine.Core.Right.HasRight(Rights right, IEnumerable`1 roles) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Security\Right.cs:451
   BlogEngine.Core.Security.IsAuthorizedTo(Rights right) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Security\Security.cs:152
   BlogEngine.Core.Web.Controls.BlogBasePage.OnPreInit(EventArgs e) in E:\Projects\BlogEngine-HG-10\Source\BlogEngine\BlogEngine.Core\Web\Controls\BlogBasePage.cs:412
   System.Web.UI.Page.PerformPreInit() +31
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +282

With Thanks and Regards

Mahender

Coordinator
Jul 24, 2011 at 5:07 AM

Do you have a DB table named be_Rights? That is one of the BlogEngine tables. It sounds like you might not have all the tables.

If this is a new install, make sure you run the new install script.

If it's an upgrade, make sure you run all the upgrade scripts ... i.e. if you are upgrading from 1.6 to 2.5, then you need to run (a) the upgrade script from 1.6 to 2.0 and then (b) run the upgrade script from 2.0 to 2.5.

Jul 25, 2011 at 4:45 AM

Hello BenAmada,

thanks for response 

yes , i have problem in be_Rights table script .i mad it correct and now i am getting new error 

i am using Blog-engine 2 and .net 2008 with sql 2000

Server Error in '/BlogEngine' Application.

Version number '1.0? encoding=' is invalid. Line 1, position 16.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Xml.XmlException: Version number '1.0? encoding=' is invalid. Line 1, position 16.

Source Error:

 

Line 237:            var ws = new WidgetSettings(zoneName) { SettingsBehavior = new XmlDocumentBehavior() };
Line 238:           
Line 239:             var    doc = (XmlDocument)ws.GetSettings();
Line 240:            
Line 241:            return doc;


Source File: c:\Documents and Settings\singh\My Documents\Download\BlogEngine\App_Code\Controls\WidgetZone.cs    Line: 239

With Regards

Mahender

Coordinator
Jul 25, 2011 at 9:48 AM

I'm not entirely sure, but if this is a new install, I would try deleting the contents in the be_DataStoreSettings table, e.g.

DELETE FROM be_DataStoreSettings

Jul 25, 2011 at 11:21 AM

thx for response 

but this is not solution i tried it same error is coming 

 

With Regards 

Mahender

Coordinator
Jul 25, 2011 at 12:48 PM

What does the data in be_DataStoreSettings look like?   Maybe you can copy-and-paste the data from that table here.

Jul 25, 2011 at 12:54 PM

INSERT INTO be_DataStoreSettings (ExtensionType, ExtensionId, Settings)VALUES (1, 'be_WIDGET_ZONE', '<?xml version="1.0" encoding="utf-16"?><WidgetData xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">  <Settings><widgets><widget id="d9ada63d-3462-4c72-908e-9d35f0acce40" title="TextBox" showTitle="True">TextBox</widget><widget id="19baa5f6-49d4-4828-8f7f-018535c35f94" title="Administration" showTitle="True">Administration</widget><widget id="d81c5ae3-e57e-4374-a539-5cdee45e639f" title="Search" showTitle="True">Search</widget><widget id="77142800-6dff-4016-99ca-69b5c5ebac93" title="Tag cloud" showTitle="True">Tag cloud</widget><widget id="4ce68ae7-c0c8-4bf8-b50f-a67b582b0d2e" title="RecentPosts" showTitle="True">RecentPosts</widget></widgets></Settings></WidgetData>');

Coordinator
Jul 26, 2011 at 12:10 PM

I can't tell if the error message is stating the exact XML, but if it is, then according to the error message, the XML it is reading from the DB is this:

Version number '1.0? encoding='

However, the SQL you pasted in your last message looks like this:

<?xml version="1.0" encoding="utf-16"?>

Have you actually looked in the be_DataStoreSettings table to see what the XML looks like.  I'm not sure if the INSERT INTO statement you pasted came from the setup script, or if it contains the actual contents currently in your be_DataStoreSettings table.

For running BE on your SQL 2000 DB, did you convert the setup script to run under SQL 2000?  Just curious since the setup script included w/ BE won't work as-is without some modifications to make it work under SQL 2000.

What happens if you change your blog provider to the default XML provider by using the web.config file that is included with BE.  Do you get the same error when using the XML provider?  It would be good to know if this error occurs regardless of the blog provider, of it it's just the DB blog provider and SQL 2000 where this error occurs.

Jul 26, 2011 at 1:28 PM

thx a log for response

my problem is solved i  delete data from  my sql table be_DataStoreSettings  first time its not worked but today i deleted data again from be_DataStoreSetting

  then  it stared working.

again thanking you very much for this help 

 :)

With Regards,

Mahender