Error: BlogEngine.Core (Unavailable) The project file was unloaded.

Topics: Business Logic Layer
Jul 28, 2011 at 9:28 PM
Edited Oct 24, 2011 at 8:29 PM

I keeping this error when trying to open any  code from the Source Code

 

BlogEngine.Core (Unavailable)  

The project file was unloaded.

 

The Core won't show up and when I go to build rebuild the solution

nothing happens.

 

So it won't generate the bin folder needed to run it.

 

Anybody else have the same problem?

 

Or know how to fix it?

 

Thanks,

 

Brian Davis


Java Blog

Jul 28, 2011 at 11:56 PM

Simple reason it was not working :)

 

It was opening in Visual Studio 2010  Not Microsoft Visual Web Developer Express !!!

 

Feel dump now working on this for hours :)

 

I am on my sister computer had to install all the things I needed and etc. 

 

Jul 29, 2011 at 12:39 AM

I also notice that all source code after BE 2.5 has a solution version of Visual Studio 2010

not Visual Web Developer Express version.

 

Is there a reason for this?

 

How do you open it in Visual Studio 2010?  Or do you have to have the pro edition? 

 

Thanks,

 

Brian Davis

Coordinator
Jul 29, 2011 at 11:42 AM

Where are you seeing that the source code "has a solution version of Visual Studio 2010 not Visual Web Developer Express version" ?

Jul 29, 2011 at 9:29 PM

When I mouse over the solution file for any source over BE 2.5  it says

 

Version: Visual Studio

 

For BE lower than BE 2.5

 

Version: Visual Studio Web Developer Express Edition

Here is a page with the screenshots to show what I am talking about:

 

http://www.kbdavis07.bloggersonline.com/page/VWD.aspx

 

Hope this helps :)

 

Brian Davis

Coordinator
Jul 31, 2011 at 1:20 PM

It looks like the 2nd (or 3rd) line in the SLN file has the following in the BE 2.0 SLN file:

# Visual Web Developer Express 2010

And has the following in the BE 2.5 SLN file:

# Visual Studio 2010

I don't think this information is critical or makes a difference in terms of whether VWD can open the SLN file.  I'm guessing it's just a description that was added in there depending on who saved it last.

As far as I know, VWD can open and work with BE 2.5.  Probably the more important factor is line 1 in the SLN file.

Microsoft Visual Studio Solution File, Format Version 11.00

I would imagine any version of VS 2010 can open a file that has this first line.  This same first line is in the BE 2.0 and BE 2.5 SLN files.

Jul 31, 2011 at 4:59 PM

Well with out doing an Right Click --> Open with  or  setting  Visual Studio 2010 to default to open in VWD Express  it will open in VS 2010 and the core will not work.

 

If the core works in VS 2010 I don't know how to get it to work :) 

 

I only use VWD Express  the Free Edition.

 

No big issue :)

 

Just I was not aware of it at the time :)  Just use to clicking on it and it opens in VWD Express.

 

Now I know to make sure it opens in VWD Express and not VS 2010.

 

 

Just a FYI from what I figure out just in case others are having the same issue :)

 

 

Have a great day!

 

Brian Davis