Errors in IE7/8 when commenting

Topics: ASP.NET 2.0
Aug 9, 2011 at 1:41 PM

Hi there,

I have users saying they are getting the following errors in IE when commenting...  Ive not had time to investgate properly yet but wanted to see if anyone had seen these before I got stuck in.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Fri, 5 Aug 2011 16:12:33 UTC

Message: Syntax error
Line: 2
Char: 1
Code: 0
URI: http://blog/js.axd?path=http%3a%2f%2fmacsblog%2fWebResource.axd%3fd%3dj246orv_38DeKtGbza6y6A2%26amp%3bt%3d634477983879608702

Message: Syntax error
Line: 2
Char: 1
Code: 0
URI: http://blog/js.axd?path=http%3a%2f%2fmacsblog%2fWebResource.axd%3fd%3dWPlOuL4rgyNDaPA-Suv_j8oz_UZDxvllDUDv5wL3hHQ1%26amp%3bt%3d634477983879608702

Message: Object expected
Line: 544
Char: 1
Code: 0
URI: http://blog/SallyBlog/post/2011/08/05/First-post-on-SallyBlog.aspx

Message: Object expected
Line: 1
Char: 5589
Code: 0
URI: http://blog/SallyBlog/js.axd?path=%2fScripts%2fblog.js&minify=

Thanks,

Andy

Aug 17, 2011 at 5:10 PM

small bump.. any one seen anything like this before?  Or could anyone give me tips on how to debug?

A

Aug 24, 2011 at 2:22 PM

In case it helps anyone else,  I have unchecked the "Compress Webresource.AXD" and it seems to have sorted the problem and people can post now.

Having said that, I did some debugging and I was getting "Object Expected" being thrown on the Client_PageValidate("AddComment") in JScript.  There appears to be three verification checks and the first one was not returning an object but the others were both being returned as true.   

Not really sure what to do about it but hope it helps someone in the future.

 

Thanks

A