Adding another blog...and getting stuck

Aug 18, 2011 at 9:12 PM

Hello all,

I am pretty new to using Blog Engine so I am hitting a little bit of a wall.

I am using the current version and trying to create multiple blogs.

For example I have website.com/blog.

I want to create website.com/blog/library.

I created the blog in the dashboard with the name 'Library' and the virtual path '~/library/' and now I am stuck.

Where do I go from here to make this a functioning second part of the blog?

Coordinator
Aug 19, 2011 at 9:01 AM

It sounds like the homepage of the primary blog is website.com/blog.  And you created a new blog instance with the virtual path of ~/library/.

You should be able to navigate to website.com/blog/library/ and see the homepage for that blog.  You can either manually type that URL into the address bar, or from the Blogs Management page (where you created the new blog instance), the name of the new blog should be clickable and will take you to the homepage of the new blog instance.  Also, make sure that the new blog instance you created is set for "Active".  It's better to leave the optional hostname field blank.

If the new blog instance at website.com/blog/library/ does not come up, then if you could describe what you do see, that would be helpful.  i.e. do you see Page Not Found, etc.

Aug 19, 2011 at 1:09 PM

Thanks for your help.

It looks like I had everything set up to what you said, but when I navigate to that page I see 'Directory Listing Denied. The Virtual Directory does not allow contents to be listed.'

Coordinator
Aug 20, 2011 at 5:58 AM
Edited Aug 20, 2011 at 7:48 AM

Did you create a physical directory named "library"?  It sounds like that might be the case.  If so, delete the "library" directory as a physical directory should (cannot) exist when using virtual paths.

EDIT:  Or if you've created a virtual directory in for "library" within IIS, that too should not exist.