This project is read-only.

BlogEngine.NET 2.5 in the root - existing sub dir doesn't work

Topics: ASP.NET 2.0, Business Logic Layer
Oct 15, 2011 at 4:25 PM

I've update my BlogEngine.NET installation to 2.5 version. This works fine in my root dir, I had no problems.

But the content of other sub directories (not related to BlogEngine.NET contents) do not work any more.

I think  it's because sub dir are affected by Web.Config placed in the root. I think I have to create a Web.Config to place in the sub dir that tells to sistem to no load BlogEngine.NET controls and behaviors. Is it correct?


If my suppositions are correct what do I write in my Web.Config for sub dir?

Thank you?

Oct 15, 2011 at 4:58 PM

The easiest way is to have both root and sub dir apps configured as separate applications in IIS.

It is applied to any applications, here is some documentation on configuration hierarchy.

Oct 16, 2011 at 8:39 AM

In my shared hosting I can't access to IIS control panel... so I think the only things I can do is create a web.config for my sub dir...

Is possible to configure a standard application that don't inherit BlogEngine.NET configuration?


Take a look at this link: (the web site of an NGO that make cooperation in Africa).

I thik that in the "/public/" dir I have to place a web.config that "clear" BlogEngine.NET behavior.



:( sorry for my poor english, and also sorry for my poor knowledge of .net framework... this NGO asked me a favor. I made it pro bono.

Oct 30, 2011 at 5:41 PM

I found this on googling the web:

I wrapped <system.web and <system.webServer> of the root web.config in <location path="." inheritInChildApplications="false"> </location> tag.

But it doesn't work: the subfolders still inherites all the settings from its parent  web.config.


What can I do?

Oct 31, 2011 at 12:01 AM

WildBoy76:  You got to contact your hosting provider and have them set up your websites as seperate applications like rtur said that they must be configured

that way.

If not there is a way to set up the app_pool with in the web.config file but, if your hosting provider has a global web.config then it won't work.

Main thing is to setup the separate app_pools if your provider won't set this up for you then you need to switch to a provider that will.

Have a great day,

Brian Davis

Java Blog