Error Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)

Dec 1, 2011 at 3:52 PM

I downloaded the latest Blogengine 2.5 Web version, extracted it and after opening it in VWD when I try to view the default page in a browser it results in this error.

Error Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)

Coordinator
Dec 2, 2011 at 2:37 AM

One place to check is in the App_Data\posts and App_Data\pages folders, and make sure any files in that folder have filenames that are "normal" GUIDs -- i.e in the format:  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx.xml

Dec 2, 2011 at 5:01 AM

Thanks Ben, however I am a bit confused as to why this should occur on a new download and installation, does everyone have to find and correct files to use BlogEngine2.5 or is there a reason why this occurred with my installation?

Thanks or your help.

Dec 2, 2011 at 5:10 AM

I checked the files in the above folders and they are in the correct format.

Dec 2, 2011 at 5:34 AM

 

Ben,

This is apparently what is causing the error I think.

 

 

Line 14:                     <h2>@Resources.labels.stats</h2>
Line 15:                     <ul>
Line 16:                         @Helpers.DashboardHelper.GetStats()
Line 17:                     </ul>
Line 18:                 </div>


Source File: e:\Websites_2011\BE2.5.jumpstart.Web\admin\default.cshtml Line: 16

Coordinator
Dec 2, 2011 at 9:41 AM

Try removing that line (line 16).. you can just temporarily delete it.  And then see if the errors disappear, and if everything works correctly.

You're right, you shouldn't have errors like that out of the box.

Dec 2, 2011 at 1:28 PM
Edited Dec 2, 2011 at 1:29 PM

I removed the line and it still does not work, same error, I think that this needs to be addressed, I am surprised that no one else has reported this issue, as of now at least for me BE 2.5 does not work out of the box.

I downloaded it 3 times to be sure and still the same issue.

Error Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)

Coordinator
Dec 4, 2011 at 9:56 AM

As a test, I downloaded BE 2.5 Web from the Downloads page, and opened it up in VS 2010 Professional (I don't have VWD).  I'm not seeing any errors on my end.

Another place you could check is in the App_Data folder, see if there is a logger.txt file that might contain additional error details.  If there is not a logger.txt file, check the settings.xml file in the App_Data folder, and try changing "enableerrorlogging" to true, so it looks like:

<enableerrorlogging>True</enableerrorlogging>

Then restart the application (make any change in the web.config file), try launching it again, and then see if there is a logger.txt file.

Also, are you seeing ANY other error details, such as a stack trace, or details on which file the error is occurring on?  Depending on the error, there often is more details.  For example, if it's a yellow screen of death, it might show the lines the error is occurring on or some other details.