Posts Page is Empty after Upgrade from 2.0 to 2.5

Topics: Controls, Themes
Dec 3, 2011 at 10:26 PM

After upgrading my blog looks fine. All the posts are there. However when I go to dashboard and click on the Posts page there is nothing on the page.

Any idea?

Coordinator
Dec 4, 2011 at 2:19 AM

Do you see other lists in the admin? Categories, tags, comments, users etc.?

Dec 4, 2011 at 7:33 PM

Thank you for your quick reply rtur...

Solving this problem was very strange!

after upgrading the BE, everything was working fine except I could not add or edit any posts and post list was empty.

I have tried every possible permission settings to solve the problems but nothing worked... I have restarted the iis and all browsers, logged off and in but no luck.

FINALLY, some voice in my head silently told me to hit the refresh button!!! now everything is working normally...

thanks again...

Dec 5, 2011 at 7:33 PM

I am having the same or a similar problem, but refreshing doesn't help. This is a fresh installation of 2.5, using SQL Server. Here's what I observe:

Dashboard information appears correct, the public pages appear correct. If I make a change to the database using Management Studio, it's reflected on the public pages.

Blogs tab is empty.

Posts tab is empty. When I try to add a new post, there is no response.

Categories displays correctly, and I can add a new category

Tags is empty (there are entries in be_PostTag)

Blogroll - able to delete entries

Users - empty, not able to enter a new user

Settings - not able to save changes, but if I make a change to the database using Management Studio, it's reflected here.

Coordinator
Dec 6, 2011 at 10:14 AM

It sounds like a JavaScript problem as data on some of those tabs (Blogs, Posts, Users, etc) are retrieved via JavaScript.

Is it the same problem using a different browser (e.g. Firefox or Chrome)?

If you have Firefox, try opening up the Error Console (Ctrl-Shift-J).  That will open up the Error Console in a new window.  Then try pulling up some of those pages and see if any Errors appear in the console.

Are you able to add a comment (or preview a comment) on a post?

Dec 6, 2011 at 12:43 PM
Edited Dec 6, 2011 at 12:44 PM

Thank you for your quick response!

I'm seeing the same exact behavior on FF and Chrome

I opened the Error Console and clicked around - no errors reported.

I was able to add a comment as a user. When I went to the admin Comments tab, I see Approved (1), but nothing in the body area - no actual comments displayed.

Dec 6, 2011 at 1:59 PM

I just uploaded a completely stock installation of BlogEngine.NET 2.5.0.6. I only changed one single thing - the connection string. I'm getting exactly the same behavior.

Coordinator
Dec 6, 2011 at 3:32 PM

Based on your list of working/not working functions, it seems like an issue with web services/json calls. If you check page loads with FireBug, I bet you'll see service calls returning "internal error" on all pages that don't work. Sometimes setting trust level to "full" fixes this, in some cases you need to set this in web.config even if IIS panel displays it as already set to "full". What do you see on "extensions" tab - do Razor(.cshtml) pages load for you at all?

Dec 6, 2011 at 3:59 PM

You're right - on the Blogs tab, I get:

GET http://searchmarketinginsights.com/blog/admin/ajaxhelper.aspx/loadblogs
     500 Internal Server Error
   71ms

I've confirmed that trust level is already full in IIS.

I've added trust level="Full" to web.config - no change.

Everything on the Extensions tab seems to be working properly.

Coordinator
Dec 6, 2011 at 5:50 PM

Take a look at this thread.

Dec 6, 2011 at 8:07 PM

Mystery solved!

The problem was a Rewrite rule in the parent web.config. The rule was rewriting default.aspx to /.

Solved by adding this to BE's web.config, system.webServer section:

        <rewrite>

<rules>

<clear/>

</rules>

</rewrite>

Coordinator
Dec 6, 2011 at 8:54 PM

Cool, glad you figured it out :)

Dec 6, 2011 at 9:08 PM

Thank you - I got the idea from your link.

Feb 14, 2012 at 7:00 PM

I have the same problem. In the admin dashboard, the list of Posts or Comments are not shown. I tried applying your solution (adding the rewrite section to BE web.config); but it invalidated the whole config file, and the the IIS 7 can no longer pars it. It seems that the <rewrite> is not an option in <system.webServer> section.

Any help is greatly appreciated.