Page not found

Topics: ASP.NET 2.0, Themes
Dec 29, 2011 at 2:14 PM


I added all the content of the web project of the 2.5 version on my website. And when i logon in the administration menu, and i want to go to the dashboard, the system allways say's "Page not found" - And when i want to go in the settings to the theme's i get the same error.

Does anyone know how i can fix this? All the other pages of the settings are working :(



Kind regards


Dec 30, 2011 at 10:43 AM

Those 2 particular pages are "Razor" pages (.cshtml extension), whereas most of the other pages are non-Razor pages (.aspx extension).  The "Extensions" page in the control panel is also a Razor page, and so I would imagine you get the same error there too.

It's probably caused by a configuration issue, maybe at the web host.  Do you have these 6 DLLs in your BIN directory?

Microsoft.Web.Insfrastructure.dll, System.Web.Helpers.dll, System.Web.Razor.dll, System.Web.WebPages.Deployment.dll, System.Web.WebPages.dll, System.Web.WebPages.Razor.dll

You could try searching the Discussions here as I think there have been some others who have run into this problem with the Razor pages.  There might be more than one solution.  Here's a search link you can use:

Feb 8, 2012 at 6:07 PM

Very strange.  I added a new domain to IIS today and get the same error as shown above.  However, my other two instances of BE work GREAT.  I've matched permissions, confirmed DLLs exist, have the same code base, and get the error.  The only difference I can find is that my other domains use the SQL provider and the new one uses XML provider.  May just be a coincidence.  HELP.

Feb 8, 2012 at 6:53 PM

For me, i found the solution here : 


I hope this will also solve your problem

Jul 16, 2014 at 1:30 AM
Adding those handlers generated a 500 error for me with version 2.7.

I just found a fix and posted the answer here: