Two problems with 1.4

Jul 2, 2008 at 1:41 PM
hi,

i'm having trouble updating to 1.4

first, the [More] tag does not appear to be working.

second, whenever i click on a post, i get the following error:

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 432:
Line 433: ExtensionSettings settings = ExtensionManager.GetSettings("BBCode");
Line 434: DataTable table = settings.GetDataTable();
Line 435:
Line 436: foreach (DataRow row in table.Rows)

Source File: d:\hosting\s\User controls\CommentView.ascx.cs    Line: 434

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
User_controls_CommentView.BBCodes() in d:\hosting\steppppo\User controls\CommentView.ascx.cs:434
ASP.user_controls_commentview_ascx.__RenderphAddComment(HtmlTextWriter __w, Control parameterContainer) in d:\hosting\steppppo\User controls\CommentView.ascx:45
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +98
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +20
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
ASP.user_controls_commentview_ascx.__Render__control1(HtmlTextWriter __w, Control parameterContainer) in d:\hosting\steppppo\User controls\CommentView.ascx:6
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +98
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +20
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +199
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +20
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
ASP.themes_standard_site_master.__Render__control5(HtmlTextWriter __w, Control parameterContainer) in App_Web_by9a8ijt.1.cs:0
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +98
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +20
System.Web.UI.HtmlControls.HtmlForm.RenderChildren(HtmlTextWriter writer) +59
System.Web.UI.HtmlControls.HtmlForm.Render(HtmlTextWriter output) +68
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.HtmlControls.HtmlForm.RenderControl(HtmlTextWriter writer) +37
ASP.themes_standard_site_master.__Render__control1(HtmlTextWriter __w, Control parameterContainer) in d:\hosting\steppppo\themes\Standard\site.master:23
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +98
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +20
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +199
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +20
System.Web.UI.Page.Render(HtmlTextWriter writer) +26
BlogEngine.Core.Web.Controls.BlogBasePage.Render(HtmlTextWriter writer) +36
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2558

Jul 2, 2008 at 2:21 PM
i also get this error when i try to add the 'admin' widget to the side panel in the standard theme.

Server Error in '/' Application.

Security Exception

Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

Line 223:    WidgetSettings ws = new WidgetSettings(_zoneId);
Line 224: ws.SettingsBehavior = new XMLDocumentBehavior();
Line 225: ws.SaveSettings(doc);
Line 226: Cache[_zoneId] = doc;
Line 227: }

Source File: d:\hosting\steppppo\Admin\WidgetEditor.aspx.cs    Line: 225

Stack Trace:

[SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
System.Security.CodeAccessSecurityEngine.SpecialDemand(PermissionType whatPermission, StackCrawlMark& stackMark) +0
System.Security.CodeAccessPermission.DemandInternal(PermissionType permissionType) +20
System.Runtime.Serialization.Formatters.Binary.ObjectWriter.Serialize(Object graph, Header[] inHeaders, __BinaryWriter serWriter, Boolean fCheck) +60
System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Serialize(Stream serializationStream, Object graph, Header[] headers, Boolean fCheck) +131
BlogEngine.Core.Providers.DbBlogProvider.SaveToDataStore(ExtensionType exType, String exId, Object settings) +90
BlogEngine.Core.DataStore.XMLDocumentBehavior.SaveSettings(ExtensionType exType, String exId, Object settings) +183
BlogEngine.Core.DataStore.SettingsBase.SaveSettings(Object settings) +20
User_controls_WidgetEditor.SaveXmlDocument(XmlDocument doc) in d:\hosting\steppppo\Admin\WidgetEditor.aspx.cs:225
User_controls_WidgetEditor.SaveNewWidget(WidgetBase widget) in d:\hosting\steppppo\Admin\WidgetEditor.aspx.cs:165
User_controls_WidgetEditor.AddWidget(String type) in d:\hosting\steppppo\Admin\WidgetEditor.aspx.cs:129
User_controls_WidgetEditor.Page_Load(Object sender, EventArgs e) in d:\hosting\steppppo\Admin\WidgetEditor.aspx.cs:49
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +33
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +7350
System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +213
System.Web.UI.Page.ProcessRequest() +86
System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +18
System.Web.UI.Page.ProcessRequest(HttpContext context) +49
ASP.admin_widgeteditor_aspx.ProcessRequest(HttpContext context) in App_Web_lhqxbu2-.2.cs:0
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +358
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean&

Jul 2, 2008 at 7:53 PM
this is getting worse. i've reinstalled to 1.3.1 and now i can't login to my blog.

am i the only one running into these issues?
Jul 2, 2008 at 8:05 PM
Your problem is that the password has been hashed. Look in App_Data/users.xml and change the password back to what it should be.
I'm having the same problem and just downgraded from 1.4 to 1.3.1 and its working fine for me now.
Jul 2, 2008 at 8:14 PM
thanks, daveWhiteNet.

did yo udowngrade because you were getting the same errors above?
Jul 2, 2008 at 8:29 PM
Yes, I am having the same problems as you.  I had to manually edit the proile associated with my main user, and now I am experiencing the "Object reference not set to an instance of an object" error.
Jul 2, 2008 at 8:33 PM
unfortunately, it's still not working. i think i must have to change it elsewhere. or it might be my go daddy hosting.

i ran into something similar when i first tried booting up 1.4. i changed my theme to standard in the be_settings table as well as the settings.xml and it still went looking for my old custom theme.

so, i kept getting errors there until i re-uploaded my old custom theme. i can't figure this out.

and, since i've gotten no response here to these inquiries, i'm imagining this must be unique to me but i can't grasp where i went wrong on the install.
Jul 3, 2008 at 2:47 AM
OK. i added a space to the web config and re-uploaded it. that caused the cache to clear, i guess, because now i can login with 1.3.1.

i want to update to 1.4 but i don't want the errors.

where's the blogengine dev team to answer questions? i've not seen one of them on these boards all day.
Jul 3, 2008 at 6:56 AM
Have you followed the upgrade guide? It helped me upgrading without problems.
Jul 3, 2008 at 11:24 AM
i did follow al's upgrade guide but i guess i'll try again.
Coordinator
Jul 3, 2008 at 12:51 PM
I'm sorry to hear you have been struggling.  I know that we have had GoDaddy issues in the past, but I'm not sure if it is the cause of your issue or not.

Have you tried getting it working on your local PC?  If you can get it working fine there, then you have an issue with your hosting.

It appears you are also using SQL Server for your BlogProvider.  Have you got everything configured correctly?  The old blog provider is gone and has been replaced with a new DbBlogProvider.  I wrote about getting it setup fresh yesterday, but the configuration information might be helpful.

Anyway, I'd suggest working on getting it setup local to remove GoDaddy from the possible problem.


Jul 3, 2008 at 2:12 PM
Edited Jul 3, 2008 at 2:20 PM
Hi there,

I too seem to be having the same 2 issues. I have upgraded using Al's guide successfully from v1.3.1 to v.1.4.

All seemed to be working; except when I click a post link OR create a new post (the new post is created but I am directed to this error message); I see the same error message as posted above.
I am using  the xml version of file management and the blog is on my own server of which I have full rights too.

It may not be of relevance but I noticed the extensions page had an empty list in it that wasn't empty in v.1.3.1.

Any ideas to go against?

Error:

Server Error in '/Blog' Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 432:
Line 433: ExtensionSettings settings = ExtensionManager.GetSettings("BBCode");
Line 434: DataTable table = settings.GetDataTable();
Line 435:
Line 436: foreach (DataRow row in table.Rows)

Source File: c:\Inetpub\wwwroot\Blog\User controls\CommentView.ascx.cs    Line: 434

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
User_controls_CommentView.BBCodes() in c:\Inetpub\wwwroot\Blog\User controls\CommentView.ascx.cs:434
ASP.user_controls_commentview_ascx.__RenderphAddComment(HtmlTextWriter __w, Control parameterContainer) in c:\Inetpub\wwwroot\Blog\User controls\CommentView.ascx:45
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +2065835
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
ASP.user_controls_commentview_ascx.__Render__control1(HtmlTextWriter __w, Control parameterContainer) in c:\Inetpub\wwwroot\Blog\User controls\CommentView.ascx:6
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +2065835
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
ASP.themes_stablestart_black_site_master.__RenderForm1(HtmlTextWriter __w, Control parameterContainer) in c:\Inetpub\wwwroot\Blog\themes\StableStart-Black\site.master:43
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +2065835
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
System.Web.UI.HtmlControls.HtmlForm.RenderChildren(HtmlTextWriter writer) +59
System.Web.UI.HtmlControls.HtmlForm.Render(HtmlTextWriter output) +68
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.HtmlControls.HtmlForm.RenderControl(HtmlTextWriter writer) +37
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
System.Web.UI.Control.Render(HtmlTextWriter writer) +7
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130
System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24
System.Web.UI.Page.Render(HtmlTextWriter writer) +26
BlogEngine.Core.Web.Controls.BlogBasePage.Render(HtmlTextWriter writer) +36
System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25
System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121
System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1896


Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

Coordinator
Jul 3, 2008 at 3:44 PM
Another thought occurred to me...  Are you sure you have the new datastore folder in the App_Data folder (as well as the extensions in the App_Code folder)?
Jul 3, 2008 at 4:09 PM
i thought i had but i will double check. is that related to the error occurring with the more tag and in the commentview page?
Jul 4, 2008 at 12:30 AM
still no dice. i have uploaded both folders. i also followed mads' advice in the 'issue tracker' thread on this problem and gave the datastore/extensions folder write permission.

still get the same errors.

on my local server, i get no errors. but on my hosted server, go daddy, i can't open the posts.

any other folders that need read/write permissions?
Coordinator
Jul 4, 2008 at 1:17 AM
Try to clean up the cache, for example save code below as test.aspx in the app root folder, go to http://yoursite/test.aspx and push button. Then re-save web.config for IIS to restart.

<%@ Page Language="C#" %>
<script runat="server">
    protected void Button1_Click(object sender, EventArgs e)
    {
        div1.InnerHtml = "";
        foreach (System.Collections.DictionaryEntry entry in Cache)
        {
            Cache.Remove(entry.Key.ToString());
            div1.InnerHtml += "Removing " + entry.Key.ToString() + "...<br />";
        }
    }
</script>
<html>
<body>
    <form id="form1" runat="server">
    <asp:Button ID="Button1" runat="server" OnClick="Button1_Click" Text="Clear Cache" /><br />
    <div id="div1" runat="server"></div>
    </form>
</body>
</html>
Jul 4, 2008 at 8:08 AM
Edited Jul 4, 2008 at 8:37 AM
Just to feedback that I have tried this today and it hasn't worked.

I'm not sure this is a GoDaddy issue as I have an internal server on win 2003 (IIS v6) with full admin rights and terminal services access.

I have created a new blog rather then upgrade and it works "better". It seems I can read a post without error but I can't create one; I get:

Access to the path 'c:\inetpub\wwwroot\Blog_Web\BlogEngine.NET\App_Data\posts\62f9651b-e07c-4b29-8288-a87734515763.xml' is denied.


Now I've made sure "aspnet" has "read/write/execute/full controll!!!" of both the app_data folder and all the individual folders within
(in case the cascaded rights were not working for some reason).
Jul 4, 2008 at 9:06 AM
Edited Jul 4, 2008 at 9:40 AM
Well I'd given up and then tried again!

I've managed to get it working.

I backed up my old blog and then deleted all folders/files except app_data.
I copied all files from new version except app_data over. Then copied profiles/datastore over into app_data.
I then updated my rights to app_data - I changed the user "IIS_WPG" to have "full control/ read & execute/write etc".

I then stopped IIS and restarted. Blog loaded; extensions page is listed; [more] tags working and I can view/add posts.

Not sure why the aspnet user has changed to IIS_WPG user but it has done the job for me.
Jul 4, 2008 at 8:38 PM
well that gives me hope. i'm going to try rtur's idea right now. will report how it goes.
Jul 4, 2008 at 9:14 PM
I've checked that I have write permissions for the asp.net account to the datastore folder, and am still getting the same errors.  I just built a quick test page that dumps out some text to a file in the App_Data\datastore folder and it works perfectly.  Am I missing something?
Jul 4, 2008 at 9:27 PM
still not working. i'm beginning to believe there's some sort of security setting i need to adjust. i get this error once and then the 1.4 blog shows up without the extensions loaded.

Security Exception

Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

Line 375:    {
Line 376: BlogEngine.Core.DataStore.ExtensionSettings xs = new BlogEngine.Core.DataStore.ExtensionSettings(ext.Name);
Line 377: xs.SaveSettings(ext);
Line 378: }
Line 379: return true;

Source File: d:\hosting\steppppo\App_Code\ExtensionManager\Manager.cs    Line: 377

Jul 4, 2008 at 9:46 PM
this posting in the issue tracker says there's a bug that pops up in a hosted environment but i don't know where to go to fix it.

any tips would be greatly appreciated.

http://www.codeplex.com/blogengine/WorkItem/View.aspx?WorkItemId=6704


Jul 4, 2008 at 11:54 PM
I had these problems too. After upgrading from 1.3.1 to 1.4 by following the upgrade guide the default page works fine but the post page returns the Steppppo error.
I'm also hosted at GoDaddy and I'm using the new DbBlogProvider.
I was able to reproduce the SaveSettings exception on my machine simply by downgrading the trust level to Medium.

Then I start to searching for a reason and I found out that DbBlogProvider.SaveToDataStore method calls BinaryFormatter.Serialize that requires PermissionType.SecuritySerialization permission.

To solve this problem I export all my posts and blog settings and change the default provider to XmlBlogProvider. Then I import the post data and settings and I was able to see and create new posts correctly.

When I click admin/profiles.aspx I'm getting this error:

Source Error:

Line 30: 	{
Line 31: ProfileCommon pc = new ProfileCommon().GetProfile(name);
Line 32: cbIsPublic.Checked = pc.IsPrivate;
Line 33: tbDisplayName.Text = pc.DisplayName;
Line 34: tbFirstName.Text = pc.FirstName;

Stack Trace:

[SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
BlogEngine.Core.Providers.XmlProfileProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection collection) in XmlProfileProvider.cs:117
System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider) +404
System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName) +117
System.Configuration.SettingsBase.get_Item(String propertyName) +89
System.Web.Profile.ProfileBase.GetInternal(String propertyName) +36
System.Web.Profile.ProfileBase.get_Item(String propertyName) +68
BlogEngine.Core.Web.AuthorProfile.get_IsPrivate() in AuthorProfile.cs:27
admin_profiles.SetProfile(String name) in d:\hosting\nmgomes\admin\Pages\Profiles.aspx.cs:32
admin_profiles.Page_Load(Object sender, EventArgs e) in d:\hosting\nmgomes\admin\Pages\Profiles.aspx.cs:22
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +33
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +7350
System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +213
System.Web.UI.Page.ProcessRequest() +86
System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +18
System.Web.UI.Page.ProcessRequest(HttpContext context) +49
ASP.admin_pages_profiles_aspx.ProcessRequest(HttpContext context) in App_Web_kgdrmcpt.2.cs:0
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +358
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64

It appears that XmlProfileProvider requires a trust level higher than Medium, and this is definitely a problem for Shared hosting in Godaddy.

Jul 5, 2008 at 7:57 PM
i see this has been added to the new version of blogengine under the source code tab:

Fixed the issue with the exception after app restart caused by the extension manager (1.4.0.3)


can anyone tell me how to run and or upload this to go daddy? i open it and there's a solution file in there and some dot net slave business logic.

do i need to do anything with those files or do i just upload the blogengine folder to go daddy?

Jul 29, 2008 at 9:46 PM

I had similar problems on a 2003 Server I own(ie. non-hosted), this seems to have fixed it.

http://www.betaparticle.com/post/2008/06/Quick-tip-to-get-blogenginenet-working-on-Godaddy.aspx
Comment out this line in your web.config file like so:

<!--<trust level="High" />-->

Additionally, if you installed blogengine.net in the root of your server and have problems with other asp.net applications, you can limit child applications from inheriting your root web.config by:

  1. Put this right above the <system.web> line (~line 39):
    <location path="." inheritInChildApplications="false">
  2. Put this right after the </system.web>: </location>

I hope this helps someone.