Godaddy problems

Topics: ASP.NET 2.0
Jul 14, 2008 at 6:22 PM
My appologies if this has been asked before.

Has anyone had problems getting blogengine to run in a godaddy hosting account. I'm trying to get it in a sub-domain, but godaddy is telling me that they will not give ASP.NET full control over the App_Data folder as described in the install video. I can change permissions in the file manager, but this only applies to the folder not files, wtf is that.

So when the program starts up, I get permissions errors from ASP.NET telling me it can't access the App_Data/settings.xml file. Will setting up the blog to use SQL Server resolve this or is there another solution?

Thanks
Jaime
Jul 14, 2008 at 7:16 PM
I'm also using godaddy but I don't have such problems.
When you changing permissions for App_Data, make sure to UNCHECK the "inherit" option, and to CHECK other three options (read, write and reset sub direction permission).



Cheers,
Miller
Jul 14, 2008 at 7:41 PM
I have done that and it doesn't work. It tells me "Access to the path '.......\App_Data\settings.xml' is denied."

Are you using a subdomain (I am)? Frontpage extensions (mine r off)? SQL Server (just XML right now)?

Its almost seems like the child files are not inheriting the parents permissions...Plus the FileManager won't let me set permissions for individual files just folders

Any suggestions?

Jaime
Jul 14, 2008 at 8:11 PM
Edited Jul 14, 2008 at 8:15 PM


jvetter wrote:
I have done that and it doesn't work. It tells me "Access to the path '.......\App_Data\settings.xml' is denied."

Are you using a subdomain (I am)? Frontpage extensions (mine r off)? SQL Server (just XML right now)?

Its almost seems like the child files are not inheriting the parents permissions...Plus the FileManager won't let me set permissions for individual files just folders

Any suggestions?

Jaime


That sounds weird to me. I'm using a subdomain, Frontpage extensions are off, and XML. Same as yours.

Did you put the whole blogengine into a sub directory too? If so, make sure to set the sub directory as an application in IIS settings.

FileManager doesn't allow setting permissions for individual files, but files inherit permissions from directory.


Cheers,
Miller