This project is read-only.

Gallery Control 1.0 not firing sometimes

Topics: Controls
Jul 28, 2008 at 4:16 PM
Edited Jul 28, 2008 at 4:19 PM
Hi, I'm not sure how to troubleshoot this or even if it's the control or BlogEngine's problem. I'm hoping someone has seen this before and might have some ideas.
I have BE 1.4 and I'm using the image gallery control (link is now broken - Hmmm. Not a good sign) quite a bit  as my blog is mostly photos.

Lately, when I add an entry or page with a gallery on it, I see the control markup in my post instead of the actual gallery.

Like this entry. But the other day I had the same problem and while trying to figure it out (pointing the gallery to different folders, doing lots of copy and paste to see if it worked in other places) and then suddenly it worked, like in this entry.

Can anyone give me any troubleshooting tips to figure this out? Or better yet, a fix? I wish I knew what I did to fix it the other day, assuming it wasn't just a coincidence. Thanks!

Oct 14, 2008 at 9:34 PM
Were you ever able to resolve the issue with the Gallery user control? I have the exact same thing--except I get the markup ALL of the time.$0$0$0$0I am using GoDaddy Hosting Connection's implementaiton of the BlogEngine--so I just dropped the extra 2 files into /user controls/ folder.$0$0$0$0$0But--so far, no luck.$0$0$0$0$0Thanks for any help you can offer.$0
Oct 14, 2008 at 10:06 PM
No, I'm still having the problem. I've found a workaround that seems to work for me but I'm guessing it won't for you because you need at least one working instance. I'll copy the markup from a working instance and initially save the post with that (which would be pointing at the wrong folder). Then, I go back and edit the post to point to the right folder and it's been working. But I'd love to not have to do that if anyone figures this out!
Oct 16, 2008 at 4:37 AM
@mattb123$0$0$0$0I've narrowed this down to the CuriouslyGreen theme. When I use it--then I get markup. If I switch to a different them (for example using ?theme=Indigo)--then all is well and the gallery looks and functions perfectly.$0$0$0$0$0If I switch back to the CuriouslyGreen theme, then no luck.$0$0$0$0$0So--that's where I'm at with that. I've tried stripping the site.master down to the core (essentially the contentplaceholder control)--and it still doesn't fire the gallery. Can't wrap my hands around why it would be theme-specific.$0