What's up with the Wiki?

Aug 2, 2008 at 5:08 AM
I have been trying to update the documenation and clean up the wiki, but I keep getting all kinds of errors.  I did some work on the FAQ page, but most other things are throwing application errors.  Custom errors are not configured to give any additional information, but I really think the docs for this project need some work... anyone??
Coordinator
Aug 2, 2008 at 2:27 PM
I completely agree that the wiki needs some work and I'm glad you are trying to help out.

The wiki was working fine for me this morning.  Could you give me the steps to reproduce the errors so I could look into it?

The wiki url is http://dotnetblogengine.net/wiki/ and it redirects to http://razorant.com/blogenginewiki/

If you have an older link into the wiki this would be cause for errors too.

Thanks.
Aug 2, 2008 at 8:00 PM

Hi,

Ok the I did have the link to http://dotnetblogengine.net/wiki  but I still have the same errors:

Clicking on all pages gives this error:

image

That means the only way to add a page to the Wiki is to create a page and assign it to a category, which also need to be cleaned up.  How do you delete or edit categories ( perhaps access to the Administration page is needed, but that gives me an access denied error) ?  The benlogo80.gif was not in the file management section, so I downloaded from the be site and uploaded that yesterday

In the categories, some of the categories bring you to the same system error page as above, ie bad pages.

Most of the pages that I can actually access via the categories menu, ie HungGiang – HomaPage, have nothing more than the following content:

image

I started at the Editable Wiki FAQ, and I commented out several links:

  1. http://razorant.com/docs/ – 404 error
  2. http://razorant.com/wiki/ – it says for more information visit the Wiki, but that doesn’t make sense because you are already at the Wiki
  3. SQL Server provider – First, I updated the Wiki to reflect the other data providers now available.  when clicking that link you get a server error in application, so again I commented it out:
    image
  4. theme creation/modification here – I commented that link out because it show the same error message as in 3)

I tried checking out the RSS Feed and again got another server error.  I also tried running a link checker, but it was no use all the pages are redirected to use cookie less sessions (ie /edit redirects to  Login.aspx-Redirect=Edit.aspx

Also, the page error.aspx (the pages shown in first screen shot) returns an http status of 200, which further makes it difficult to check for broken links using a link validator.

I then stopped editing and made this post because if all of errors are caused from some configuration issue, I don’t what to go through the Wiki and comment out valuable and useful links.

 

Aug 2, 2008 at 11:05 PM
Also, if you create a wiki link using [Visual%20Basic%Edition|Visual Basic Edition], you get an error about some firewall alert being triggered,  I saw that yesterday but can't remember where
Aug 2, 2008 at 11:07 PM
searching brings up the errorpage.aspx as well