resource cannot be found error

Topics: ASP.NET 2.0
Aug 2, 2008 at 8:38 PM
whenever a new post is posted it redirects to page "title".aspx

such a page cannot be found and gives and error

also after posting when clicked on post tile it redirects to "post/post_title.aspx" which also leads to page not found

I have downloaded web project files and using IIS 7.0 on Vista and using default XMLProvider

pl. tell me how to solve it

Aug 2, 2008 at 8:40 PM
I am new here, but let me try to help out.  What version of BE.Net are you using??
Aug 2, 2008 at 8:50 PM

In BE 1.4, i see this
  Response.Redirect(post.RelativeLink.ToString());

Which means after it saves it redirects you to the post.  If you are getting a 404, something is not set up correctly,

Please create a test entry and post the following information here:

1) The absolute url of the page you are being redirected to:
  ie, not just "post/post_title.aspx" but http://domainname.com/post/post_title.aspx
2) The absolute url of the entry admin page:
  ie, http://domainname.com/admin/Pages/Add_entry.aspx
3) Go to the front end of the web site and browse for the test page you just created, and post the absolute url of that post
 ie  http://domainname.com/post/2008/06/28/Welcome-to-BlogEngineNET-1-4.aspx

Aug 2, 2008 at 8:57 PM
Edited Aug 3, 2008 at 5:54 AM
problem solved

pl refer following url

http://www.codeplex.com/blogengine/Thread/View.aspx?ThreadId=21124

Aug 2, 2008 at 9:33 PM
Edited Aug 2, 2008 at 9:33 PM
Does this work?? http://sohin.no-ip.info/sohin.net/post/test.aspx

Also, can you verify in the settings section of the admin that "Add date to post links" is checked..

I am not familiar with vista or iis7.. but is the application configured as a virtual directory as shown in the video?


Aug 3, 2008 at 5:31 AM
Edited Aug 3, 2008 at 5:55 AM
problem solved

pl refer following url

http://www.codeplex.com/blogengine/Thread/View.aspx?ThreadId=21124

Aug 3, 2008 at 7:51 AM
you can go through all the changes to the web.config in the above article... or you can make run Be.Net in Legacy mode and configure the sub directory as a virtual directory in IIS as shown as in the installation video.  Personally, I would rather configure the application pool in IIS.  Why?? You are going to run into problems when you deploy BlogEngine.Net to a Windows 2003 server and have to rever back to the original Web.Config. 

On servers in IIS 6.0, when you want to run an asp.net application in a sub directory, you configure the application as a virtual directory in IIS an make sure the virtual directory is configure as an application. 

But there's always more than one way to skin a cat, so if you comfortable make the changes to the web.config then just do that.  But like I said, you won't be able to deploy it to a live server.
Aug 3, 2008 at 10:05 AM
ya i didn't change web.config

instead

%systemroot%\system32\inetsrv\APPCMD.EXE migrate config "BlogSiteName/"