This project is read-only.

Strage behavior security

Aug 4, 2008 at 7:27 AM
Just intstaled 1.4 with no problems, set up SQL, no problems. Went to the homepage the first record came up, logged in as admin, no problems. Selected administration and clicked add.....problem....

I have double checked to make sure that the app_data folder has write permissions and it does. Can anyne point me in the right direction to fix this, I am using a shared godaddy account.

[SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
   System.Security.CodeAccessSecurityEngine.SpecialDemand(PermissionType whatPermission, StackCrawlMark& stackMark) +0
   System.Security.CodeAccessPermission.DemandInternal(PermissionType permissionType) +20
   System.Runtime.Serialization.Formatters.Binary.ObjectWriter.Serialize(Object graph, Header[] inHeaders, __BinaryWriter serWriter, Boolean fCheck) +60
   System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Serialize(Stream serializationStream, Object graph, Header[] headers, Boolean fCheck) +131
   System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Serialize(Stream serializationStream, Object graph) +13
   BlogEngine.Core.Providers.DbBlogProvider.SaveToDataStore(ExtensionType exType, String exId, Object settings) in DbBlogProvider.cs:1317
   BlogEngine.Core.Providers.BlogService.SaveToDataStore(ExtensionType exType, String exId, Object settings) in BlogService.cs:318
   BlogEngine.Core.DataStore.XMLDocumentBehavior.SaveSettings(ExtensionType exType, String exId, Object settings) in XMLDocumentBehavior.cs:56
   BlogEngine.Core.DataStore.SettingsBase.SaveSettings(Object settings) in SettingsBase.cs:55
   User_controls_WidgetEditor.SaveXmlDocument(XmlDocument doc) +73
   User_controls_WidgetEditor.SaveNewWidget(WidgetBase widget) +290
   User_controls_WidgetEditor.AddWidget(String type) +173
   User_controls_WidgetEditor.Page_Load(Object sender, EventArgs e) +424
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +33
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +47
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +7350
   System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +213
   System.Web.UI.Page.ProcessRequest() +86
   System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +18
   System.Web.UI.Page.ProcessRequest(HttpContext context) +49
   ASP.admin_widgeteditor_aspx.ProcessRequest(HttpContext context) +4
Aug 4, 2008 at 2:38 PM
1.4.0 does not work in medium trust with DB provider because it uses binary formatters. 1.4.5 however does - you need to upgrade to 1.4.5 (or use XML provider in 1.4.0).
Aug 4, 2008 at 5:48 PM
I am afraid something similar happens in 1.4.5 as well.  But it behaves weird.
Check out
An error comes by default. Refresh the screen, and the error goes.

Any idea why?

Thanks in advance,
Aug 5, 2008 at 5:25 AM
This is probably a MySQL bug, please see
Aug 10, 2008 at 12:32 AM
I upgraded to 1.4.5, this seems to have corrected the problem. I am using a shared godaddy account and using the ms sql provider. Thanks for the help.
Sep 2, 2008 at 1:46 PM
Upgrading wont really fix the problem. The actual fix is to run the application under medium trust.