BE 1.4.5 silently rejects username?

Aug 12, 2008 at 7:49 PM
Hey everyone,

I've got a fresh install of BE in a virtual directory inside an existing app that's using the sql membership provider.  I've got the app_data folder with write permissions and everything, but for some reason, it won't let me login.  I don't get an error message, I just redirected back to the home page.  The page still says 'Login' at the top and I'm not getting the admin widget on the side.  Does anyone have a suggestion?

Thanks in advance!

Aug 12, 2008 at 8:05 PM


You don't say whether you modified BE's web.config to use the sql membership and role provider,  did you?  Have you tried logging into the blog with admin/admin?  If that works, you are still using the XML provider.  If you did modify the web.config,  have you created the Administrators and Editors Roles in your aspnet member/role tables? Did you create users and assign them to these roles?  OR take existing users in your app and assign them to the Administrators role?  One other gotcha is the applicationName must match the one in your current membership tables.  You need to add the applicationName attribute to the Role and Membership provider sections of the blog web.config...

I know that's alot of suggestions...hope one or more helps..


Aug 12, 2008 at 8:13 PM
Hi blognewbie,

I haven't really touched the web.config file.  The only changes I made were to fix any errors that were cropping up due to the inherited web.config settings from the parent app. 

The changes were:
  • Adding a connection string value
  • Removed the httpModules->remove values for the PassportAuthenication, Profile and AnonymousIdentification
  • Removed a httpHandler setting for a Telerik control
I'm still trying to use the default xml provider.
Aug 12, 2008 at 8:34 PM

Sorry Joel...

Guess I can't help out...did you set up BE to store posts then?  Could other parent app settings be interfering, like security settings? 

Good Luck

Aug 13, 2008 at 3:27 AM
If you've already seen: Setting up BlogEngine.NET 1.4 to use SQL Server then you may have noticed you don't really need to configure DbProfileProvider when you've done DbBlogProvider.  But the installation and configuration for all providers and SQL schema is well documented.

Are you trying to use the SqlMembershipProvider with the other XML providers?  This I haven't tried so someone else would need to help in this case.  I'm new to using the current SQL providers, but it appears to be working as advertised.
Aug 13, 2008 at 4:11 PM
Ok, I've tried switching over to using the sqlmembership provider for usernames--I'm still using the XML storage for blog posts.  However, I'm still having trouble with the blog not seeing me as an Admin.  I've changed the admin role in the web.config to the following:

<add key="BlogEngine.AdminRole" value="BlogAdmin"/>

I've also updated the roles listing the /admin/pages/web.config

The system takes the username, without a problem, it just won't show the admin panel.  Does anyone see what I'm missing?
Aug 13, 2008 at 7:44 PM
One last crack.  I have my blog (in a virtual directory) talking to an existing membership data.  This is proven by adding the following code to my site.master.cs:

 MembershipUserCollection temp = Membership.GetAllUsers();
        GridView1.DataSource = temp;

It show's all the users stored in the DB, so I know that parts good.  However, I've also added a LoginName to the master page to see if it ever sees a logged in user, even if the role isn't right.  This is where stuff goes wrong--the control is always blank, even after a successful login.

I've changed the appSettings like so:
<add key="BlogEngine.AdminRole" value="BlogAdmin"/>
as well as the web.config file in /admin/pages/web.config

I've got matching machine key values in both config files (blog and parent app), but they're still not talking.

Does anyone have a suggestion?...please? :-P