This project is read-only.

getting an error while installing 1.4.5

Aug 19, 2008 at 10:42 AM

I've installed v1.3, v1.4 without getting any error. But when i try to install the 1.4.5, i get this :

-----------------------the error (in french)----------------------

Impossible de générer une classe temporaire (result=1).
error CS2001: Impossible de trouver le fichier source 'C:\WINDOWS\TEMP\x8tkczac.0.cs'
error CS2008: Absence d'entrée spécifiée

Description : Une exception non gérée s'est produite au moment de l'exécution de la demande Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur l'erreur et son origine dans le code.

Détails de l'exception: System.InvalidOperationException: Impossible de générer une classe temporaire (result=1).
error CS2001: Impossible de trouver le fichier source 'C:\WINDOWS\TEMP\x8tkczac.0.cs'
error CS2008: Absence d'entrée spécifiée

Erreur source:

Ligne 32 : 			WidgetSettings ws = new WidgetSettings("be_WIDGET_ZONE");
Ligne 33 : 			ws.SettingsBehavior = new XMLDocumentBehavior();
Ligne 34 : XmlDocument doc = (XmlDocument)ws.GetSettings();Ligne 35 : 			return doc;
Ligne 36 : 		}

Fichier source : d:\Inetpub\vhost\\subdomains\blog\App_Code\Controls\WidgetZone.cs    Ligne : 34

-----------------------end of the error msg----------------------

The server is Windows Server 2003 web x64. 3.5
an old version of BE : (v1.3)
the problem :  (v1.4.5)
Jan 7, 2009 at 8:53 PM
Did you find out what this was? I ask because I just got the same error (in English) on my personal site. I'd made no changes to the thing, so it's probably a change made by the hoster, but I can't clear it by re-uploading the web.config. Anyone know what the cause is and what the fix is?

Jan 7, 2009 at 9:05 PM
Just curious, what's the error in English?
Jan 7, 2009 at 10:27 PM
It's pretty much the same thing, but..... I noticed that all my blog installations with that hoster are similarly broken, and of course I changed nothing. I checked and they had an outage earlier today... then I thought about it... it looks like this is some sort of "just in time" compiler problem, so I think they probably screwed up the servers when they fixed their outage.

Long story short: I think it's a problem for the hosting company, who have been informed and claim to be on it..
Jan 14, 2009 at 3:35 AM
Guys anyone got a resolution for this? I am getting this same error on my IIS6 W2003 box.
Jan 14, 2009 at 4:03 AM
Not sure, but I think is just a temporary error that may resolve itself.  You could try ...

1. Restarting IIS.

2. Deleting the files in the "Temporary ASP.NET Files" folder (this folder is normally under C:\Windows\Microsoft.NET\Framework\v2.0.50727\ and you may need to have IIS stopped while deleting the files).

3. Deleting the files unded c:\windows\temp.

4. Rebooting the server.
Jan 14, 2009 at 4:26 AM
Hi Ben,

unfortunately these suggestions have not resolved the issue.
Jan 14, 2009 at 4:44 AM

To assits the assiters here is the 

Stack Trace:

 [InvalidOperationException: Unable to generate a temporary class (result=1).

error CS2001: Source file 'C:\WINDOWS\TEMP\nsh7lybo.0.cs' could not be found

error CS2008: No inputs specified


   System.Xml.Serialization.Compiler.Compile(Assembly parent, String ns, XmlSerializerCompilerParameters xmlParameters, Evidence evidence) +1060

   System.Xml.Serialization.TempAssembly.GenerateAssembly(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, Evidence evidence, XmlSerializerCompilerParameters parameters, Assembly assembly, Hashtable assemblies) +2024

   System.Xml.Serialization.TempAssembly..ctor(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, String location, Evidence evidence) +74

   System.Xml.Serialization.XmlSerializer.GenerateTempAssembly(XmlMapping xmlMapping, Type type, String defaultNamespace) +99

   System.Xml.Serialization.XmlSerializer..ctor(Type type, String defaultNamespace) +348

   System.Xml.Serialization.XmlSerializer..ctor(Type type) +6

   BlogEngine.Core.DataStore.XMLDocumentBehavior.GetSettings(ExtensionType exType, String exId) in C:\Documents and Settings\Mads Kristensen\Dokumenter\Visual Studio 2005\Projects\BlogEngine.NET\DotNetSlave.BusinessLogic\DataStore\XMLDocumentBehavior.cs:76

   BlogEngine.Core.DataStore.SettingsBase.GetSettings() in C:\Documents and Settings\Mads Kristensen\Dokumenter\Visual Studio 2005\Projects\BlogEngine.NET\DotNetSlave.BusinessLogic\DataStore\SettingsBase.cs:64

   Controls.WidgetZone.RetrieveXml() in c:\BlogEngine.Web\App_Code\Controls\WidgetZone.cs:34

   Controls.WidgetZone..cctor() in c:\BlogEngine.Web\App_Code\Controls\WidgetZone.cs:28


[TypeInitializationException: The type initializer for 'Controls.WidgetZone' threw an exception.]

   Controls.WidgetZone..ctor() +0

   ASP.themes_standard_site_master.__BuildControlrightzone() in c:\BlogEngine.Web\themes\Standard\site.master:41

   ASP.themes_standard_site_master.__BuildControl__control5() in c:\BlogEngine.Web\themes\Standard\site.master:28

   ASP.themes_standard_site_master.__BuildControlTree(themes_standard_site_master __ctrl) in c:\BlogEngine.Web\themes\Standard\site.master:1

   ASP.themes_standard_site_master.FrameworkInitialize() in c:\BlogEngine.Web\themes\Standard\site.master.cs:912307

   System.Web.UI.UserControl.InitializeAsUserControlInternal() +31

   System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) +2028700

   System.Web.UI.Page.get_Master() +48

   System.Web.UI.Page.ApplyMasterPage() +18

   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +685 


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

Jan 14, 2009 at 6:52 PM
There's a number of hits for that error doing a Google search.  I didn't go through all the results, but a number of the results explain giving read/write privileges for the Temp folder to the ASPNET account.
Jan 14, 2009 at 10:58 PM
Seems to be a server patch issue...  Web Services Enhancements (WSE) 2.0 SP3 for Microsoft .NET ( has fixed it for me.