Sadness... works locally but not on my server

Topics: ASP.NET 2.0
Aug 27, 2008 at 3:45 AM
So I just spent about a bazillion hours over the past month or so putting together a site based on the BE.NET framework getting it to work perfectly on my local system.  Finally it is ready to go, so I make all the necessary changes (that I can think of) for local to hosted and upload it. Alas, it does not work, and I am met with this error message:

(note: I'm using MySQL as my backend (it works both with my local DB and my hosted DB), I've turned ASP.NET on on my server, and I've uploaded all my files....)

anyone have any ideas as to what I may have forgotten/am doing wrong? (yep, I changed my data provider string in my web.Config)  PLEASE HELP!!! THANK YOU!!! 

Server Error in '/' Application.

Unable to find the requested .Net Framework Data Provider.  It may not be installed.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.]
   System.Data.Common.DbProviderFactories.GetFactory(String providerInvariantName) +1447431
   BlogEngine.Core.Providers.DbBlogProvider.LoadSettings() +215
   BlogEngine.Core.Providers.BlogService.LoadSettings() +39
   BlogEngine.Core.BlogSettings.Load() +123
   BlogEngine.Core.BlogSettings..ctor() +333
   BlogEngine.Core.BlogSettings.get_Instance() +61
   BlogEngine.Core.Web.HttpModules.ReferrerModule..cctor() +71

[TypeInitializationException: The type initializer for 'BlogEngine.Core.Web.HttpModules.ReferrerModule' threw an exception.]

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) +103
   System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) +268
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +66
   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +1036
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +114
   System.Web.Configuration.Common.ModulesEntry.Create() +41
   System.Web.Configuration.HttpModulesSection.CreateModules() +203
   System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1006
   System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +259
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +114
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +350
Aug 30, 2008 at 3:11 AM

bump...

i'm still really having problems here... i thought it was my host's connector, so i had them update their connector, and that didn't help.  my msql.data assembly is version 5.2.3, and i updated it in the proper places in my web.config, and still the same freaking error message... i can't get it to work at all, despite working perfectly on my local machine... HELP PLEASE! :(

Aug 30, 2008 at 3:31 AM
i've now tried a completely fresh install, following the instructions exactly... same thing... is there no one out there who can help?
Sep 2, 2008 at 12:48 PM
A fresh install wont help. Check your IIS to see under what framework is BE.NET running. By the looks of it, its certainly running under 1.1 or 3.5


Thanks,
Sk
Sep 2, 2008 at 12:54 PM
Ahhh... sorry, I forgot to post my solution here.  The problem wasn't on my end, it was on my hosting company's end.  They had a stray character in their machine.config file near the DbFactoryProviders or whatever node that was causing the MySQL connector to not be found.  Unreal.