Hosting BlogEngine in multiple folders on server

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Sep 18, 2008 at 10:25 AM

Hi there,

The problem I seem to be having at the moment is as follows:
I am currently hosting with Streamline.net and have an instance of BlogEngine.net 1.4.5 sitting in the root of the server space > HTDOCS > BlogEngine.net files and web.config
This instance works fine. Now what i have tried to do is create 5 folders and put an instance of BlogEngine.net 1.4.5 in each of the 5 folders.

Now the problem I have is that I have setup 5 folders.
Folder name: Blog1
Folder name: Blog2
Folder name: Blog3
Folder name: Blog4
Folder name: Blog5

Within each of the 5 folders I have an instance of BlogEngine.net 1.4.5 WITHOUT the web.config file. This resides in the root of the HTDOCS folder so I need all 5 applications in each of the 5 folders to read this web.config.

The error I am getting is that each app in each folder can't read the web.conf BlogEngine.Core tag.
Anyone else having problems hosting multiple BlogEngine.net apps with Streamline.net??

Kindest Regards,
LBI

Sep 21, 2008 at 8:28 PM
try adding <location inheritInChildApplications="fale"> just after the configuration start in the web.config file in the root web.config like so: (don't forget the endint tag)

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
<location inheritInChildApplications="false"><!-- tyeodle added -->

.... your web.config information.

</location><!-- tyeodle added -->
</configuration>
Sep 21, 2008 at 10:15 PM
The OP wants the apps to read the web.config file. That will only make it not readable.
Sep 21, 2008 at 10:48 PM
Thanks the response guys. Am still having problems. tried the following:

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <configSections>
        <sectionGroup name="BlogEngine">
            <section name="blogProvider" requirePermission="false" type="BlogEngine.Core.Providers.BlogProviderSection, BlogEngine.Core" allowDefinition="MachineToApplication" restartOnExternalChanges="true"/>
        </sectionGroup>
    </configSections>
    <BlogEngine>
<location inheritInChildApplications="false"><!-- tyeodle added -->
        <blogProvider defaultProvider="XmlBlogProvider">
            <providers>
                <add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>
                <add name="DbBlogProvider" type="BlogEngine.Core.Providers.DbBlogProvider, BlogEngine.Core" connectionStringName="BlogEngine" />
            </providers>
        </blogProvider>
    </BlogEngine>
    <!-- configSource is not implemented in Mono.
    <connectionStrings configSource="sql.config" />
  -->
    <connectionStrings>
        <clear/>
        <add name="LocalSqlServer" connectionString="dummy"/>
        <!-- Mono complains if LocalSqlServer isn't specified -->
        <add name="BlogEngine" connectionString="Data Source=MySQLServer;User ID=user;Password=password;persist security info=False;initial catalog=BlogEngine;" providerName="System.Data.SqlClient"/>
    </connectionStrings>
 
    <appSettings>
        <add key="BlogEngine.FileExtension" value=".aspx"/>
        <!-- You can e.g. use "~/blog/" if BlogEngine.NET is not located in the root of the application -->
        <add key="BlogEngine.VirtualPath" value="~/"/>
        <!-- The regex used to identify mobile devices so a different theme can be shown -->
        <add key="BlogEngine.MobileDevices" value="(nokia|sonyericsson|blackberry|samsung|sec\-|windows ce|motorola|mot\-|up.b|midp\-)"/>
        <!-- The name of the role with administrator permissions -->
        <add key="BlogEngine.AdminRole" value="Administrators"/>
        <!--This value is to provide an alterantive location for storing data.-->
        <add key="StorageLocation" value="~/App_Data/"/>
    <!--A comma separated list of script names to hard minify. It's case-sensitive. -->
    <add key="BlogEngine.HardMinify" value="blog.js,widget.js,WebResource.axd"/>
    </appSettings>
   
  <system.web>
        <compilation debug="true">
            <assemblies>
                <add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                <add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                <add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                <add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                <add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                <add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            </assemblies>
        </compilation>

    <globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto"/>
        <httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384"/>
        <machineKey validationKey="D9F7287EFDE8DF4CAFF79011D5308643D8F62AE10CDF30DAB640B7399BF6C57B0269D60A23FBCCC736FC2487ED695512BA95044DE4C58DC02C2BA0C4A266454C" decryptionKey="BDAAF7E00B69BA47B37EEAC328929A06A6647D4C89FED3A7D5C52B12B23680F4" validation="SHA1" decryption="AES"/>
       
    <authentication mode="Forms">
            <forms timeout="129600" name=".AUXBLOGENGINE" protection="All" slidingExpiration="true" loginUrl="~/login.aspx" cookieless="UseCookies"/>
        </authentication>
       
    <pages enableSessionState="false" enableViewStateMac="true" enableEventValidation="true">
            <controls>
                <add namespace="Controls" tagPrefix="blog"/>
            </controls>
        </pages>
       
    <customErrors mode="Off">
            <error statusCode="404" redirect="~/error404.aspx"/>
        </customErrors>
               
    <membership defaultProvider="XmlMembershipProvider">
            <providers>
                <clear/>
                <add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed"/>
                <add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
                <add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine"/>
            </providers>
        </membership>
       
    <roleManager defaultProvider="XmlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES">
            <providers>
                <clear/>
                <add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider"/>
                <add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
                <add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>
            </providers>
        </roleManager>
       
    <siteMap defaultProvider="PageSiteMap" enabled="true">
            <providers>
                <add name="PageSiteMap" description="The site map provider that reads in the .sitemap XML files." type="BlogEngine.Core.Web.Controls.PageSiteMap, BlogEngine.Core"/>
                <add name="SecuritySiteMap" description="Used for authenticated users." type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>
            </providers>
        </siteMap>
   
        <httpModules>
            <add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>
            <add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>
            <add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>
            <add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core"/>
            <!--Remove the default ASP.NET modules we don't need-->
            <remove name="PassportAuthentication"/>
            <remove name="Profile"/>
            <remove name="AnonymousIdentification"/>
        </httpModules>
       
    <httpHandlers>
            <add verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" validate="false"/>
            <add verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="js.axd" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" validate="false"/>
            <add verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" validate="false"/>
            <add verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" validate="false"/>
            <add verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" validate="false"/>
        </httpHandlers>
    </system.web>
</location><!-- tyeodle added -->
</configuration>
Sep 21, 2008 at 11:14 PM
For me to get it to work I had to put the <location inheritInChildApplications="false"> as high up as possible.

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
<location inheritInChildApplications="false"><!-- tyeodle added -->
    <configSections>
Sep 21, 2008 at 11:18 PM
One more thing: to use <location inheritInChildApplications="false">in the root you must still have a full web.config in the child sub folders. It's used to not let the children use the parents web.config.
Sep 22, 2008 at 10:58 AM
Hi Tyeodle,

Carried out what you said. Put the web.config in the root without the <location inheritInChildApplications="false">.
In the other folders put a web.config in each with the <location inheritInChildApplications="false">. When trying to access get this error:
 

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Only one <configSections> element allowed per config file and if present must be the first child of the root <configuration> element.

Source Error:

Line 2:  <configuration>
Line 3:  <location inheritInChildApplications="false"><!-- tyeodle added -->
Line 4: <configSections>Line 5:  		<sectionGroup name="BlogEngine">
Line 6:  			<section name="blogProvider" requirePermission="false" type="BlogEngine.Core.Providers.BlogProviderSection, BlogEngine.Core" allowDefinition="MachineToApplication" restartOnExternalChanges="true"/>

Source File: e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config    Line: 4



It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 10)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 56)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 58)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 72)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 81)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 90)

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

Apparently Streamline are stating that I can only have 1 web.config that resides in the root. And when i asked about helping with setting up Virtual Directories they mentioned they can't do anything cause they are using a Shared Hosting Platform. Bunch of muppets they are!!!

Anyone got anymore ideas from here???

Tyeodle are you with streamline.net for hosting your blog engine apps and do you have your exisiting in the root and also in folders???? If so whats your url so we can have a looky? :P

Kindest Regards,
lbi
<!-- [ConfigurationErrorsException]: Only one <configSections> element allowed per config file and if present must be the first child of the root <configuration> element. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 4) at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal) at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors) at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject) at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission) at System.Configuration.BaseConfigurationRecord.GetSection(String configKey) at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName) at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index) at System.Web.Configuration.RuntimeConfig.get_CustomErrors() at System.Web.Configuration.CustomErrorsSection.GetSettings(HttpContext context, Boolean canThrow) at System.Web.HttpResponse.ReportRuntimeError(Exception e, Boolean canThrow, Boolean localExecute) at System.Web.HttpRuntime.FinishRequest(HttpWorkerRequest wr, HttpContext context, Exception e) --- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 10) at System.Web.Configuration.WebConfigurationHost.VerifyDefinitionAllowed(String configPath, ConfigurationAllowDefinition allowDefinition, ConfigurationAllowExeDefinition allowExeDefinition, IConfigErrorInfo errorInfo) at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps) --- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 56) at System.Web.Configuration.WebConfigurationHost.VerifyDefinitionAllowed(String configPath, ConfigurationAllowDefinition allowDefinition, ConfigurationAllowExeDefinition allowExeDefinition, IConfigErrorInfo errorInfo) at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps) --- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 58) at System.Web.Configuration.WebConfigurationHost.VerifyDefinitionAllowed(String configPath, ConfigurationAllowDefinition allowDefinition, ConfigurationAllowExeDefinition allowExeDefinition, IConfigErrorInfo errorInfo) at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps) --- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 72) at System.Web.Configuration.WebConfigurationHost.VerifyDefinitionAllowed(String configPath, ConfigurationAllowDefinition allowDefinition, ConfigurationAllowExeDefinition allowExeDefinition, IConfigErrorInfo errorInfo) at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps) --- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 81) at System.Web.Configuration.WebConfigurationHost.VerifyDefinitionAllowed(String configPath, ConfigurationAllowDefinition allowDefinition, ConfigurationAllowExeDefinition allowExeDefinition, IConfigErrorInfo errorInfo) at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps) --- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (e:\domains\l\lightboxinteractive.co.uk\user\htdocs\blogtest\web.config line 90) at System.Web.Configuration.WebConfigurationHost.VerifyDefinitionAllowed(String configPath, ConfigurationAllowDefinition allowDefinition, ConfigurationAllowExeDefinition allowExeDefinition, IConfigErrorInfo errorInfo) at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps) --><!-- This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using <customErrors mode="Off"/>. Consider using <customErrors mode="On"/> or <customErrors mode="RemoteOnly"/> in production environments.-->
Sep 22, 2008 at 11:26 AM
The error you are receiving is definately about not being setup as virtual directories. Does your provider give you a control panel of some type where you can create your own virtual directories? If not, I would consider a switch. That is essential in a Windows environment IMHO.
Sep 22, 2008 at 3:36 PM

I think you misunderstood me. You "want" to put the <location inheritInChildApplications="false"> in the top root directory parent's web.config; then let the child applications use the normal web.config.

Sorry about the confusion.

Sep 22, 2008 at 3:44 PM
Taylex is correct; you need to have "virtual directories" set up. However; with virtual directories I still had to add the tag in the root web.config.
Sep 22, 2008 at 7:50 PM
Hey guys,

Thanks for the advice. These Streamline.net hosting people are a bunch of idiots. Here is my latest response:

Thank you for your query

The htdocs directory is the only directory in which customers can put a web.config file for .NET applications. .NET applications created with web.config files in any other directory will not run.

Kind Regards,
StreamlineNet
Streamline.Net - The home of good value web hosting

I would have considered a swtich but have paid for 2 years hosting which is a bit of s shi**er but hey! The only way they suggested was for me to create subdomains and BUY! yes BUY the .NET framework for each setup!!!! Obviously I told them where to go!

So scenario is as follows:
1) Only 1 web.config in the root htdocs folder
2) Each folder can hold .NET apps but have to use root web.config
3) Problem still is each folder with each .NET instance reading web.config

So questions guys is without using the  <location inheritInChildApplications="false"> setup as can't be used here due to this companies setup how should the virtual directories be set on each of the folders. Ideally virtual directories need to be setup on each folder to point ot the root.
Input once again appreciated!!

Thanks
lbi
Sep 22, 2008 at 9:01 PM
Edited Sep 22, 2008 at 9:07 PM
Without being able to set each of your subfolders as an IIS application (virtual directory) I believe you will have no luck. I tried a couple of ways on my test machine with no success. If I delete the web.config in the subfolders it throws no errors but is still only affecting the main blog which is of no use. I believe some serious hacking of the source code would be required to accomplish what you have at your current provider.

If you are dead set on not changing providers and have access to MSSQL you might want to give subtext a shot.
Mar 11, 2011 at 7:21 AM

Hello Everyone

I am facing similar problem.

 <!--l version="1.0-->
<!-- 
    Note: As an alternative to hand editing this file you can use the 
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in 
    machine.config.comments usually located in 
    \Windows\Microsoft.Net\Framework\v2.x\Config 
-->


  
  
		
	
	
		
			
				
				
					
					
					
					
				
			
		
	
	
	
	
		<!-- 
            Set compilation debug="true" to insert debugging 
            symbols into the compiled page. Because this 
            affects performance, set this value to true only 
            during development.
        -->
		
			
				
				
				
				
			
		
		<!--
            The <authentication> section enables configuration 
            of the security authentication mode used by 
            ASP.NET to identify an incoming user. 
        -->
		
		<!--
            The <customErrors> section enables configuration 
            of what to do if/when an unhandled error occurs 
            during the execution of a request. Specifically, 
            it enables developers to configure html error pages 
            to be displayed in place of a error stack trace.

        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
        -->
		
			
				
				
			
		
		
			
			
			
			
		
		
			
		
	
	
		
			
				
				
			
			
				
				
				
			
		
	
	<!-- 
        The system.webServer section is required for running ASP.NET AJAX under Internet
        Information Services 7.0.  It is not necessary for previous version of IIS.
    -->
	
		
		
			
			
		
		
			
			
			
			
			
			
			
		
	
	
		
			
				
				
			
			
				
				
			
		
	

was doing an example code for storing images in a database. And I am getting the same error as above. I got another error that inheritInChildApplications not declared when I added <location inheritInChildApplications="false"> in web.config.

I am new to .Net please help. Much appreciated.

 

Uday

 

Mar 11, 2011 at 1:21 PM

I agree with Taylex

I have 2 blogs in the same place. Both are subdirectories of the root folder and both are set as Virtual directories. They have they own config files which makes sense because they need different connection strings and possible SMTP setting. I would fight your contract hard.