blogengine.net 2.6 style sheet problem in admin area

Topics: Themes
Jul 11, 2012 at 4:29 PM
Edited Jul 11, 2012 at 4:30 PM

CSS or Page Formatting gets vanished in admin (/admin/default.cshtml) section of BE 2.5 and 2.6.Using Standard theme without any changes.. How to fix it ?

Jul 12, 2012 at 7:30 PM

we are also facing the same issue, can anyone please help about this.

@jha_jee have you found any solution???

Coordinator
Jul 12, 2012 at 9:36 PM

Start by making sure you running in app pool with .net 4.0 and integrated mode. Check in the FireBug or alike if you have any client-side errors. Turn off custom errors in web.config to display any server-side errors in the page. Specifying what version of BE and IIS you are running and what is not working (is this only .cshtml admin pages? any admin pages? every single page in the blog?) can give some clues too. But main thing is to get to the error.

Jul 13, 2012 at 6:34 AM
rtur wrote:

Start by making sure you running in app pool with .net 4.0 and integrated mode. Check in the FireBug or alike if you have any client-side errors. Turn off custom errors in web.config to display any server-side errors in the page. Specifying what version of BE and IIS you are running and what is not working (is this only .cshtml admin pages? any admin pages? every single page in the blog?) can give some clues too. But main thing is to get to the error.

Thanks for the reply rtur ,

Checking source throug firebug  ..brought this ..

 

 

Now clicking on the above css file shows an error - no resource.

 

 

What i believe , this seems to be a path problem related to url mapping side effects.This happens only when you are within some folder like /admin and not the root. cshtml is not a problem here as i am executing it locally on VWD 2010 express with .net 4.0.

What do you suggest to fix this path problem..

Coordinator
Jul 13, 2012 at 3:04 PM

This path points to optimized (combined) resource that served by system.web.optimization.dll. I'm guessing you either missing this DLL, which should be copied from lib/optimization when you build VS solution, or for some reason it does not work in your environment. You can use very latest code (under "source code" tab on this page) to turn optimization off if it does not work for some reason. We added this so people running IIS6 or Mono can use BE even though optimization is not supported there. It is an option in admin/settings/advanced.

Jul 13, 2012 at 5:06 PM
Edited Jul 13, 2012 at 5:07 PM
rtur wrote:

This path points to optimized (combined) resource that served by system.web.optimization.dll. I'm guessing you either missing this DLL, which should be copied from lib/optimization when you build VS solution, or for some reason it does not work in your environment. You can use very latest code (under "source code" tab on this page) to turn optimization off if it does not work for some reason. We added this so people running IIS6 or Mono can use BE even though optimization is not supported there. It is an option in admin/settings/advanced.

Great ! ,

It has worked in my case . what i did -

1.downloaded the latest source code of BE from the location pointed.

2.Compiled the VS solution without any error.

3.Copied the BlogEngine.NET folder's contents to my location.

Apart from that i noticed that my problem re-appears when   <enableoptimization>False</enableoptimization> (App_Data/settings.xml) is set to true which means it is not compatible with IIS6 or Mono...I could not locate enableoptimization option in the existing BE 2.5 that your main website is hosting which i previously downloaded..

Thanks again !!