WebForm_InitCallback' is undefined ERROR in admin area

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Jul 13, 2012 at 6:32 PM

Eeverytime I try to view the homepage or admin.aspx I get Jscript error saying "WebForm_InitCallback' is undefined"

I am using web version, just downloaded fresh copy from codeplex.

Jul 13, 2012 at 6:33 PM

Everywhere in admin area I am getting error messages ,

I just clicked on "Users" and I am getting "Microsoft JScript runtime error: 'jQuery' is undefined"

Coordinator
Jul 13, 2012 at 7:14 PM

Try to turn off "compress webresource.axd" in admin/settings/advanced, sometimes it causes this js error to pop up. Then refresh browser cache (ctrl + F5).

Sep 28, 2012 at 6:08 PM

Hi,

I'm getting Line 4: jQuery is undefined error going into admin V2.6.  Any ideas /fix for this?

Oct 27, 2012 at 3:18 PM
rtur wrote:

Try to turn off "compress webresource.axd" in admin/settings/advanced, sometimes it causes this js error to pop up. Then refresh browser cache (ctrl + F5).

I was getting this error on the main page after a brand new first-time install, using Windows 7/IIS7. The error arose whenever I tried to add a comment, and googling got me here. The problem was solved by "rtur"s solution.

Adding comments is a very basic function - and so I was close to dropping blogengine.net entirely as too buggy. So I recommend they fix this for new installs, as others might easily just turn away.

Thanks for your help.

Feb 24, 2013 at 11:49 AM
rtur wrote:
Try to turn off "compress webresource.axd" in admin/settings/advanced, sometimes it causes this js error to pop up. Then refresh browser cache (ctrl + F5).
Hi rtur,

I've got the same problem in 2.6 and 2.7 with windows Web Server 2008 and IIS7.5.

can you please make it clearer. I didnt understand what you meant by "Try to turn off "compress webresource.axd" in admin/settings/advanced".

I changed in admin/settings following files a followed:
advanced.aspx:
            "compressWebResource": $("[id$='_cbCompressWebResource']").is(':unchecked'),
and
advanced.aspx.cs
        cbCompressWebResource.Checked = false;
        cbCompressWebResource.Enabled = false; 
Nothing helps.
It would be very nice when you make it a little bit clearer.

Regards Jürgen
Coordinator
Feb 24, 2013 at 5:05 PM
JAB33699 wrote:
It would be very nice when you make it a little bit clearer.

Regards Jürgen
When you log in as admin, you should see admin menu with links to common functions like "settings". If don't, you can go straight to "/admin/Settings/Advanced.aspx" on your blog to get to advanced settings. There you'll find options to turn on/off compression and optimization - try to find combination that will work with your server.
Feb 27, 2013 at 10:09 AM
Hi rtur,

thanks for reply.
For more understanding please check My Blog.
You can login as admin as you know. Then you see that everything is in textmode.

The problem is that jquery is undefined.

What must I write instead of checked in "/admin/Settings/Advanced.aspx"? I tried "unchecked" but that doesnt work.

Many thnaks for your help.

Regards Jürgen
Feb 27, 2013 at 11:49 AM
Hi,

another crazy thing.
I downloaded the whole source onto my lokal computer and started the solution with Visual Studio.

Run and it works fine also the adminstration site.

What went wrong at the server? Maybe the security setting?

I would appreciate help.

Regards Jürgen
Coordinator
Feb 27, 2013 at 5:08 PM
The optimization is not working on your server, so all bundled JS/CSS throw errors. It is not that visible on blog page because theme stylesheet not bundled, but it happens site-wide. You need to disable optimization in the /app_data/settings.xml file, set it to "False" and it should work.
<enableoptimization>False</enableoptimization>
Feb 27, 2013 at 5:40 PM
Hi rtur,

I'm very sorry.
It doesnt work after changing the settings.

Any other idea?

Regards Jürgen
Coordinator
Feb 27, 2013 at 5:55 PM
I don't see settings changed - it still enabled.
Feb 27, 2013 at 6:16 PM
Hi rtur,

I copy the Install-zip onto the server again.
Made changes to the settings.xml-file and it works.

Many, many thanks for your help.

I dont know what went wrong but I'm sure that I made a mistake.

Regards Jürgen
Apr 18, 2013 at 3:17 PM
I get the same thing. I set
<enableoptimization>False</enableoptimization>

but when I run it, it's still coming back as checked. and get the jquery undefined error.