Adding a comment hangs in 1.4.5?

Oct 2, 2008 at 4:46 PM
I am setting up a new blog and downloaded the 1.4.5 web release, installed it, and everything goes fine until I try to post a comment. When I do that, I just get a "saving the comment..." message and it never completes. Has anyone seen this? I have a 1.3.x version running on the same server which is working fine.

Thanks,
Bill
Oct 3, 2008 at 9:54 AM
I am facing the same problem, have you find the solution.
please let me know when you get the answer, even i face one more problem.
When i m going to edit widgets like twitter, its values in text boxes will not be updated instead they are pertainng last values.

Thanks,
Jitendra Singh
www.newGenLives.com
Oct 3, 2008 at 5:33 PM
What I have done in the past is select the entire site on the server, and uncheck the ReadOnly bit on every file in the site.

My assumption is that when you FTP'd the site to it's destination, or when you unzipped it, the files became read only, thus, when you try to comment it is unable to save the comment.  Comments are saved along with the post by the way.

Uncheck your readonly flag on the files on the server and I think you'll see it works after that.

Cheers!

Wayne
Oct 3, 2008 at 6:43 PM
Wayne,

Thanks for the tip but it didn't help in my case. I'm still experiencing this issue.

Bill
Oct 3, 2008 at 7:26 PM
So I'm wondering if it's because I'm running on IIS7. I looked at the traffic in Fiddler for when I click the save comment button and I see the following error:

The target 'ctl00$cphBody$CommentView1' for the callback could not be found or did not implement ICallbackEventHandler.

I've tried a couple of different standard themes with no luck.
Oct 7, 2008 at 6:26 PM
I finally got this working, I had to change line 62 in blog.js from:

WebForm_DoCallback(
'ctl10$cphBody$CommentView1',argument, callback,'comment',null,false);

to:

 

WebForm_DoCallback(controlId, argument, callback,

'comment',null,false);

 

Oct 22, 2008 at 8:07 PM
Has anyone else been able to get this corrected? I tried making the change to my blog.js file, but I still am not able to post a comment to my blog.
Nov 11, 2008 at 5:01 AM
I am still having this problem with 1.4.5. My install is saving the posts as XML with no database. Anyone able to get this fixed?
Nov 13, 2008 at 8:06 PM
I am on Win2k3 Server w/ IIS6 ... I did the same thing billreiss did and comments now work on my system.

Thank you for posting that!

Shan
Nov 21, 2008 at 1:44 PM
I do the same change of billreiss and this works fine. I got this issue only when I install BlogEngine as a subsite (IIS virtual folder).

My environment is: BlogEngine 1.4.5. IIS 5 and 6 (I've tested it in both), SQL Server 2005.

BillReiss, Did you submit it as patch to BlogEngine ? I think this can help other people if BlogEngine Team incorporated it in the next release.

Bye,

Bruno Caimar
Nov 26, 2008 at 10:05 PM
I have found that it depends where you click to add the comments from.  From the main blog list if you select comment when you goto add a comment #comment is encoded on the url and it is unable to post. If you click the blog first then add a comment it works fine.

Anyone else seeing this issue?  Any ideas?
Dec 1, 2008 at 11:10 AM
Same question.

But when I use the Chrome browser the problem won't occur, anyone has the same case?
Jan 23, 2009 at 7:38 AM
Hello,

For me 1.4.5.0 worked fine but the problem appeared in 1.4.5.13 (changeset 24381) with a javascript error in blog.js :
Erreur : replyToDropDown is not defined
Fichier Source : http://localhost:49406/myblog/js.axd?path=%2fmyblog%2fblog.js&v=1.4.5.13
Ligne : 2

Occurs in any browser.
Server IIS6 on W2K3

Had to downgrade to 1.4.5.0...