Upgrading from 1.2.0.0

Oct 8, 2008 at 9:01 PM
Hello,

It's been a while since I upgraded my blog.  I'm still on 1.2.0.0.  And I still use XML, instead of a database, to store content. Naturally, I would like to upgrade to the latest stable version.  I have a couple of questions:
1. Should I go directly to 1.4.5 or an earlier version?
2. Are there any tips to make the upgrade painless?

Thanks a lot.