This project is read-only.

Problem with URLrewrite

Topics: Business Logic Layer, Controls
Aug 4, 2012 at 5:04 PM

Hello all,

I have a blog running on 2.5

When clicking on a link on my blog, instead of it redirecting to:

it redirects to:

I know that BE seems to have a built in urlrewrite module. There is nothing listed in my extensions listing. How do I find and edit or add a urlrewrite module so that I can fix this problem.


Thank you

Aug 5, 2012 at 1:04 AM

All URL rewrite rules are under "Core/Web/HttpModules/UrlRewrite.cs". It is in the compiled BlogEngine.Core.Dll so you need to open source version in VS to edit and recompile if needed. I doubted though it is something in there you need to change, most likely it is IIS issue. Like virtual directory not setup or sub-domain rerouted by host.

Aug 9, 2012 at 1:58 PM

Thank you,

You were correct, it was a showing the folder name from the host. Can anyone tell me how I can have remove this from the url so that I do not have a canonical issue?



are the same page. How can I redirect one to the other with a 301? WHen I try to add rewrite rules to the web.con, I get a 500 error.



Aug 21, 2012 at 8:12 AM
Edited Aug 21, 2012 at 8:29 AM

First of all thanks for this wonderful blogging engine. My blog is running in BE for more than 3 years and now I transferred my hosting to GoDaddy now..

Seems if you use GoDaddy shared hosting you get this problem.. I too use GoDaddy.

I am giving more details below:

I am using BE 2.6




The solution given in this link does NOT solve the problem..

What should we need to do..

I have also found this thread in the forum which is not resolved, I too have the same issue, can anyone please help..?? and shed more light on this issue ?

Please help

Aug 21, 2012 at 9:06 PM

no ideas ?

Oct 22, 2012 at 10:34 PM

This problem is very annoying and seems nobody know how to fix it. Shouldn't be there an option in BlogEngine Settings that it accommodate also hosting solutions and ignore that extra url before by some optional settings related with hosting providers and their virtual folders or whatever mess it is?

This becomes a pain and our amazing BlogEngine Developers could help with this? Not only there is a problem with BlogEngine in some hosting providers related with BlogEngine url rewriter but also when you want to run multiple separated installation of BlogEngine in hosting provider and when BlogEngine is in the root as a main domain it interference with the child BlogEngines..

Well, if somebody found a solution please give it to us NOW!! :-) ha ha


Oct 23, 2012 at 3:50 AM
Edited Oct 23, 2012 at 3:53 AM

Not to point fingers, but this not exactly BE issue - look at this for example. This solution (also not BE specific) seems to make sense, although I can't confirm it works. Again, not to make an excuse - would be nice to handle big fat godaddy more gracefully, a lot of people use it, like it or not.

Oct 23, 2012 at 1:07 PM

I believe the problem with BE is that you cannot add rewrite rules to web.config as you would any other site, without it causing a 500 error. Maybe I'm wrong. If there is a way to add custom rewrite rules to BE, please let me know.

Oct 27, 2012 at 8:03 PM
Edited Oct 27, 2012 at 8:04 PM

You do can add any rewrite rules like to any new ASP.NET (3.5+?) website  just like rtur above mentioned. Unfortunately I wasn't able to success with the suggestion above coz I had experienced big problem with Domain Mapping with my 123reg Shared Hosting and any support ticket took days to response with a proper asnwer what is going on. So I don't know if the problem was with Domain Mapping or the suggestion above but after 1 month I gave up and upgraded to VPS. So far all good as I can do whatever I want with my IIS 7.5 :-O except it costs so much $$$$$ :-O

So no clear solution for this at the moment :-(

Anyway, thank you for your suupport rtur and Rdollc.