url repeating twice issue in GoDaddy..

Topics: ASP.NET 2.0
Aug 21, 2012 at 6:36 AM
Edited Aug 21, 2012 at 7:29 AM

First of all thanks for this wonderful blogging engine. My blog is running in BE for more than 3 years and now I transferred my hosting to GoDaddy now..

Seems if you use GoDaddy shared hosting you get this problem.. I too use GoDaddy.

I am giving more details below:

I am using BE 2.6




The solution given in this link does NOT solve the problem..

What should we need to do..

I have also found this thread in the forum which is not resolved, I too have the same issue, can anyone please help..?? and shed more light on this issue ?

Please help

Aug 21, 2012 at 8:05 PM

Common any ideas ?

Aug 21, 2012 at 9:44 PM

Upload simple "hello world"-type application just to see if it works with your host. If it also duplicates domain in the path, you can contact GoDaddy to resolve it. There are issues with sub domain on GoDaddy (when you use "") and "deluxe" accounts using URL rewrite tricks that can conflict with rewrites in BE. Obviously one would need to have an account with GoDaddy to troubleshoot this.

Aug 21, 2012 at 10:12 PM

hi rtur

Thanks for your reply, i have uploaded a fresh copy of the BE2.6 at

Few points if it would help:

- My blog is not in subdomain this page displays the following output:(iamashoka.com_fldr <- this is where i keep files, I changed from to this now to avoid confusion)

Utils.AbsoluteWebRoot -
Utils.AbsoluteWebRoot.Host -
Utils.AbsoluteWebRoot.LocalPath - /iamashoka.com_fldr/
Utils.AbsoluteWebRoot.PathAndQuery - /iamashoka.com_fldr/
Utils.AbsoluteWebRoot.AbsolutePath - /iamashoka.com_fldr/

- I am in Unlimited plan of godaddy

- your check :)

If there is no solution I would cancel godaddy and go to winhost or any other host.


Please help


Aug 22, 2012 at 12:27 AM
Edited Aug 22, 2012 at 1:21 AM

Silly question but... you did configured that directory as application, right? Kind of like described here?

You can also try this workaround, looks like exactly your case.

Aug 22, 2012 at 7:14 AM

Yes it is set as application..

Thanks will try that link's solution and get back.. 

Aug 22, 2012 at 5:45 PM

The link you provided solved the problem to some extent.. 

If we click the month on the archive section it shows error (

So I guess leaving godaddy is the best solution ? if so, do you suggest anyother host, I have read your post here on winhost, do you have some more hosting recommendations ? I would need the ability to host multiple domains with decent space&bandwidth.. winhost seems to have less number of ftps than the number of sites I have, even in the ultimate plan..  please provide other hosts if you know..