Install issue /subfolder on site

Topics: ASP.NET 2.0
Nov 8, 2008 at 7:43 PM
I know i cannot be the first with this issue but I cannot find the solution.  I am installing the blogengine in a folder on an established website; I have write permissions to the App_data folder.  iget the following error;

 

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

Line 7:  	</configSections>
Line 8:  	<BlogEngine>
Line 9: <blogProvider defaultProvider="XmlBlogProvider">Line 10: 			<providers>
Line 11: 				<add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>


Any help would be apreciated.
Nov 9, 2008 at 10:02 AM
Daunting as they may sometimes seem, the error message you receive can actually be quite useful. See the part where it says "This error can be caused by a virtual directory not being configured as an application in IIS.
"?

What that means is you must convert your subdirectory (folder where the blog is) into an application starting point (virtual directory). You should be able to accomplish this through your web hosts control panel or through IIS Manager if you are on your own server.

You may then find you have additional errors if your parent application contains a web.config file that has conflicting elements. We'll help you get through those too. :)
Nov 9, 2008 at 2:23 PM
Sorry I should have stated this had already been converted as a   subweb. 
Nov 9, 2008 at 2:44 PM
Success!  I hd to reset permissions for the subweb.