IE 9, BE 2.5, Yoko theme and <![endif]--> (solved)

Dec 18, 2012 at 2:46 PM

How would I get rid of <![endif]--> when using IE 9 with the Yoko theme and BE 2.5 at sahcinfo.org?

This is not a problem with Chrome Safari, Opera, and Firefox.

 

Thank you

Dec 18, 2012 at 4:02 PM
Edited Dec 18, 2012 at 4:03 PM

Why do you want to get rid of it? Are you trying to get rid of the entire piece?

	<!--[if lt IE 9]>
	<script src="/themes/yoko/js/html5.js" type="text/javascript"></script>
	<![endif]-->

If so, just open the site.master file in the theme folder and remove it.

Dec 18, 2012 at 4:11 PM
Edited Dec 18, 2012 at 4:20 PM

If you go to sahcinfo.org with IE 9 and view the page it is showing up in the header and looks like crap, it does not show up in other browsers.

If I remove it the whole header breaks.

Dec 18, 2012 at 4:37 PM
Edited Dec 18, 2012 at 4:40 PM

I had a similar problem when I built a theme that I needed the conditional IE browser statement. The work around that I found was to go into the Admin panel and unchecked the "Enable Optimization" in the Advanced Settings window. Try that and see how it goes.

Dec 18, 2012 at 4:48 PM

Thanks, I just tried that and it didn't seem to help.

Dec 18, 2012 at 7:29 PM

I can't seem to duplicate the issue when using the stock Yoko theme. Have you modified it?

Dec 18, 2012 at 8:06 PM
Edited Dec 18, 2012 at 8:24 PM

Changed the header image, I'll try it with the original image and se what happens.  I tried the original image and it still exists, I thought maybe the size of the image may have something to do with it.  I found the problem, when I changed the menu in the site master I left <![endif]--> in the wrong place.  Thanks for your help.

Dec 19, 2012 at 2:35 PM
jerrysdean43 wrote:

I found the problem, when I changed the menu in the site master I left <![endif]--> in the wrong place.  Thanks for your help.

I'm glad you found the problem.