Issue: Contact Page

Dec 11, 2008 at 2:56 AM
Hello,

I have the 1.4.5 version of BlogEngine.net and am having a problem with the contact page. When I send a test email via the settings page it works fine, but when I send via the contact page I get the "emailwas sent" confirmation, but no email shows up in my inbox. About the only thing I can think of is that my smtp server requires authentication, but then that would also affect the test email going through.

What is the fix for this?

Thanks!
Coordinator
Dec 11, 2008 at 4:18 AM
Do you have "Enable Attachments" disabled for your Contact form?  If so, then you're probably running up against this issue which was fixed in version 1.4.5.12.
Dec 11, 2008 at 5:40 AM

Hi Ben,

No, attachments are enabled. I am uploading the 1.4.5.12 right now to see if that fixes the problem. I'll let you know if that does the trick.

From: BenAmada [mailto:notifications@codeplex.com]
Sent: Wednesday, December 10, 2008 10:18 PM
To: jeff@jeffgramins.com
Subject: Re: Issue: Contact Page [blogengine:42015]

From: BenAmada

Do you have "Enable Attachments" disabled for your Contact form? If so, then you're probably running up against this issue which was fixed in version 1.4.5.12.

Read the full discussion online.

To add a post to this discussion, reply to this email (blogengine@discussions.codeplex.com)

To start a new discussion for this project, email blogengine@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Dec 11, 2008 at 6:03 AM

Nope -

Uploaded 1.4.5.12 an even tried it with attachments disabled on each of my mail servers suggested ports (25 and 2525). The test email comes through just fine, but the mail sent from the contact page never arrives.

From: BenAmada [mailto:notifications@codeplex.com]
Sent: Wednesday, December 10, 2008 10:18 PM
To: jeff@jeffgramins.com
Subject: Re: Issue: Contact Page [blogengine:42015]

From: BenAmada

Do you have "Enable Attachments" disabled for your Contact form? If so, then you're probably running up against this issue which was fixed in version 1.4.5.12.

Read the full discussion online.

To add a post to this discussion, reply to this email (blogengine@discussions.codeplex.com)

To start a new discussion for this project, email blogengine@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Dec 14, 2008 at 4:21 PM
Hmmm - I didn't even realize I had this problem till I saw this post and tested it. Sure enough, if I test it using my own email address, it works fine - but I never get it if anyone else sends me a message through the contact page.  Also, doesn't seem to matter if attachments are enabled or not.

Looks like this is still an issue.


David Workman
www.HalfBakedLunatic.com
Coordinator
Dec 14, 2008 at 7:07 PM
I can't reproduce this problem, but I was comparing the code for sending a test email vs. sending an email on the contact page.  One noticeable difference that looks like it could be causing the problem is on the contact page, the "Sender" email header is set.  This is set to the email address of the person leaving feedback.  I could see where a mail server may not like this since it may be required that the Sender account is a valid account on your mail server.  In the contact.aspx.cs file, in the SendEmail function, try removing or commenting out this line.

// mail.Sender = mail.ReplyTo;

The two forward slashes will comment out the line so it is ignored.  This shouldn't cause any problems since the From header and ReplyTo headers are already being set.
Dec 17, 2008 at 4:36 PM
I was having the same problem.  I had to comment out the following lines:

                mail.ReplyTo = new MailAddress(BlogSettings.Instance.Email, name);
                mail.Sender = mail.ReplyTo;

Coordinator
Dec 17, 2008 at 4:52 PM
jmaddrey - that's good information.  I would think the ReplyTo header could remain safely.  But every mail server has its own little restrictions on what is and isn't permitted.
Dec 17, 2008 at 10:02 PM
Yeah!  Commenting out both these lines fixed the issue for me too!  Thanks!


DW
Dec 24, 2008 at 1:08 AM
Edited Dec 24, 2008 at 1:19 AM
Hope this helps somebody.
http://www.dotnetblogger.com/post/2008/12/23/Quick-Fix-for-the-BlogEngineNet-Contact-page.aspx