This project is read-only.

The tags from a blog entry vs the tags from the Tag Cloud

Dec 14, 2008 at 9:01 PM
Edited Dec 14, 2008 at 9:02 PM
For example if we look at Mads blog, this blog entry, has the tag "geek dinner". A mouse move over it, and we can see that the link is "....tag=/geek+dinner". However, if we move the mouse over the "same" tag from the tag cloud, the link will be "....tag=/geek-dinner".
If we click the tag from the blog entry, we get no results(not nice). If we click the tag from the tag cloud, we will see the posts tagged with " geek dinner"(very nice).

This is a little confusing, is this the expected behavior(that's a bit weird), or just a bug ?

Dec 15, 2008 at 11:45 AM
I believe this is a bug as I experience this in all my source code builds as well.
Dec 15, 2008 at 11:59 AM
Here is an interesting observation.
I have also manually been adding the "newsletter" widget.ascx file into source to make it available. It got me started thinking that maybe I am not using source correctly.
I just downloaded 1.4.5 release and source. I overwrote the web files from release with source then moved the overwritten files back to source. Compiled and not the "tags" are working and of course my newsletter widget does too.
Dec 15, 2008 at 12:09 PM
Edited Dec 15, 2008 at 1:51 PM
Another observation. My Visitor Info never worked either, usually just gave me a javascript error. Now it actually asked me if I wanted to filter my blog based on another blog I have. That shocked me because I never realized what the VI widget actually did.

Edit: works locally but not hosted.
Dec 15, 2008 at 8:57 PM
Thanks T.
I remember that the tags used to work sometime ago, but I was not sure.
I've never tried the newsletter or the visitor info widgets.

Jan 4, 2009 at 2:41 PM
Looks like the bug filled by Ben was fixed.
Using source code 23913 and the tags issue is gone.