Problem with multiple blogs

Topics: ASP.NET 2.0
Dec 27, 2012 at 7:03 AM


I have created a primary blog and then a second blog using the admin options. The second blog is the "same" blog in a different language. It works fine on my PC (VIsual Studio 2010) but when I deploy to the web, ISS 7 hosted in discountasp, only the primary blog works properly.

When I try to achieve the second blog, I receive the following error:

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

But for instance, if I try to open a non existant page, the error is like this:

HTTP Error 404.0 - Not Found

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

<fieldset><legend>Detailed Error Information</legend>
Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002

showing that the customerror works OK.

I understand that the webconfig options are not properly taken when I try to access to the second blog.

Could you give me some advice on this issue?.


Best regards


Dec 27, 2012 at 9:24 AM


If I disable the "Enable optimization" in advanced settings, it works properly.




Dec 28, 2012 at 5:18 PM
Edited Dec 28, 2012 at 5:40 PM

Carlosco, I have the same error you have -- when I initially set up my blog.  The default.aspx main page comes up, and I can navigate to some pages.  But when I try to click the "log in" link, I get the same error as you.  My shared hosting provider says that all directories have permissions set to "write" by default, so I don't know if it's still my app_data folder or what.

Where did you find the "advanced settings" so you can disable the "enable optimization"?

Dec 28, 2012 at 6:20 PM

I think the problem stemmed from having an IIS7 rewrite rule set up to remove the "aspx" extensions.  Once I got rid of this rewrite rule, it still didn't work.  I cleared my browser's cache, and things work now.  So I guess it was just that rewrite rule.