This project is read-only.

I can login to my blog, I can create categories, etc., but I cannot create new users, posts

Topics: Business Logic Layer, Controls
Dec 28, 2012 at 8:28 PM

I have a fresh installation of blogengine.  I'm not a professional programmer, but I've followed the documentation precisely.

I'm with a shared hosting company.  My website is hosted on a Windows 2012 server w/ IIS8.  But I'm using IIS7 Manager.

They claim:  "Your IIS and aspnet users are granted full set of permissions on your site root and all subsequent directories by default. Your and your web applications should be able to write to any directory. The permissions of those users cannot be altered, and that's why they are not listed in permissions manager. Permission manager is for additional users that you create in User/Quota Manager only."

I can:

I can go to the blog's home page and login using the default admin login.  I can go to my dashboard and edit categories, create new categories, etc. ... When I attempt to create a new post, I can insert images.

I cannot:

But I cannot write new posts, or create new users.  When I try to create a new post, for instance, clicking the "Save post" button just doesn't do anything; the page remains stagnant.  Likewise, when I go to the users section in the admin, I can fill out the "create new user" form, but when I click "Save", it doesn't actually create a new user, and it goes back to the users page.

Does anybody have any suggestions as to what I might be doing incorrectly?  Any guidance would be greatly appreciated!

Dec 29, 2012 at 8:22 AM

My hosting provider says:

I double checked your permissions on your folders and they are not misconfigured.

It would be best for you to ask the creators of Blog Engine to see how you can trouble shoot this problem with them. Tell them that the hosting provider has already checked your permissions and they have not been misconfigured. A web site user has full read and write access to the site.

I also went ahead and tried to see if I can recreate the problem and notice nothing has happening after I tried to create a user or post. So, I tried to use Google Chrome Developer tools to see if I can get any kind of http error message and didn't receive any problems. No error messages are being produced in Google Chrome Developer Tools. I also tried using Fiddler to see if any error messages were coming up and didn't notice any errors.

When this happen I went back on to the web server and check for the http error logs and your site isn't producing any http error messages too. Please check with Blog Engine to see what could be the problem.

Not sure what to do now!

Dec 29, 2012 at 6:15 PM

First, check the permissions for your user role (admin/users/roles -> select permissions in the tools menu). Make sure it has permissions to create posts and users.

If this doesn't help, use FireBug or F12 in IE to check for JavaScript errors. Sometimes during FTP deployment files got missing and you might have JS file not found error - save button calls JS function which calls back-end via Ajax.

Dec 31, 2012 at 2:41 AM

Hi, thanks Rtur for taking the time to respond.


I just changed the name of my web.config in my root to web.config1.  Then I copied the /blog/web.config and put that in my root, as my root web.config .... and everything works perfectly.  It was an inheritance issue of some sort.


Thanks again!